Excel Summe

%3CLINGO-SUB%20id%3D%22lingo-sub-2719490%22%20slang%3D%22de-DE%22%3EExcel%20Sum%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2719490%22%20slang%3D%22de-DE%22%3E%3CP%3EHello%20everyone%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20want%20to%20form%20a%20sum%20with%20sum()%20and%20dynamically%20assign%20the%20number%20of%20cells%20to%20be%20summed%20below%20it%2C%20e.B.%20sum%20up%20the%20values%20of%20the%20next%203%20cells%20below.%20The%20number%203%20should%20be%20taken%20from%20a%20cell%20(and%20not%20be%20given%20absolutely).%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20anyone%20know%20how%20to%20do%20it%3F%20Thank%20you%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2719490%22%20slang%3D%22de-DE%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EFormulas%20and%20Functions%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2719508%22%20slang%3D%22en-US%22%3ERe%3A%20Excel%20Summe%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2719508%22%20slang%3D%22en-US%22%3E%3DSUM(OFFSET(%24B%242%2C%2C%2CCOUNTA(%24B%3A%24B)-1%2C1))%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2719509%22%20slang%3D%22en-US%22%3ERe%3A%20Excel%20Summe%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2719509%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1146473%22%20target%3D%22_blank%22%3E%40gwmuc%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-applescript%22%3E%3CCODE%3E%3DSUMME(FILTER(A1%3AA100%3BZEILE(A1%3AA100)%26lt%3B%3DC1))%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2738920%22%20slang%3D%22de-DE%22%3ESubject%3A%20Excel%20Sum%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2738920%22%20slang%3D%22de-DE%22%3E%3CP%3Egreat%2C%20thanks%20a%20lot%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hallo Zusammen,

 

ich möchte mit summe() eine Summe bilden und dabei die Anzahl der zu summierenden Zellen darunter jeweils dynamisch vergeben, also z.B. summiere die Werte der nächsten 3 darunter stehenden Zellen auf. Die Zahl 3 soll dabei aus einer Zelle entnommen werden (und nicht absolut vorgegeben werden). 

Weiß jemand wie es geht? Danke

3 Replies

 

=SUM(OFFSET($B$2,,,COUNTA($B:$B)-1,1))

 

=SUMME(BEREICH.VERSCHIEBEN($B$2;;;ANZAHL2($B:$B)-1;1))

=SUMME(BEREICH.VERSCHIEBEN($B$2;;;ANZAHL2($B:$B)-1;1))

@gwmuc 

=SUMME(FILTER(A1:A100;ZEILE(A1:A100)<=C1))

 

great, thanks a lot