Excel Solver Add-In

New Contributor

Hi all,

I am trying to get the Solver Add-In to work. I activated it without a problem following the recommended steps, but once I try to use it, I get an error message saying the macro 'SOLVER.XLAM!GetGroupLabel' could not be run and that macros might be disabled in the document. I checked and made sure that I allow all macros in the document, but that did not solve it. Additionally, I get the following error message saying there is a compile error:



(If I click on "help" a very generic, not helpful help page comes up so sadly that didn't get me anywhere either...)

I would very much appreciate any help with this problem! And I am happy to provide more information if needed!

Thank you so much!



4 Replies


Welcome to the forum.

Please read this Maybe it can help you.

@Juliano-Petrukio Hi, thank you for taking the time to read through my question! I tried almost everything mentioned in that post and have not had any luck so far. I will try to uninstall Excel next and hope that will work.

Hi again! I have tried every tip in the thread you suggested including uninstalling and reinstalling Microsoft Office and I still get the same error messages
If you can think of any other tip (or possibly a way to get through to Microsoft), I would be very, very grateful!!
The issue I think can be caused by 32bit vs 64bit incompatibility. Did you notice that when uninstalling MS office another office app came with the installation called "WPS Office"? If it is there you can uninstall it.