Excel online - Issue with easy filtering

New Contributor

Hello,

I hope I may be able to get some assistance here.

I have a simple sheet (Excel online), about 4,000 rows. Flat data, no formulas, no table, easy content (just descriptions, names, dates and so). For some reason it looks like it's not possible to filter. The error returned is very much uncommon and I can't find anything on Google about that.

 

Uchenzei_0-1639421221364.png

 

"The content in this view can't be displayed , as it contains more data than currently supported."

 

To better explain, I recorded the screen when filtering the sheet (just few seconds to watch): https://tinyurl.com/2wms89d6

 

As you can see, when I try to filter, the sheet becomes unusable. If I restore the previous version and try again, I get same issue every time.

 

Of course this is perfectly working on Desktop.

 

I don't really think it's a problem with the amount of rows as 4k rows is not so much. By the way, this filtering action should leave just 20 rows or so.

 

Any help would be very much appreciated, thanks in advance.

7 Replies

@Uchenzei 

Did you apply filter to entire columns or to some range?

Hi Sergei,
thanks for replying.
I tried both actually (and even more, probably):

- filter applied to entire columns
- filter applied to the range only
- filter applied not selecting anything first, just one cell into the row 1

Always the same result...

@Uchenzei 

Thank you for the details. I also see such alert first time, tried to reproduce but can't. The only some issues if select entire columns, but bit different ones.

I am running even more tests. It actually looks like Excel online has a limit in terms of data which can be display, which sounds crazy indeed. I have tried deleting random blocks of columns and/or rows and it looks like the filter is not able to work anymore when over a certain amount of data is in the sheet!

This is driving me crazy, how could such a low amount of data reach any limit, if still a limit exists?

I would really love to know more about that. Not to mention I need this simply sheet to work

@Uchenzei 

Afraid that's something else. I tested on 100 000 rows x 75 columns sheet, it works.

@Sergei Baklan 

yes it definitely looks like a bug for Excel on line. Where may I submit this request to Microsoft? Is there a way to open a ticket to them?

Thanks

@Uchenzei 

That's only Help->Feedback