excel crashes changing font color

Copper Contributor

hi all,

here is a good one.

in excel (via microsoft365) I can open a speadsheet and enter data into a cell.

I can't change anything with the font, color etc from the ribbon or the right click menu. It works with keyboard short cuts.

Excel just hangs until I am forced to crash.

I have tried with an existing spreadsheet on a different PC and it works fine.

I have tried with a new blank spreadsheet with entry only in one cell, same.


repaired MS 365, fast and slow, uninstalled and reinstalled to no avail.


I am at a loss, any clues or directions?






9 Replies


One possible solution to this issue is to start Excel in safe mode.

This can help determine if the problem is caused by an add-in or other setting.

To start Excel in safe mode, press the control key immediately after clicking the Excel icon. 

It should pop up a confirmation dialog to ask whether you want to start in safe mode.

If Excel starts in safe mode, you can check if you have any custom add-ins installed in Excel by clicking File -> Options -> Add-Ins.

At the bottom of the dialog box, change the Manage dropdown to COM add-ins, and select Go. 

Clear the checkbox for any enabled COM add-ins and select OK .

If this doesn’t help, you might want to try updating or repairing your Microsoft 365 installation.



Hope I was able to help you with this info.



I know I don't know anything (Socrates)

hi, @NikolinoDE
thanks for the answer,
been down that rabbit hole to no avail.
Even removed office and reinstalled but still same.
it appears to be anything to do with the "font" toolbar!

Does it only happen in Excel? Have you tried other applications? One can only guess how the problem arises. On the one hand it can be a "buck" in Office.
Have you updated it to the latest?

Another focus can be the graphics card or the antivirus software, strange as it sounds. Uninstall and install your graphics drivers. Update to the latest.
Disable your antivirus software and try again.

Have you recently installed any new software? or any new hardware?

Information about the Excel version, operating system, storage medium, etc. would be an advantage.
hi @NikolinoDE, further update
only in excel. works fine in word, outlook, powerpoint, onenote. These even change text instantly when you hover on the chosen, font, color, style.
Excel allows the drop menu but then crashes.
yes, bug somewhere, or registry setting ****** up.

no new software (except MS) no hew hardware.

it is an Acer Aspire 64 -bit all in one running Windows 11 Home 22H2, (build 22621.1485) and office both updated from Microsoft 365.
Excel works fine on a surface tablet with the same account, I can use excel online which works fine (but slow internet)

MS defender for AV, upto date.
no conflicts in hardware, I will look at the graphics drivers once I get the replacement.

as said, uninstalling and reinstalling office didn't do anything, I am almost at reinstalling windows just looking if I have missed anything

I'm at my wit's end, unfortunately I can't help with any suggestions for a solution.
If I find something newer I'll update you.
Maybe it's a buck, as already said, and will be solved with the new updates in April, or another user has a suggested solution that will help.
Until then...thank you for your patience and understanding

@NikolinoDE yeah, me too. Defies logic.

Thanks for trying 

@galowglass Hey there, not sure if your issue has been solved, but I was having a similar issue and found this thread. I wanted to leave my solution in case it could help someone else.


I couldn't change the font color on Excel. Word worked fine, fill color worked fine, just the font color.


Issue was solved when I changed the default printer. At the time of the issue, the default printer was offline. No idea if this is related, but could be a relevant bit of information. I changed it to "Print to PDF".

Have also just had this reported for 1 user on a shared PC. The problem is only present for that user and not others who have an existing or new profile for that same PC. Did the usual first steps - repair, uninstall/install etc.

Will check default printer suggestion from @match17 - we did update our print server recently so it could be a possible cause.
Just ran into this problem. Windows updated last night & now today when I change font in Excel (only excel...word, etc are fine) it locks up. Beyond frustration!

After reading the above about changing default printer, I decided to give it a try. But, all of my printers had disappeared! Decided to run services.msc & reset the print spooler. This entirely fixed the problem. Printers are back & excel is working!