Excel ALT+ shortcuts replacing with incorrect symbols

Copper Contributor

This post is a continuation and deviation from: https://techcommunity.microsoft.com/t5/excel/excel-alt-shortcut-keys-problem/m-p/2171038


It is driving me crazy. I copy/pasted a bunch of data from a USGS website, and was having issues getting the data to be recognized as numbers. Alas, a 10 y.o. post:

 https://answers.microsoft.com/en-us/msoffice/forum/all/excel-not-recognizing-numbers-in-cells/d4ee1a... gave me the answer. "ASCII 32 spaces, but rather are ASCII 160 non-breaking spaces." For ONE USE. One worksheet of data at end of day yesterday. Typing ALT+1620 into find/replace removes an odd space size and allows excel to recognize this text as a number. Worked on my first chunk of data yesterday.


Came back today, to apply the same fix to the rest of the data (broken up in a workbook in two month worksheet tabs), and instead of a space entering the "find" dialogue box when I type in ALT+1620, I get the letter "T". Tried typing it in as ALT16+ALT20, different combos, etc, and got a bunch of symbols, etc. 


ALT+1620 worked yesterday, now "T" and various symbols are replacing ALT+ functions in the find/replace box. 


I opened Excel in safe mode via win+R, excel /safe, and did a quick repair of Office 365, and restored all ribbons to default settings, and am still getting an output of "T" in find/replaces "find" dialogue box when typing ALT+1620. Different ALT+ combinations give me symbols, wingdings, etc.


Why would it work yesterday, put computer to sleep, and today I get this? Any help would be greatly appreciated, as my boss is breathing down my neck to produce this work! 


1 Reply
For me the non-breaking space character is generated by typing Alt+0160 (using the num keys!)