Excel ALS function

%3CLINGO-SUB%20id%3D%22lingo-sub-1532572%22%20slang%3D%22en-US%22%3EExcel%20ALS%20function%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1532572%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20tried%20to%20made%20a%20formula%20with%20ALS%20and%20i%20need%20to%20add%20more%20funtion%20arguments%20but%20it%20gives%20an%20error%20and%20i%20dont%20know%20why.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3DALS(AC7%3D0%3B45%25%3B%20ALS(AC7%3D1%3B51%25%3B%20ALS(AC7%3D2%3B56%25%3B%20ALS(AC7%3D3%3B62%25))))%20this%20is%20the%20formule%20for%20now%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ei%20need%20the%20following%204%3D67%25%2C%205%3D73%25%2C%206%3D78%25%20and%207%3D85%25%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ekind%20regards%2C%3C%2FP%3E%3CP%3Ejeffry%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1532572%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1532853%22%20slang%3D%22en-US%22%3ERe%3A%20Excel%20ALS%20function%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1532853%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F733565%22%20target%3D%22_blank%22%3E%40jeffry_de_Graaf%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ELike%20this%3A%3C%2FP%3E%0A%3CP%3E%3DALS(AC7%3D0%3B%2045%25%3B%20ALS(AC7%3D1%3B%2051%25%3B%20ALS(AC7%3D2%3B%2056%25%3B%20ALS(AC7%3D3%3B%2062%25%3B%20ALS(AC7%3D4%3B%2067%25%3B%20ALS(AC7%3D5%3B%2073%25%3B%20ALS(AC7%3D6%3B%2078%25%3B%20ALS(AC7%3D7%3B%2085%25))))))))%3C%2FP%3E%0A%3CP%3EAlternatively%3A%3C%2FP%3E%0A%3CP%3E%3DZOEKEN(AC7%3B%20%7B0%3B%201%3B%202%3B%203%3B%204%3B%205%3B%206%3B%207%7D%3B%20%7B0%2C45%3B%200%2C51%3B%200%2C56%3B%200%2C62%3B%200%2C67%3B%200%2C73%3B%200%2C78%3B%200%2C85%7D)%3C%2FP%3E%0A%3CP%3EOr%3A%3C%2FP%3E%0A%3CP%3E%3DSCHAKELEN(AC7%3D0%3B%2045%25%3B%20AC7%3D1%3B%2051%25%3B%20AC7%3D2%3B%2056%25%3B%20AC7%3D3%3B%2062%25%3B%20AC7%3D4%3B%2067%25%3B%20AC7%3D5%3B%2073%25%3B%20AC7%3D6%3B%2078%25%3B%20AC7%3D7%3B%2085%25)%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1532901%22%20slang%3D%22en-US%22%3ERe%3A%20Excel%20ALS%20function%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1532901%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F127945%22%20target%3D%22_blank%22%3E%40Hans%20Vogelaar%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eis%20there%20any%20possibility%20that%20the%20formule%20can%20be%20in%20the%20exact%20cell%3F%20I%20dont%20think%20so%20but%20I%20thought%20it%20was%20worth%20to%20shoot%20the%20shot%20anyways.%20for%20example%20if%20I%20put%20in%20the%20number%20in%20AC7%20that%20the%20result%20will%20be%20also%20be%20shown%20in%20AC7.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1533091%22%20slang%3D%22en-US%22%3ERe%3A%20Excel%20ALS%20function%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1533091%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F733565%22%20target%3D%22_blank%22%3E%40jeffry_de_Graaf%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ENope%2C%20formula%20can't%20take%20the%20cell%20value%2C%20perform%20some%20calculations%20and%20return%20result%20into%20the%20same%20cell.%20With%20very%20few%20and%20very%20specific%20exceptions%20result%20shall%20be%20returned%20to%20another%20cell.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hi all,

 

I tried to made a formula with ALS and i need to add more funtion arguments but it gives an error and i dont know why. 

 

=ALS(AC7=0;45%; ALS(AC7=1;51%; ALS(AC7=2;56%; ALS(AC7=3;62%)))) this is the formule for now

 

i need the following 4=67%, 5=73%, 6=78% and 7=85%

 

kind regards,

jeffry

3 Replies

@jeffry_de_Graaf 

Like this:

=ALS(AC7=0; 45%; ALS(AC7=1; 51%; ALS(AC7=2; 56%; ALS(AC7=3; 62%; ALS(AC7=4; 67%; ALS(AC7=5; 73%; ALS(AC7=6; 78%; ALS(AC7=7; 85%))))))))

Alternatively:

=ZOEKEN(AC7; {0; 1; 2; 3; 4; 5; 6; 7}; {0,45; 0,51; 0,56; 0,62; 0,67; 0,73; 0,78; 0,85})

Or:

=SCHAKELEN(AC7=0; 45%; AC7=1; 51%; AC7=2; 56%; AC7=3; 62%; AC7=4; 67%; AC7=5; 73%; AC7=6; 78%; AC7=7; 85%)

 

@Hans Vogelaar 

is there any possibility that the formule can be in the exact cell? I dont think so but I thought it was worth to shoot the shot anyways. for example if I put in the number in AC7 that the result will be also be shown in AC7.

@jeffry_de_Graaf 

Nope, formula can't take the cell value, perform some calculations and return result into the same cell. With very few and very specific exceptions result shall be returned to another cell.