SOLVED

Error en Matriz

New Contributor

Hola, estoy realizando un formato para control de horas, vacaciones, bajas, horas acumuladas, horas extra, por meses y total por año.

Casi lo tengo resuelto, pero el problema está en una fórmula que debe sumar solo los valores en las celdas del mes en curso que sean "Festivos", para ello, busca en la tabla "Festivos", los días de vacaciones del año.

La fórmula funciona excepto si por el camino encuentra alguna celda con "V" de vacaciones, o "B" de baja por enfermedad.

Como es una formula matricial, si hay un valor que corresponde con la tabla de vacaciones pone "1" y si no hay valor pone "0", lógicamente, cuando encuentra algún texto, sale error #¡VALOR!

La cabeza me va a estallar, solo soy un aficionado con mucho entusiasmo.

Si alguien me puede ayudar adjunto imágenes, no veo cómo adjuntar el fichero.

La formula en cuestión, que está en la columna AT, es:

=SI(Y(Festivos!$B$3:$B$33="");"";SUMA((Festivos!$B$3:$B$33=$J$10:$AN$10)*1*$J13:$AN13))

 

Saludos

Francesc

Francesc_Sinotec_65_0-1657732267190.png

Francesc_Sinotec_65_1-1657732303440.png

2 Replies
best response confirmed by Francesc_Sinotec_65 (New Contributor)
Solution

@Francesc_Sinotec_65 

 

=SUMPRODUCT(--ISNUMBER(MATCH($J$10:$AN$10,Festivos!$B$3:$B$33,0)),$J13:$AN13)

 

=SUMAPRODUCTO(--ESNUMERO(COINCIDIR($J$10:$AN$10;Festivos!$B$3:$B$33;0));$J13:$AN13)

@Hans Vogelaar 

 

Hola Hans, encantado de saludarte

Que sorpresa encontrar esta mañana tu correo con la solución, es increíble, cortar y copiar y ha funcionado a la primera.

Gracias y mil gracias!!!, realmente empezaba a desesperar y ya no sabía que hacer.

Ahora que ya estoy de nuevo animado voy a seguir hasta comprender tu solución y más allá...

 

Un abrazo Francesc