SOLVED

Error at inserting activeX button

%3CLINGO-SUB%20id%3D%22lingo-sub-3320975%22%20slang%3D%22en-US%22%3EError%20at%20inserting%20activeX%20button%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3320975%22%20slang%3D%22en-US%22%3E%3CP%3EI%20want%20to%20insert%20an%20ActiveX%20button%20but%20get%20this%20error%20message%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Susan49_0-1651737159129.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F369391i10DA81D9FB1EA7A4%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22Susan49_0-1651737159129.png%22%20alt%3D%22Susan49_0-1651737159129.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EIt%20translates%20to%20'can%20not%20insert%20the%20object'.%20I%20have%20searched%20a%20lot%20but%20can%20not%20find%20a%20solution.%20I%20use%20excel%20365%20(version%202108%20click-and-run).%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-3320975%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3321721%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20at%20inserting%20activeX%20button%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3321721%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1381653%22%20target%3D%22_blank%22%3E%40Susan49%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Emaybe%20some%20security%20settings%20are%20blocking%20this.%20You%20could%20check%20this%20setting%20in%20the%20Trust%20Center%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Martin_Weiss_0-1651743100884.png%22%20style%3D%22width%3A%20486px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F369417iEF99E9099B902914%2Fimage-dimensions%2F486x244%3Fv%3Dv2%22%20width%3D%22486%22%20height%3D%22244%22%20role%3D%22button%22%20title%3D%22Martin_Weiss_0-1651743100884.png%22%20alt%3D%22Martin_Weiss_0-1651743100884.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Martin_Weiss_1-1651743137676.png%22%20style%3D%22width%3A%20477px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F369418iB70330C4E7ED0A55%2Fimage-dimensions%2F477x227%3Fv%3Dv2%22%20width%3D%22477%22%20height%3D%22227%22%20role%3D%22button%22%20title%3D%22Martin_Weiss_1-1651743137676.png%22%20alt%3D%22Martin_Weiss_1-1651743137676.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20the%20first%20%22Disable%20all%20controls%22-option%20is%20checked%2C%20just%20try%20the%20other%20ones.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3321894%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20at%20inserting%20activeX%20button%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3321894%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F48469%22%20target%3D%22_blank%22%3E%40Martin_Weiss%3C%2FA%3E%26nbsp%3BThank%20you%20for%20your%20reply.%20This%20box%20is%20indeed%20checked%2C%20but%20I%20am%20not%20allowed%20to%20change%20this%20setting%20(everything%20is%20greyed%20out)%2C%20probably%20is%20this%20controlled%20by%20my%20IT%20department.%20I%20have%20to%20check.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

I want to insert an ActiveX button but get this error message:

Susan49_0-1651737159129.png

It translates to 'can not insert the object'. I have searched a lot but can not find a solution. I use excel 365 (version 2108 click-and-run).

2 Replies
best response confirmed by Susan49 (New Contributor)
Solution

Hi @Susan49 

 

maybe some security settings are blocking this. You could check this setting in the Trust Center:

Martin_Weiss_0-1651743100884.png

Martin_Weiss_1-1651743137676.png

 

If the first "Disable all controls"-option is checked, just try the other ones.

 

@Martin_Weiss Thank you for your reply. This box is indeed checked, but I am not allowed to change this setting (everything is greyed out), probably is this controlled by my IT department. I have to check.