Datenprüfung mit Benutzerdefinierter Formel

Highlighted
New Contributor

Hallo zusammen,

 

ich möchte gerne folgende benutzter definierte Formel anwenden:

 

WENN(und(H36=16%;DATWERT(B16)>DATWERT("30.06.2020");DATWERT(B16)<DATWERT("01.01.2021");WAHR;FALSCH))

 

In B 16 steht ein Datum mit dem Format tt.mm.jjjj

 

Wenn ich dann in B16 das Datum 01.02.2020 eingebe kommt eine Fehlermeldung soweit korrekt aus meiner Sicht.

 

Wenn ich dann aber in B16 das Datum 01.09.2020 eingebe kommt auch eine Fehlermeldung was ja aus meiner Sicht falsch ist.

 

Kann mir hier jemand sagen was an der Formel falsch ist?


Danke vorab.

 

VG


Alexander

 

2 Replies
Highlighted

@alsc201175 Try this:

=WENN(UND(H36=16%;DATWERT(B16)>DATWERT("30/06/2020");DATWERT(B16)<DATWERT("01/01/2021"));WAHR;FALSCH)

 I added a ")" before ";WAHR" and removed the one at the end. And, I replaced the decimal points in the date values to a "/". I also needed to do this in cell B16, but perhaps German Excel allows the decimal points.

Highlighted

@Riny_van_Eekelen 

Thanks, but the problem ist the same.
I have found another solution for my problem.

 

Thanks anyway