SOLVED

Data Regression Analysis Using ToolPack

Occasional Contributor

Hello,

I keep trying to run data regression, but the ToolPack produces incorrect results. This also occurs when I use Analytic Solver. When I send others the file, they are able to run it without any issue, so it is something on my end. I've tried redownloading Excel, using a different version, and contacting support and no one has answers. I know I am running it correctly because when I try on another computer, I am able to. The data is also not corrupted because I have retyped it. Does anyone know why this is happening? I do use a Mac but other Mac users have not had this issue. If I need to reinstall ToolPack, how would I do so?

6 Replies
Can you provide us with an example workbook and indicate what results you think are wrong please?

Screen Shot 2022-04-21 at 9.17.11 AM.pngsee highlighted on RESIDUAL OUTCOME and equation next to linesee highlighted on RESIDUAL OUTCOME and equation next to line

If you were to run the same test, you would get different answers. The equation to the line should be something similar to y=16.6351+5.7098x
best response confirmed by tewksbam (Occasional Contributor)
Solution
If you uncheck that "Labels" box, you should get the exact same results as I do. With that box checked, you are excluding the first data point (14, 95).
OH MY GOSH THAT WORKED!!! Do you know why that is? On other computers it doesn't seem to matter whether the box is checked or not.
If you check that box, the first row of the data you selected in the boxes above is ignored. So if you select B2:B9 and check the box the regression tool ignores cell B2, but that is OK since it is the label. On the other hand, if you select B3:B9, checking the box makes the tool use cells B4:B9 to calculate the regression because the checked box tells it to ignore row 3.