Cursor in Edit mode

Copper Contributor

When I'm in Edit mode, my cursor doesn't move to where I click in the Edit box - it only stays at the end of the text. Did anyone experience this and how did you resolve it? I also have the same problem when I click in the cell. If I have a lot of text in the cell, this is a pain in getting the cursor to the start of the text. Thanks. 

4 Replies


Part 1:

Maybe it's the "Scroll" button?

Accidentally turned on the scroll lock?


Part 2:

Edit cell contents

Basically, causes can be many, from insufficient RAM to settings in options and cell formatting.

Without knowing a file (without sensitive data), Excel version, operating system and storage medium,

it is difficult to list or guess all possibilities.

In this link you will find some more information about it:

Welcome to your Excel discussion space!



Hope I was able to help you with this info.



I know I don't know anything (Socrates)

Was the answer useful? Mark them as helpful!

This will help all forum participants.


Thanks. I just noticed this problem a couple days ago. I was working on a file that I've had for years so it shouldn't be the file, OS, RAM, or Excel version. I tried a different mouse with the same results. The issue seems to go away when I use the mouse to scroll to the top of the sheet (I can edit in the cell or formula bar with the cursor positioned at the location that I clicked). If I use the mouse to scroll down the page, then the issue appears (I cannot edit in the cell or formula bar and the cursor is positioned at the end of the cell contents). Again, I tried a different mouse with the same result. Thanks for the suggestions though.
This is the exact same situation I have, too - I can't use the mouse to put the cursor in a specific bit of text in a cell, but I CAN do so if I have the sheet scrolled to the top. I tried two different keyboards, two different mice, had no impact.
The weird thing is the problem is not consistent - as in for cells where I'm not scrolled to the top, I can sometimes edit them as I want, sometimes I can't. No idea why.
I've tried turning scroll lock on and off, made no difference.

Ok, this is.... stupid. Makes no sense, but here's what's happening, in my case at least:

For me, the problem has been intermittent. I've been trying to figure out why, so I selected one  sheet that had a ton of data on it. I made a copy of the sheet and started tinkering. I selected one cell to focus on (kept testing there to see when I can/can't edit), I tried changing fonts in various places on the sheet, fill colors, deleting big chunks of data, deleting rows, columns, etc, scrolling up and down, etc to try to see when I was allowed to edit that cell vs. when I wasn't.
The answer is stupid.
I had some cells on that sheet that had borders turned on. I got rid of the borders, I could edit every cell in every condition, whether I was scrolled to the top or not. I put the borders back, the bug comes back. I've tried this a number of times, it's consistent - bug's there when borders are present, leaves when the borders are gone.


I've been using excel for over 20 years, I've never encountered this issue; I've even got some very similar sheets at home, I use the same type of formatting everywhere - doesn't happen on my home computer, just here at work.