Copy/paste no longer working in Excel

Copper Contributor

Sometime in the last few months the copy/paste function within Excel (Office 365 version) stopped working for me.  I have updated Windows and all Office apps to the latest version but that hasn't fixed the problem.  I've also run the Office 365 


The symptom is very strange.  When I hit Ctrl-C (or use the drop-down menus) on a cell in Excel the dashed lines that surround a cell selected for copying show up very briefly but immediately disappear.  If I go to another cell and paste it just puts a open parenthesis "(" in the cell.  Using Ctrl-X to cut exhibits similar behavior.


If I repeatedly hit Ctrl-C it will occasionally work (the dashed lines remain and I can paste) but it typically takes 15-20 tries before it will work and if I try again it will fail.  This only seems to affect me when I try to copy cells.  If I select a cell and then edit the cell and manually select the content of the cell I can copy and paste with no issue.  It also appears to only be an issue when a cell is not empty.  If I select an empty cell I can copy/paste just fine.  If I select a cell that has been highlighted but has no content that also works properly.  It's only when there's text or a formula in the cell that this is an issue.


This only affects Excel, I haven't observed the issue in any other app.


Any ideas?

102 Replies
Try starting Excel in safe mode (press the control key immediately after starting Excel, it should pop up a confirmation dialog to ask whether you want to start in safe mode).
If that makes your problem go away, the cause is very likely either an add-in or your personal macro workbook. See: with some pointers as to how to trouble-shoot add-ins.

Thanks for the suggestion, I didn't even know safe mode was an option for Excel.  Unfortunately it looks like that isn't the issue.  I tried starting in safe mode and the same problem exists.  Any other ideas?

Hi Jon,


If you open clipboard (as on picture) do you see what you copied?



Hi Sergei,


No, it shows an open parentheses in the clipboard, not the contents of the cell.



At least clear what happens with dashed border - if clipboard doesn't work it dissappears. 


Google says similar issue appears from time to time, for example (by the way, you are on Mac or on PC?) or here

But i didn't find concrete solution, sorry. I'd start from Office repair/update if that help.

Thanks, I'm using a PC.  I've tried Office repair/update and that hasn't solved the problem.  

Hi Jon,


Under the Home Ribbon, can you expand cell styles.   Do you have something like this..  or are there many many odd formats..


Cell Styles.PNG

Hi Jon,


Under the Home Ribbon, can you expand cell styles.   Do you have something like this?  or are there many many odd formats..


Cell Styles.PNG

Mine looks basically identical to yours.

Ah ok, that's not the issue then. Really strange

Jan, it looks like here clipboard is not locked by any other program. Even if external clipboard doesn't work Excel shall copy/paste within it, you only not able to copy/paste from Excel outside. Something is wrong within Excel.


However, above is only my guess, i could be wrong.

Correct, I don't think that's the case.  I'm not getting an error that the clipboard is locked and the clipboard still functions correctly.  ex. if I edit a comment I can select text, copy, and paste it inside or outside of excel just like I can select a formula in a cell and copy/paste it.  I just can't copy/paste a cell.

Any chance your keyboard has a problem? e.g. if the Escape key is pressed, the clipboard is emptied in Excel when a cell is copied, but not if you copy the text of a comment.

Sorry for the delayed response, for some reason I didn't get a notification about another post so I just saw it when I came back and checked manually.  


It's definitely not a keyboard issue.  I have the same problem at home and at work and regardless of whether I'm using a docking station with external keyboard or built-in laptop keyboard.


Any other ideas?  Excel is basically worthless if you can't copy and paste cells.

I had a similar issue, I copied a selection of rows to the clipboard, then tried to paste in a single cell below where I copied from and got the error "You can't paste here because the copy area and paste area aren't the same size. Select just one cell in the paste area or an area that's the same size, and try pasting again."
It turned out that I wasn't scrolled all the way over, so column A wasn't showing and I was trying to paste the selection starting with column B at the row of the currently highlighted cell. I just needed to scroll over horizontally select the cell in column A, and press Enter or Ctrl-V to paste.

I am in the same boat.


I can copy/paste from Excel, to Excel.

I am unable to copy/past from OneNote to Excel.


This function was working fine a couple of weeks ago, and now it is not. I am also noticing a latency in Excel across all files.



I am also in the same boat. 


Excel in Windows 10 slows down very frequently, even when only 1 workbook with no complex formulas is open.


The copy/paste function for cells is intermittent at best, you cannot copy a formula across multiple cells like you could in the past, and another unrelated issue: you can't delete a column or row that is under a merged cell at the beginning of the column or row like you could in the past.

Hi Jon,


I have the exact same problem on both my surface pro 4 and on my freshly formatted desktop pc.

In Excel 2016, I cannot copy any cells. The dashed lines will show briefly and then disappears.. A copied cell usually have the dashed lines circling it all the time.

When I try to paste, a left bracket shows up. "  (  "


Can anyone help us solve this mysterious problem..?

1 best response

Accepted Solutions
best response confirmed by Jan Karel Pieterse (Silver Contributor)
I’d recommend that everyone having thus issue goes to File > Feedback and send a frown, putting your details in the section and start it [Can’t Copy Paste]

Also what version is everyone in who’s having this problem ? File > Account

It will read something like
Semi Annual Channel
Build 1234.567

View solution in original post