SOLVED

Contar ocurrencias con mas de una condicion

Contributor

Saludos a todos, a ver si alguien me ayuda a resolver esto. Tengo esta formula:

=SI(Y(B39<PROMEDIO(B30:B36)*$I$7;PROMEDIO(C37:C39)<=$I$4;PROMEDIO(D37:D39)<=$I$5;PROMEDIO(E37:E39)<=$I$6);"Invalido";SI(Y(B39>PROMEDIO(B30:B36)*$H$7;PROMEDIO(C37:C39)>=$H$4;PROMEDIO(D37:D39)=$H$5;PROMEDIO(E37:E39)>=$H$6);"Valido";"Nulo"))

Con ella filtro los resultados de un rango y obtengo tres posibles resultados: valido, invalido o nulo.

Lo que me gustaría es modificar la formula para que hiciera un conteo de las veces que ocurren los resultados "valido" e "invalido" y que de acuerdo a una escala especificada, me devuelva los resultados.

Es decir, si "valido" ocurre 3 veces en un rango especifico, es un resultado, si ocurre >3 y <6 veces en un rango especifico, es un resultado, si ocurre >6 veces en un rango especifico, es un resultado, la cantidad de filas que componen cada rango es diferente.

Para "invalido", seria la misma situación y produciría tres resultados diferentes a los anteriores.

Puede ocurrir por, ejemplo,  que "valido" o "invalido" ocurran 9 veces seguidas, en ese caso coincidirían en una celda los tres resultados posibles de la escala (ocurrirían 3 veces, entre 4 y 6 veces y mas de 6 veces) y se tomaría como resultado el mayor de ellos.

Uso Excel 2016,

Gracias por la ayuda o comentarios.

 

 

 

 

 

 

2 Replies
best response confirmed by a7024782 (Contributor)
Solution

@a7024782 

=IF(COUNTIF(G6:G11,"Valido")=3,"valido resultado 1",IF(AND(COUNTIF(G4:G11,"Valido")>3,COUNTIF(G4:G11,"Valido")<6),"valido resultado 2",IF(COUNTIF(G4:G11,"Valido")>6,"valido resultado 3",IF(COUNTIF(G6:G11,"Invalido")=3,"invalido resultado 1",IF(AND(COUNTIF(G4:G11,"Invalido")>3,COUNTIF(G4:G11,"Invalido")<6),"invalido resultado 2",IF(COUNTIF(G4:G11,"Invalido")>6,"invalido resultado 3",""))))))

 

Is this what you want to do?

Gracias por la respuesta, voy a evaluarla.