SOLVED

Contar con Sumaproducto y 4 filtros

%3CLINGO-SUB%20id%3D%22lingo-sub-3416387%22%20slang%3D%22es-ES%22%3EHave%20Sumaproducto%20and%204%20filters%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3416387%22%20slang%3D%22es-ES%22%3E%3CP%3ERegards%3A%20I%20have%20the%20following%20formula%20%3DSUMPRODUCT(--(AP!%24Y%248%3A%24Y%242999)%3D%24C%2431)%3B--(AP!%24AQ%248%3A%24AQ%242999)%3D%24B%2036)%3B--(AP!%24AT%248%3A%24AT%242999%3DC%243))%2C%20with%20it%20I%20get%20a%20result%20that%20is%20the%20account%20of%20certain%20values%2C%20once%20the%20filters%20of%20the%20formula%20have%20been%20applied%3B%20it's%20working%20well.%20My%20problem%20is%20that%20I%20want%20to%20add%20to%20that%20formula%20one%20filter%20per%20month%2C%20that%20is%2C%20that%20the%20result%20obtained%20from%20the%20previous%20formula%20is%20shown%20according%20to%20a%20month%20that%20is%20specified.%20I%20add%20this%2C%20at%20the%20end%20of%20the%20formula%20but%20it%20doesn't%20work%20for%20me%3A%20--(MES(AP!%24B%248%3A%24B%242999)%3DMONTH(D%2432)).%3C%2FP%3E%3CP%3EThank%20you%20for%20the%20help%20you%20can%20provide%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-3416387%22%20slang%3D%22es-ES%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EFormulas%20and%20Functions%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3416782%22%20slang%3D%22en-US%22%3ERe%3A%20Contar%20con%20Sumaproducto%20y%204%20filtros%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3416782%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1187812%22%20target%3D%22_blank%22%3E%40a7024782%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-applescript%22%3E%3CCODE%3E%3DSUMPRODUCT(N((AP!%24Y%248%3A%24Y%242999)%3D%24C%2431)%2CN((AP!%24AQ%248%3A%24AQ%242999)%3D%24B36)%2CN(AP!%24AT%248%3A%24AT%242999%3DC%243)%2CN(MONTH(AP!%24B%248%3A%24B%242999)%3DMONTH(D%2432)))%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3EI've%20entered%20this%20formula%20in%20an%20empty%20sheet%20and%20it%20returns%20the%20expected%20result%20of%202992.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

Saludos: tengo la siguiente formula =SUMAPRODUCTO(--((AP!$Y$8:$Y$2999)=$C$31);--((AP!$AQ$8:$AQ$2999)=$B36);--(AP!$AT$8:$AT$2999=C$3)), con ella obtengo un resultado que es la cuenta de determinados valores, una vez que se han aplicado los filtros de la formula; esta funcionando bien. Mi problema es que quiero agregar a esa formula un filtro por mes, es decir que el resultado obtenido de la formula anterior sea mostrado de acuerdo a un mes que se especifique. Yo agregue esto, al final de la formula pero no me funciono: --(MES(AP!$B$8:$B$2999)=MES(D$32)).

Gracias por la ayuda que puedan brindar

1 Reply
best response confirmed by a7024782 (Contributor)
Solution

@a7024782 

=SUMPRODUCT(N((AP!$Y$8:$Y$2999)=$C$31),N((AP!$AQ$8:$AQ$2999)=$B36),N(AP!$AT$8:$AT$2999=C$3),N(MONTH(AP!$B$8:$B$2999)=MONTH(D$32)))

I've entered this formula in an empty sheet and it returns the expected result of 2992.