SOLVED

Comment imbriquer "sommeprod" dans nb.si ? Nb valeur à partir d'une formule et non d'une colonne?

New Contributor

Je recherche à compter le nombre de dossiers ayant une valeur > 0$ (mais pour lequel je n'ai pas une colonne distingue pour la valeur recherchée). La valeur recherchée est toutefois trouvée à l'aide d'une formule et n'est pas dans une colonne. 

Voir tableau ci-joint. Je recherche la formule en jaune.

Merci!

3 Replies
best response confirmed by ILarouche (New Contributor)
Solution

@ILarouche 

Dans E20:

 

=SOMMEPROD(($C$5:$C$10=C20)*($D$5:$D$10-$E$5:$E$10<>0))

 

Remplir vers E21.

Wow merci! Mon cerveau ne comprends pas trop pourquoi cette formule donne des nombres au lieu de des $, mais ça fonctionne! Un gros merci!!

@ILarouche 

($C$5:$C$10=C20) renvoie un tableau de valeurs VRAI/FAUX, et ($D$5:$D$10-$E$5:$E$10<>0) aussi.

Dans la somme, VRAI = 1 et FAUX = 0.