Changing absolute hyperlinks to relative

%3CLINGO-SUB%20id%3D%22lingo-sub-176679%22%20slang%3D%22en-US%22%3EChanging%20absolute%20hyperlinks%20to%20relative%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-176679%22%20slang%3D%22en-US%22%3E%3CDIV%20class%3D%22thread-message-content-body-text%20thread-full-message%22%3E%0A%3CP%3EThis%20is%20a%20follow-up%20to%20%3CA%20title%3D%22this%20discussion.%22%20href%3D%22https%3A%2F%2Fanswers.microsoft.com%2Fen-us%2Fmsoffice%2Fforum%2Fmsoffice_excel-mso_winother-mso_2013_release%2Fbatch-hyperlink-image-files-in-excel-worksheet%2Fa874c1ad-a759-4371-89aa-210696f72c4a%3Ftm%3D1504123369709%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3E%20this%20discussion.%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI%20made%20all%20my%20image%20hyperlinks%20as%20absolute%20links%20%5Bex%3A%20%3DHYPERLINK(%22S%3A%5CMain%5CBusiness%20Card%20registry%5CScanned%20Cards%5C%22%26amp%3BB2%26amp%3B%22%20%22%26amp%3BD2%26amp%3B%22.jpg%22%2CB2%26amp%3B%22%20%22%26amp%3BC2%26amp%3B%22%20%22%26amp%3BD2)%20%5D%20but%20now%20I%20need%20to%20move%20all%20the%20images%20to%20another%20server.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ESo%20I%20tried%20to%20change%20them%20to%20a%20relative%20link%20%3DHYPERLINK(Business%20Card%20registry%5CScanned%20Cards%5C%22%26amp%3BB2%26amp%3B%22%20%22%26amp%3BD2%26amp%3B%22.jpg%22%2CB2%26amp%3B%22%20%22%26amp%3BC2%26amp%3B%22%20%22%26amp%3BD2)%20and%20it%20%22can't%20open%20the%20specified%20file%22.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ESo%2C%20what%20do%20I%20need%20to%20do%20differently%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI%20tried%20going%20to%20Info%20%26gt%3B%20Properties%20%26gt%3B%20Advanced%20Properties%20%26gt%3B%20Summary%20%26gt%3B%20Hyperlink%20base%20to%20change%20it%20to%20Business%20Card%20registry%5CScanned%20Cards%20but%20that%20didn't%20work%20either.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAny%20help%20would%20be%20appreciated.%20I%20don't%20want%20to%20have%20to%20go%20through%20and%20relink%20700%2B%20images.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3Eedit%3A%20the%20folder%20is%20on%20a%20Box%20shared%20server%2C%20if%20that%20makes%20a%20difference%3C%2FP%3E%0A%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-176679%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-182275%22%20slang%3D%22en-US%22%3ERe%3A%20Changing%20absolute%20hyperlinks%20to%20relative%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-182275%22%20slang%3D%22en-US%22%3E%3CP%3EThere%20is%20no%20drive%20letter%2C%20the%20files%20are%20stored%20on%20Box.%3C%2FP%3E%3CP%3EShould%20I%20put%20the%20URL%20instead%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-177213%22%20slang%3D%22en-US%22%3ERe%3A%20Changing%20absolute%20hyperlinks%20to%20relative%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-177213%22%20slang%3D%22en-US%22%3Eso%20you%20had%20%3DHYPERLINK(%22S%3A%5CMain%5CBusiness%20Card%20registry%5CScanned%20Cards%5C%22%26amp%3BB2%26amp%3B%22%20%22%26amp%3BD2%26amp%3B%22.jpg%22%2CB2%26amp%3B%22%20%22%26amp%3BC2%26amp%3B%22%20%22%26amp%3BD2)%3CBR%20%2F%3E%3CBR%20%2F%3Enow%20you%20replaced%20it%20with%20%3CBR%20%2F%3E%3DHYPERLINK(Business%20Card%20registry%5CScanned%20Cards%5C%22%26amp%3BB2%26amp%3B%22%20%22%26amp%3BD2%26amp%3B%22.jpg%22%2CB2%26amp%3B%22%20%22%26amp%3BC2%26amp%3B%22%20%22%26amp%3BD2)%3CBR%20%2F%3E%3CBR%20%2F%3Ethere%20is%20definitely%20a%20problem%20with%20your%20second%20link%20there%20is%20no%20drive%20letter%20at%20the%20begining.%3CBR%20%2F%3Ewhen%20you%20say%20another%20server%20what%20is%20the%20drive%20letter%20%3F%3C%2FLINGO-BODY%3E
New Contributor

This is a follow-up to this discussion.

 

I made all my image hyperlinks as absolute links [ex: =HYPERLINK("S:\Main\Business Card registry\Scanned Cards\"&B2&" "&D2&".jpg",B2&" "&C2&" "&D2) ] but now I need to move all the images to another server.

 

So I tried to change them to a relative link =HYPERLINK(Business Card registry\Scanned Cards\"&B2&" "&D2&".jpg",B2&" "&C2&" "&D2) and it "can't open the specified file".

 

So, what do I need to do differently?

 

I tried going to Info > Properties > Advanced Properties > Summary > Hyperlink base to change it to Business Card registry\Scanned Cards but that didn't work either.

 

Any help would be appreciated. I don't want to have to go through and relink 700+ images.

 

edit: the folder is on a Box shared server, if that makes a difference

2 Replies
Highlighted
so you had =HYPERLINK("S:\Main\Business Card registry\Scanned Cards\"&B2&" "&D2&".jpg",B2&" "&C2&" "&D2)

now you replaced it with
=HYPERLINK(Business Card registry\Scanned Cards\"&B2&" "&D2&".jpg",B2&" "&C2&" "&D2)

there is definitely a problem with your second link there is no drive letter at the begining.
when you say another server what is the drive letter ?
Highlighted

There is no drive letter, the files are stored on Box.

Should I put the URL instead?