Cannot open Excel files after upgrading to Windows 11

Occasional Visitor

Hi,

I just upgraded to Windows 11. Now, when I opened my excel files in my QNAP NAS, excel showed document recovery message: "Excel has recovered the following files. Save the ones you wish to keep.". I tried to click the file to recover it but it has no response. Excel stopped there. I had to close Excel. I tried to reopen Excel and reopen the same file. It repeated. I could not open the file. 

Initially, I suppose my excel file is damaged but I don't know why because I edited the file the night before. It had not problem. Finally, I copied the excel file from my NAS to my local drive in my laptop (i.e. the one I connected to my NAS).  I opened the file in the local drive with Excel. It worked. I had no problem. Why?

 

Please help, thanks.

 

Summer

15 Replies
I am having the exact same problem as I just installed Windows 11 and now a very important excel file of mine won't open because it says it is corrupted?

Same issue here with a macro enabled Excel 2007 workbook.

Used OpenOffice to open & save to new workbook but macros were lost.

@Pete_59 

Additional info & some good news: File is NOT corrupt. Same "Corrupt" Excel file opened OK with no issues on Win10 running on VMware.
I had the same issue but came across this solution. Try to right-click on the file and select Open, instead of double-click.

@Summer_Chow  I have same problem, all possible solutions did not solve the issue!

I am having the same issue with Excel files.

@Summer_Chow 

@nsrumschlag I have exactly the same problem and it is related to the windows 11 install. All xlsx files now show with an IE symbol and will try to open in internet explorer (without success of course). The workaround is to right click on the file and select "open with" excel. That is necessary for all files with an xlsx extension. Files with an xls extension, however (older version of excel), show with the excel symbol and open directly. Once an xlsx file is open, saving it as a excel 2009 version with an xls extension solves the "open with" problem but some functions are obviously lost. 

This is only an excel problem; the same issues do not exist with Word. 

@homeuserhvp 

That's not Excel, that's Windows settings. Set in them Excel as default app for that extension.

image.png

@Sergei Baklan 

 

Upon searching .xlsx files via apps -> default apps, it comes out empty. I have no idea what is going on anymore, but your solution does not work. I have the same issue as @homeuserhvp 

@homeuserhvp I had to resave all my excel files as .xls instead of .xlsx and it worked. I hope the same does for you, but the issue still remains.

@Sepharo 

If it is empty you shall assign Excel as default application. Double click on the field and follow the prompt.

@Sergei Baklan Good Morning.  I tried to add the .xlxs option to settings and set the default app to Excel however it still tries to open the file with Internet Explorer.  Seems like an issue with Win 11 as I am not seeing this on a Win 10 computer at the same client.

 

Ideas?

@Sepharo I have tried the "Right-Click" and "Open with Excel", but it fails.  I tried "xls" and "xlsx" files and neither will open.  WORD works as it normally would.  I can start Excel and it shows up to allow me to open a file.  If I click on starting a blank new worksheet, Excel shutsdown.  The ones I try to open show up in the "recently opened" list, but I still can't open any.

I have the same problem after upgrading to win 11.

Please help

 

@rajuann check online for commandline parameters.  I think "/e" as the one I tried.  To do this, find the shortcut for starting Excel and add those two characters outside the quotes(I think), skipping my quote marks.  Experiment.  I don't have my laptop with me it the moment.