Cannot open Excel File

Occasional Contributor

Excel opens, but my file won't open even though I'm clicking right on the filename.

It keeps opening a blank file called "Book1- Excel".

I use Windows 11.

I just used this file.

6 Replies
best response confirmed by K9-Gal (Occasional Contributor)

@K9-Gal Did you perhaps accidentally click on Hide in de View ribbon (Window group)? and upon closing Excel you confirmed to save changes.


If you then open the file, it will open in its hidden state, i.e. not visible. Go to the View ribbon and select Unhide. You should then see your workbook there.

Screenshot 2022-02-23 at 08.19.36.png


Hi Riny,

You may have the most brilliant idea yet -- I do remember that I was doing a PAGE LAYOUT / PRINT TITLES when all of a sudden, it was gone!  Maybe I clicked the wrong thing(?)


I spent so many hours last night trying to figure it out!  By now I've tried everything humanly possible, even MS Cha Support couldn't help. They just said do a Windows Upgrade--which didn't help at all!


Today, I am able to see the exact FILENAME in my FILE EXPLORER. It doesn't appear corrupt -- it still shows the correct FILESIZE, FLENAME, PATH, etc.


However, when I click on it (either left or right click), it always opens a blank EXCEL document.  I cannot figure out which VIEW link you mean--the one in the FILE EXPLORER or the one in the blank worksheet document.  I tried both, but neither shows an UNHIDE.


Thank you for thinking outside the box!

Message says file may be corrupted@K9-Gal 

@K9-Gal not sure if you resolved it or not, but I meant the View ribbon in Excel. There you find the Hide and Unhide buttons as shown in the picture I uploaded earlier.



Why did a MS Chat Support Tech waste HOURS of my time? These people are total AMATEURS. The answer was so simple, and should have been suggested FIRST. At least I didn't waste another 10 hours re-creating this very important company document.

Anyway, if you need a tech job in NJ, I will DEFINITELY put in an A+++ recommendation for you.

Lorenza Vidris,

Mainframe Programmer Analyst


No - it was "HIDDEN."