Buscar, necesito ayuda

%3CLINGO-SUB%20id%3D%22lingo-sub-1972900%22%20slang%3D%22es-ES%22%3ESearch%2C%20I%20need%20help%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1972900%22%20slang%3D%22es-ES%22%3E%3CP%3EGood%20afternoon%2C%20I%20explain%3A%3C%2FP%3E%3CP%3EI%20have%20created%20an%20Excel%20workbook%20for%20comparing%20a%20serial%20number%20list%20of%20a%20few%20items%20and%20returning%20their%20location%20to%20me.%20Monthly%20I%20have%20to%20inventory%20some%20retired%20items%20for%20their%20keeping%2C%20the%20items%20I%20have%20them%20in%20numbered%20boxes.%20Then%20they%20send%20me%20a%20list%20with%20the%20items%20that%20I%20have%20to%20send%20for%20maintenance%20or%20for%20final%20withdrawal.%3C%2FP%3E%3CP%3EIn%20annexed%20sheets%20I%20have%20the%20inventories%20and%20in%20the%20main%20the%20search%20the%20formula%20used%20is%3A%3C%2FP%3E%3CP%3EYES.%20ERROR(SEARCH(C3%3B'%20202011'!%24A%3A%24B%3A%3B2%3B%20FALSE)%3B%20VS%20SEARCH(C3%3B'%20202010'!%24A%3A%24B%3A%3B2%3B%20FALSE))%3C%2FP%3E%3CP%3EI%20do%20not%20get%20error%20in%20the%20formula%2C%20but%20when%20I%20manually%20enter%20the%20code%20to%20be%20searched%20in%20C3%20it%20does%20not%20return%20me%20the%20value%20of%20column%202%2C%20no%20more%20times%20I%20check%20the%20formula%20I%20do%20not%20find%20where%20the%20error%20is.%20The%20strange%20thing%20is%20that%20if%20I%20go%20to%20the%20sheet%20in%20question%20and%20copy%20the%20code%20when%20I%20enter%20it%20in%20the%20search%20box%20if%20it%20returns%20its%20location%20to%20me%20and%20that%20is%20what%20has%20me.%20Can%20you%20help%20me%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1972900%22%20slang%3D%22es-ES%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Visitor

Buenas tardes, os explico:

He creado un libro Excel para la comparación de un listado de número de serie de unos artículos y que me devuelva su ubicación. Mensualmente tengo que inventariar unos artículos retirados para su manteniendo, los artículos los tengo metidos en cajas numeradas. Después me envían un listado con los artículos que tengo que enviar para su mantenimiento o para su retirada definitiva.

En hojas anexas tengo los inventarios y en la principal la búsqueda la formula empleada es:

= SI.ERROR(BUSCARV(C3;'202011'!$A:$B:;2;FALSO);BUSCARV(C3;'202010'!$A:$B:;2;FALSO))

no me da error en la fórmula, pero cuando introduzco manualmente el código a buscar en C3 no me devuelve el valor de la columna 2, por más veces que reviso la fórmula no encuentro donde está el error. Lo extraño es que si voy a la hoja en cuestión y copio el código cuando lo introduzco en la casilla de búsqueda si me devuelve su ubicación y es lo que me tiene mosqueado. ¿Me podéis ayudar?

0 Replies