Alt+Enter does nothing

%3CLINGO-SUB%20id%3D%22lingo-sub-650247%22%20slang%3D%22en-US%22%3EAlt%2BEnter%20does%20nothing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-650247%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20guys.%3CBR%20%2F%3EI%20am%20trying%20to%20get%20a%20line%20break%20in%20lists%20but%20every%20time%20I%20press%20Alt%2BEnter%20absolutely%20nothing%20happens.%3CBR%20%2F%3E%3CBR%20%2F%3EAnyone%20can%20drop%20in%20to%20help%20please%3F%3C%2FP%3E%3CP%3EThanks%20in%20advance!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-650247%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAlt%2BEnter%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ELine%20break%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-650262%22%20slang%3D%22en-US%22%3ERE%3A%20Alt%2BEnter%20does%20nothing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-650262%22%20slang%3D%22en-US%22%3E%3CP%3EI%20suspect%20you%20have%20been%20successful%20in%20inserting%20an%20ASCII%2010%20character%20but%20you%20do%20not%20have%20'Wrap%20text%22%20enabled%20for%20the%20cell%20so%20the%20display%20does%20not%20show%20multiple%20rows.%20The%20array%20formula%3C%2FP%3E%3CP%3E%3CSTRONG%3E%3D%20CODE(%20MID(%20ref%2C%20%7B1%2C2%2C3%2C4%7D%2C%201%20)%20)%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3Ewill%20test%20a%20four%20character%20string%20to%20see%20whether%20a%2010%20is%20present.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1054456%22%20slang%3D%22en-US%22%3ERE%3A%20Alt%2BEnter%20does%20nothing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1054456%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F214174%22%20target%3D%22_blank%22%3E%40Peter%20Bartholomew%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEven%20I%20am%20facing%20same%20problem.%20Wrap%20is%20enabled.%20This%20problem%20is%20persisting%20for%20last%202%20years%20since%20I%20installed%20it%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1054509%22%20slang%3D%22en-US%22%3ERE%3A%20Alt%2BEnter%20does%20nothing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1054509%22%20slang%3D%22en-US%22%3EHave%20you%20tried%20the%20second%20part%20of%20the%20recommendation%3F%20Namely%2C%20use%20MID%20to%20separate%20out%20individual%20characters%20from%20the%20string%20and%20CODE%20to%20allow%20you%20to%20see%20which%20character%20is%20selected.%20The%20line%20feed%20character%20is%20non-printing%20but%20should%20give%20a%20code%20value%20of%2010%20if%20it%20is%20present.%3CBR%20%2F%3E%3CBR%20%2F%3EThat%20should%20help%20narrow%20the%20problem%20down%20to%20one%20of%20string%20content%20or%20formatting.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1054676%22%20slang%3D%22en-US%22%3ERe%3A%20Alt%2BEnter%20does%20nothing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1054676%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F349468%22%20target%3D%22_blank%22%3E%40Monica_Moura%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EDo%20we%20speak%20about%20Excel%20for%20Windows%20or%20Excel%20for%20Mac%20or%20which%20one%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1055076%22%20slang%3D%22en-US%22%3ERe%3A%20Alt%2BEnter%20does%20nothing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1055076%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F349468%22%20target%3D%22_blank%22%3E%40Monica_Moura%3C%2FA%3E%26nbsp%3BYou%20would%20need%20to%20double%20click%20in%20the%20cell%20before%20using%20alt%2Benter%20for%20it%20to%20work.%20Did%20you%20do%20that%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1489917%22%20slang%3D%22en-US%22%3ERe%3A%20Alt%2BEnter%20does%20nothing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1489917%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20the%20same%20problem%20that%20alt%20%2B%20enter%20does%20nothing.%26nbsp%3B%20It%20used%20to%20work%20fine.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1490175%22%20slang%3D%22en-US%22%3ERe%3A%20Alt%2BEnter%20does%20nothing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1490175%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F710447%22%20target%3D%22_blank%22%3E%40douga54%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EDid%20you%20apply%20%3CSTRONG%3EWrap%20text%3C%2FSTRONG%3E%20to%20the%20cell%20format%20(use%20Ctrl%2B1)%3F%3C%2FP%3E%0A%3CP%3EHere%20that's%20the%20only%20difference%20between%20two%20cells%3C%2FP%3E%0A%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22image.png%22%20style%3D%22width%3A%20365px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F201173iD38AADC857A37408%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22image.png%22%20alt%3D%22image.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1490197%22%20slang%3D%22en-US%22%3ERe%3A%20Alt%2BEnter%20does%20nothing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1490197%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F521%22%20target%3D%22_blank%22%3E%40Sergei%20Baklan%3C%2FA%3E%26nbsp%3B%3CSPAN%3EI%20did%20that%2C%20actually%20I%20always%26nbsp%3Bdo%20that.%26nbsp%3B%20It's%20working%20now.%26nbsp%3B%20I%20updated%20my%20Microsoft%20Office%20apps%20and%20had%20to%20completely%20shut%20down%20and%20restart%20before%20the%20updates%20were%20applied.%26nbsp%3B%20I%20just%20don't%26nbsp%3Bunderstand%20if%20it%20has%20always%20been%20working%2C%20why%20would%20it%20stop%20working%20now%3F%26nbsp%3B%20That's%20the%20kind%20thing%20Microsoft%26nbsp%3Bdoes%20which%20drives%20me%20crazy.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1490246%22%20slang%3D%22en-US%22%3ERe%3A%20Alt%2BEnter%20does%20nothing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1490246%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F710447%22%20target%3D%22_blank%22%3E%40douga54%3C%2FA%3E%26nbsp%3Bgreat%20to%20know%20you%20sorted%20this%20out%2C%20thank%20you%20for%20the%20feedback%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1490267%22%20slang%3D%22en-US%22%3ERe%3A%20Alt%2BEnter%20does%20nothing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1490267%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20for%20your%20input%20and%20for%20trying%20to%20help.%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F521%22%20target%3D%22_blank%22%3E%40Sergei%20Baklan%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Visitor

Hi guys.
I am trying to get a line break in lists but every time I press Alt+Enter absolutely nothing happens.

Anyone can drop in to help please?

Thanks in advance!

10 Replies
Highlighted

I suspect you have been successful in inserting an ASCII 10 character but you do not have 'Wrap text" enabled for the cell so the display does not show multiple rows. The array formula

= CODE( MID( ref, {1,2,3,4}, 1 ) )

will test a four character string to see whether a 10 is present.

Highlighted

@Peter Bartholomew 

Even I am facing same problem. Wrap is enabled. This problem is persisting for last 2 years since I installed it

Highlighted
Have you tried the second part of the recommendation? Namely, use MID to separate out individual characters from the string and CODE to allow you to see which character is selected. The line feed character is non-printing but should give a code value of 10 if it is present.

That should help narrow the problem down to one of string content or formatting.
Highlighted

@Monica_Moura 

Do we speak about Excel for Windows or Excel for Mac or which one?

Highlighted

@Monica_Moura You would need to double click in the cell before using alt+enter for it to work. Did you do that? 

Highlighted

I have the same problem that alt + enter does nothing.  It used to work fine.

Highlighted

@douga54 

Did you apply Wrap text to the cell format (use Ctrl+1)?

Here that's the only difference between two cells

image.png

Highlighted

@Sergei Baklan I did that, actually I always do that.  It's working now.  I updated my Microsoft Office apps and had to completely shut down and restart before the updates were applied.  I just don't understand if it has always been working, why would it stop working now?  That's the kind thing Microsoft does which drives me crazy.

Highlighted

@douga54 great to know you sorted this out, thank you for the feedback

Highlighted

Thanks for your input and for trying to help.

@Sergei Baklan