ActiveX buttons unresponsive or having to be clicked twice to run macro


Hello, community!

I inherited two Excel files that come with a bunch of ActiveX buttons.

In some cases the buttons don't do anything: I click them, it shows kind of a duplicate image of the button on the side when I press the button, but nothing happens. The macro associated runs well if I run it from the VB Editor. 

On the other file, the buttons do work but only when I click them for the second time. Any idea what may cause this to happen?


Thank you in advance for any tip or guidance.

34 Replies
Hard to say without the file. ActiveX buttons do cause havoc at times, perhaps replacing them with forms buttons helps?
Hi Celia,

I've just started having this issue - on my old laptop it was only one click to make the buttons work, but now on Windows 10 it takes a double-click to make them work? So strange, never seen this before.

Just wondering if you ended up finding the issue?

Hi, @_Ness_.
Unfortunately, I did not find the cause or a solution.
If I remember, I think that in one of the cases, deleting the button and creating a new one, helped. I am not sure if I replaced it with an active x button or one of the other button types.

oi tudo bem @Celia_Alves  I have this issue too. I don't think it's W10 per-se as they were fine until recently - so it's something to do with a recent update I would say. I did look at replacing them with ordinary buttons but there was some disadvantage to that - which I can't recall right now. I'll try the "delete and replace with new" approach to see if that works, though, even if it does, it's hardly satisfactory. I don't recall a recent update coming with a disclaimer from MS saying that activeX macro buttons may not work (properly) anymore (mind you I expect what the small print actually says is that if their update causes Armageddon it's still not their fault!).

ActiveX buttons have never been very reliable in my experience. Given that it is unlikely that Microsoft will fix that issue I always advise:
1. Use the forms controls instead
2. Even better, avoid controls to begin with.
They worked reliably enough until recently for what I use them for which is generally to display and hide text boxes. I find this useful as you can display text to explain what a workbook/worksheet is doing/what it is for/how to sue it etc. and then hide the text so that it doesn't obscure the data. I don't know of another way to do that. I guess an ordinary button may work, but, as I say there is a snag to using them - which may be that I'd just have to edit all that worksheet vba I have. What a pain.
As far as I know, regular shapes mostly behave themselves. You can assign macro's to a shape too, so it might fit your need?
Maybe, I did look into it before and as I say there was a snag, I can't remember what it was, - I don't have time to look into it again right now - but, if, as you say, MS have now broken activeX controls and are unlikely to fix them, then I'll have no choice but to try that eventually.
I'm not aware of any recent change to the working of ActiveX controls. There was a problem a couple of years ago, that I do know. Try clearing your temporary files, especially files with the .exd extension must be deleted from your temporary folders.
Mmm, well, I labour under corporate lockdown, as do many, of course I could raise a ticket to get these cleared, if there are any (I can't even look). Maybe I will. Thanks.
Does typing this in the Windows explorer address bar take you anywhere: %temp% (and press enter of course)?
Yes it did, thanks. I found one exd file there - which I am unable to delete at the moment as I have excel open and it is in use, it tells me. Too many things open now to close everything for this - but when I shut down I'll delete it. I presume it will get created again (the last modified date of it is the 14th). I did go "looking" for this folder manually as it were but couldn't see it.
It may be necessary to weed out subfolders as well.
I never really understood what caused this issue. Vid kuch abd let us know how it goes.
There did appear to be only one .exd file. Default search seems to find anything in subfolders of the folder you're in too. I deleted the one I found which was the only thing in a folder called Excel 8.0. It seems to have done the trick though, so, thanks.

@Jan Karel Pieterse 

If you have any other ideas, I would appreciate hearing them.  I've described everything I can think of that is relevant below.


ActiveX buttons that used to work on a single click now required two clicks to activate the macro. The buttons worked fine on my previous machine which was, as far as I can tell, identical.  I have dozens of spreadsheets that are affected, each spreadsheet has many buttons (15-20) so I can't replace the buttons on each one. The functionality is occurring on two machines in my department (of 4), both recently configured.  The problem does not occur on the other two (older) machines in my department.  The other machine in my department that has problems is a Lenovo T570.

Things I have checked for my machine:

- Hardware: Microsoft Surface model 1769

- Operating system: Windows 10

- Microsoft Excel for Office 365 MSO (16.0.12026.20344) 64 bit (previous version was 64 bit “Microsoft Excel for Office 365 MSO (16.” but I can’t prove the exact version).

The functionality is the same whether the file is opened from a SharePoint (SP) web page, a local synced folder, or on the local HD (not synced).

Two single clicks cause the macro to activate on the second click.  The second click can be separated from the first by anything up to 1 minute (didn't wait any longer).  If the cursor leaves the button between clicks, then it is as if the button has not been clicked.  Similarly, a single click, switching windows (Alt-Tab) switching back and clicking again acts the same as a single click (does nothing).

Double clicking the button is no different than single clicking. The two clicks must be separated by at least 1 second.

The problem occurred before I installed many of my custom programs so they should not be the issue.

I noticed the problem on the first day I used a spreadsheet with an ActiveX control. The problem has continued on subsequent days despite reboots and cold starts (over 2 weeks now).

I followed the directions above, I tried:

- deleting \AppData\Local\Temp\Excel8.0\MSForms.exd and then re-running Excel. 

- deleting MSForms.exd, rebooting, and then re-running Excel.

- deleting everything I could delete in …\AppData\Local\Temp\*.* including sub folders, rebooting, and then re-running Excel.