ActiveX buttons not working when sheet is protected

%3CLINGO-SUB%20id%3D%22lingo-sub-2294794%22%20slang%3D%22en-US%22%3EActiveX%20buttons%20not%20working%20when%20sheet%20is%20protected%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2294794%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20everyone%2C%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20having%20some%20difficulty%20with%20the%20ActiveX%20buttons.%20I%20created%20three%2C%20refresh%2C%20pending%20and%20completed.%20I%20want%20to%20protect%20the%20sheet%20so%20others%20don't%20accidently%20click%20on%20anything%20except%20those%20three%20buttons.%20Once%20I%20protect%20the%20sheet%20a%20Run-time%20error%20'1004'%3A%20pops%20up.%20I%20click%20debug%20and%20it%20takes%20me%20to%20the%20code%20page%20and%20it%20highlights%20a%20line.%20It%20does%20the%20same%20thing%20ever%20time%20I%20click%20on%20any%20of%20the%20buttons.%20Any%20recommendations%3F%20I%20am%20attaching%20screen%20shots.%20%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2294794%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EBI%20%26amp%3B%20Data%20Analysis%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ECharting%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EFormulas%20and%20Functions%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMacros%20and%20VBA%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ETraining%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Contributor

Hello everyone, 

 

I am having some difficulty with the ActiveX buttons. I created three, refresh, pending and completed. I want to protect the sheet so others don't accidently click on anything except those three buttons. Once I protect the sheet a Run-time error '1004': pops up. I click debug and it takes me to the code page and it highlights a line. It does the same thing ever time I click on any of the buttons. Any recommendations? I am attaching screen shots.  

0 Replies