WSUS Edge Update detection not working on legacy Windows versions

Occasional Contributor

My Windows 8.1 Professional clients don't seem to be offered Edge updates via my WSUS server starting with the last couple of updates, while Windows 10 Professional clients do get offered the update by the same WSUS server.  The same GPO applies to both, it just seems that within the last several updates to Edge, the detection stopped working for Windows 8.1 (and possibly Windows 7 as well, I don't have any legacy Windows 7 computers to test).  Not sure who to report this to but we use WSUS to manage Edge updates.

19 Replies
Anyone at Microsoft care to look into this?

@broland Hi - Apologies for the delay!  I can discuss with the team and see if they have any insights.  


Do you know when and what version the last MS Edge update was available for Windows 8.1?  This information might be helpful on our end to investigate.  Thanks!



@Kelly_Y I believe that for Stable, version 85.0.564.63 was the last one that the WSUS detection worked correctly only Windows 8.1.  I believe the Dev channel (and possible Beta, I'm not using that one) also stopped detecting via WSUS around the same time period (September 23rd-ish).  Let me know if I can be of further assistance.

@broland Thank you for the additional information!  I'll let you know if there are any follow up questions.  



Same problem here, I can confirm that 85.0.564.63 is the most recent version that gets detected by Windows 8.1 using WSUS.

@mdaehlmann Thank you!  This is helpful!  I've let the team know you are also experiencing the same issue.   



@Kelly_Y just FYI, the latest batch of updates that hit WSUS last night, still do not detect Edge updates on Windows 8.1 clients.  

Same on Server 2016 and 2019

@broland  and @Pepijn_Vermeersch  - Thank you for sending your updates!  I've passed them on to our team who continues the investigation.  



I can confirm that the last WSUS delivered update for Microsoft Edge that detected and installed on our legacy Windows 7 endpoints (with ESU) was 85.0.564.63.


The latest update - 86.0.622.48 - which arrived overnight yesterday/today (20/21st Oct 2020) is not scanning for any endpoint, including Windows 10, despite being approved.

@jdseymour1978 Thank you for confirming the behavior on Windows 7.  I've let the team know!  




Thank you. I'm pleased to say that the latest version of Edge - 86.0.622.48 - is now being detected as 'Needed' on Windows 10 endpoints on our network, where it is installed, by WSUS.


WSUS shows all versions of Edge after 85.0.564.63 as 'Not applicable' to Windows 7 endpoints, even though it (or superseding versions) are approved for installation, and it is installed on several Windows 7 endpoints on our network (we are still at the test and evaluation stage of our implementation of Edge).

Still not working on Windows 8.1 either.  Doesn't seem like it should be this difficult considering it did work at one time.

@broland @mdaehlmann @Pepijn_Vermeersch @jdseymour1978 - Hi Everyone!  Great news, our team was able to deploy a fix.  Edit: You should now be able to receive the MS Edge updates on downlevel Windows.   I'm double checking when you should be able to see the change. 


Appreciate all the feedback as it really helped with our investigation!  If you continue to reproduce the issue, please let us know.  Thanks! 



@Kelly_Y according to me the issue is fixed on server 2016 and 2019

The build that was installed is 86.0.622.48

@Kelly_Y revised Microsoft Edge Servicing Detectoid has beem deployed to WSUS

Hi - Just to follow up, for anyone that was experiencing the issue a resync should pull down the updated detectoid and mitigate the issue.  If anyone is still reproducing the issue, please let us know!  





@Kelly_Y I did a resync and the latest Stable was detected and installed on Windows 8.1, thanks for that!


I still do not see Beta/Dev channels detect updates.  Maybe I just need to give them more time?

EDIT: Oops, apparently I should have checked the update history, Beta/Dev actually already downloaded and updated in the background.  So it appears to be working correctly now.  Thanks guys!

Thanks Kelly! I can confirm that the latest version 86.0.622.51 is now properly detected by Windows 8.1 endpoints again!