Unable to import passwords with hidden FRE

Brass Contributor

We have GPO (Computer Configuration) set to import everything from default browser on first run. We also have the FRE wizard & splash hidden.


Everything seems to import except saved passwords. :(


Had posted this on the Edge uservoice but that seems to have been killed off.

18 Replies

@DamienSolodow Hi Damien - You mentioned you are using a GPO, is it 

AutoImportAtFirstRun Policy (https://docs.microsoft.com/en-us/deployedge/microsoft-edge-policies#autoimportatfirstrun)? 


Saved passwords should be imported, except if the default browser is Safari.  When the issue reproduces, what browser is the information being imported from?  


Also, If you haven't had a chance yet, can you please submit feedback/diagnostic data through the browser? ("..." menu > Help and feedback > Send feedback)






@Kelly_Y  - default browser is Chrome. Windows 10 1909 x64


Pretty sure I've submitted feedback on this issue under this email address but can try again in the AM.

@DamienSolodow I tried to search our feedback but could not see anything.  That would be great if you could try again! 


If could mention my user name "Kelly_Y" then it should be easier to track down.  Once received, I can reach out to the team that owns the policy and ask them to take a look.  





@Kelly_Y submitted feedback with your name on it. :)

@DamienSolodow Great!  I found it!  I'll check with the team and follow up with any information.  



@Kelly_Y thanks!

Any news here?

@DamienSolodow Not yet!  The internal PM owner is currently out of the office but I'll make sure to follow up with them.  Thanks for your patience! 



@Kelly_Y Do we need to sic Missy on them? :lol:

They still hiding from you? :)

@DamienSolodow Still waiting for some info!  We'll keep you updated! :) 


Anything come up yet? This issue is holding up our rollout, and it's generating some pressure. :(

@DamienSolodow Sorry for the delay! 


I'm following up internally again.  :) 


Also, another option I wanted to mention is reaching out to MS Edge Support (https://microsoftedgesupport.microsoft.com/hc/en-us) they would be able to help investigate your specific case.  


But I will keep you updated when I get any updates.  Thanks! 



@DamienSolodow Quick update :)  We are going through internal testing and trying to reproduce. 


In the feedback you submitted, it says you are using Version 88.0.4324.182.  Are you still using the same or have you updated?  If you've updated, can you share the build number and if the issue is still reproducing or if there is any changes in the behavior?


Thanks for your help!



Just tried it on my test VM with Edge 89.0.774.57 (64-bit) Stable channel.
Same behavior. :(

Hi @DamienSolodowm, We did an internal test and were unable to reproduce the error.

Can you please help me with responses to couple of questions that may help us debug further


1. Have you set any other policy apart from the AutoImportatFirstRun? More specifically, please check the the policy for Import passwords is not set to disabled.

2. Can you confirm that passwords in question are visible in password manager page of chrome and are usable in chrome.




@HimanshuJain - the passwords are visible and usable in Chrome. Now, I did notice in Chrome that when I clicked the option to view the password, it prompted me for my Windows credentials. Once I gave it the password, it showed the password successfully.

There are a number of policies set, but Import Passwords is set to enabled. I can send you the policies.json if you email me, or I think I already sent it to Kelly_Y

@DamienSolodow Hi - I only received the user feedback which I don't think captures the policies.


If you send a message to @HimanshuJain you should be able to include the policies.json file as an attachment.  



Just messaged @himanshusJain with a procmon log. Hoping that helps reproduce or figure out what's going on.