SOLVED

Two taskbar icon if working with startmenu.xml

%3CLINGO-SUB%20id%3D%22lingo-sub-1989287%22%20slang%3D%22en-US%22%3ETwo%20taskbar%20icon%20if%20working%20with%20startmenu.xml%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1989287%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20are%20using%20a%20xml%20to%20set%20the%20startmenu%20and%20the%20pinned%20taskbar%20icon.%3C%2FP%3E%3CP%3EOur%20taskbar%20section%20in%20the%20XML%20looks%20like%3A%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-basic%22%3E%3CCODE%3E%3CCUSTOMTASKBARLAYOUTCOLLECTION%20pinlistplacement%3D%22Replace%22%3E%0A%20%20%20%20%20%20%3CTASKBARLAYOUT%3E%0A%20%20%3CTASKBARPINLIST%3E%0A%20%20%20%20%20%20%20%20%20%20%3CDESKTOPAPP%20desktopapplicationlinkpath%3D%22%25APPDATA%25%5CMicrosoft%5CWindows%5CStart%20Menu%5CPrograms%5CSystem%20Tools%5CFile%20Explorer.lnk%22%3E%3C%2FDESKTOPAPP%3E%0A%20%20%3CDESKTOPAPP%20desktopapplicationid%3D%22MSEdge%22%3E%3C%2FDESKTOPAPP%3E%0A%20%20%3C%2FTASKBARPINLIST%3E%0A%20%20%3C%2FTASKBARLAYOUT%3E%0A%20%3C%2FCUSTOMTASKBARLAYOUTCOLLECTION%3E%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAll%20looks%20fine%20and%20the%20Edge%20is%20pinned%20in%20the%20Taskbar.%3C%2FP%3E%3CP%3EAt%20the%20first%20start%20there%20are%20two%20icons%20in%20the%20taskbar%20a%20few%20seconds.%3C%2FP%3E%3CP%3EThen%20log%20out%20and%20log%20in%20now%20there%20are%20two%20Edge%20icons%20in%20the%20taskbar%26nbsp%3B%3CIMG%20class%3D%22lia-deferred-image%20lia-image-emoji%22%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Fhtml%2Fimages%2Femoticons%2Funamused_40x40.gif%22%20alt%3D%22%3Aunamused%3A%22%20title%3D%22%3Aunamused%3A%22%20%2F%3E.%3C%2FP%3E%3CP%3ESo%20I%20am%20checking%20the%20properties%20of%20them%20and%20see%20the%20target%20is%20different.%3C%2FP%3E%3CP%3EFirst%20icon%3A%20%22C%3A%5CProgram%20Files%20(x86)%5CMicrosoft%5CEdge%5CApplication%5Cmsedge.exe%22%20--profile-directory%3DDefault%3C%2FP%3E%3CP%3ESecond%20icon%3A%26nbsp%3B%22C%3A%5CProgram%20Files%20(x86)%5CMicrosoft%5CEdge%5CApplication%5Cmsedge.exe%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20I%20unpin%20the%20first%20icon%20and%20open%20edge%20with%20the%20second%20one%20the%20same%20happens%20as%20i%20mention%20above.%3C%2FP%3E%3CP%3EOnly%20one%20icon%20stays%2C%20but%20if%20I%20log%20out%20and%20log%20in%20the%20second%20one%20(from%20the%20xml)%20get%20pinned.%3C%2FP%3E%3CP%3EIf%20I%20unpin%20the%20second%20icon%20and%20open%20Edge%20the%20same%20happens%20as%20mentioned%20before.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20everytime%20the%20icon%20on%20the%20taskbar%20get%20changed%20to%26nbsp%3B%22C%3A%5CProgram%20Files%20(x86)%5CMicrosoft%5CEdge%5CApplication%5Cmsedge.exe%22%20--profile-directory%3DDefault%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAdditional%20information%3A%20If%20I%20do%20not%20pin%20Edge%20with%20the%20xml%20on%20the%20taskbar%20and%20open%20them%20out%20of%20the%20startmenu%20NO%20icon%20get%20pinned%20automatically.%3C%2FP%3E%3CP%3ESo%20this%20happens%20ONLY%20when%20open%20the%20taskbar%20pinned%20Edge!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThat%20behavior%20is%20super%20annoying%20and%20make%20no%20sense!%3C%2FP%3E%3CP%3EMicrosoft%20please%20fix%20this%20or%20let%20us%20know%20how%20we%20could%20add%20Edge%20to%20the%20xml!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2002347%22%20slang%3D%22en-US%22%3ERe%3A%20Two%20taskbar%20icon%20if%20working%20with%20startmenu.xml%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2002347%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F522208%22%20target%3D%22_blank%22%3E%40pilgi3%3C%2FA%3E%26nbsp%3BHello!%26nbsp%3B%20Thanks%20for%20your%20post!%26nbsp%3B%20Our%20developers%20have%20taken%20a%20look%20and%20the%20two%20MS%20Edge%20icons%20is%20indeed%20a%20bug.%26nbsp%3B%20They%20are%20currently%20working%20on%20a%20fix.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EOnce%20the%20change%20is%20available%2C%20you%20should%20be%20able%20to%20use%20the%20following%20entry%20in%20your%20XML%20for%20MS%20Edge%3A%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSTRONG%3E%3CDESKTOPAPP%3E%3C%2FDESKTOPAPP%3E%3C%2FSTRONG%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EWe'll%20follow%20up%20once%20the%20change%20is%20available!%26nbsp%3B%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CEM%3E-Kelly%3C%2FEM%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2005847%22%20slang%3D%22en-US%22%3ERe%3A%20Two%20taskbar%20icon%20if%20working%20with%20startmenu.xml%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2005847%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F757644%22%20target%3D%22_blank%22%3E%40Kelly_Y%3C%2FA%3E%26nbsp%3BThanks%20for%20your%20reply!%3C%2FP%3E%3CP%3EI%20tried%20so%20many%20things%20but%20nothing%20works%2C%20driving%20me%20a%20little%20bit%20crazy%26nbsp%3B%3CIMG%20class%3D%22lia-deferred-image%20lia-image-emoji%22%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Fhtml%2Fimages%2Femoticons%2Flaugh_40x40.gif%22%20alt%3D%22%3Alol%3A%22%20title%3D%22%3Alol%3A%22%20%2F%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EGood%20to%20know%20that%20this%20get%20fixed.%3C%2FP%3E%3CP%3EDo%20you%20will%20post%20when%20the%20fix%20was%20released%20or%20should%20I%20check%20the%20release%20notes%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2007944%22%20slang%3D%22en-US%22%3ERe%3A%20Two%20taskbar%20icon%20if%20working%20with%20startmenu.xml%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2007944%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F522208%22%20target%3D%22_blank%22%3E%40pilgi3%3C%2FA%3E%26nbsp%3BI'll%20try%20to%20make%20sure%20to%20update%20you%20here%20once%20it%20has%20been%20released!%26nbsp%3B%20Due%20to%20the%20holidays%2C%20it%20might%20get%20delayed%20until%20the%20new%20year.%26nbsp%3B%20But%20they%20are%20working%20on%20it!%26nbsp%3B%20Thanks!%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CEM%3E-Kelly%3C%2FEM%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2061277%22%20slang%3D%22en-US%22%3ERe%3A%20Two%20taskbar%20icon%20if%20working%20with%20startmenu.xml%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2061277%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3EI%20am%20also%20experiencing%20this%20issue%20in%20my%20company.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAdditionally%20if%20I%20unpin%20the%201st%20icon%20and%20restart%20explorer%20only%20one%20icon%20is%20in%20pinned%20to%20the%20taskbar.%20If%20I%20click%20on%20this%20icon%20edge%20starts%20in%20a%20separate%20icon.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20there%20any%20timeline%20on%20when%20the%20fix%20will%20be%20released%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2076767%22%20slang%3D%22en-US%22%3ERe%3A%20Two%20taskbar%20icon%20if%20working%20with%20startmenu.xml%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2076767%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F929252%22%20target%3D%22_blank%22%3E%40sonofvashon%3C%2FA%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F522208%22%20target%3D%22_blank%22%3E%40pilgi3%3C%2FA%3E%26nbsp%3BHello!%26nbsp%3B%20Thanks%20for%20your%20patience!%26nbsp%3B%20Our%20developer%20is%20busy%20working%20on%20the%20fix!%26nbsp%3B%20Hopefully%20we'll%20have%20some%20updates%20soon!%26nbsp%3B%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E-Kelly%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2107920%22%20slang%3D%22en-US%22%3ERe%3A%20Two%20taskbar%20icon%20if%20working%20with%20startmenu.xml%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2107920%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F757644%22%20target%3D%22_blank%22%3E%40Kelly_Y%3C%2FA%3E%26nbsp%3B%20Any%20news%20from%20your%20side%3F%20We%20are%20facing%20this%20issue%20too..%20Even%20in%20Edge%20Stable%2088.%20We%20want%20to%20deploy%20MS%20Edge%20Chromium%20group%20wide%20and%20everything's%20look%20fine.%20Just%20this%20tiny%20little%20annoying%20issue%20%3B)%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2108686%22%20slang%3D%22en-US%22%3ERe%3A%20Two%20taskbar%20icon%20if%20working%20with%20startmenu.xml%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2108686%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F947171%22%20target%3D%22_blank%22%3E%40MayerRe_1337%3C%2FA%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F522208%22%20target%3D%22_blank%22%3E%40pilgi3%3C%2FA%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F929252%22%20target%3D%22_blank%22%3E%40sonofvashon%3C%2FA%3E%26nbsp%3BHappy%20Friday%20everyone!%26nbsp%3B%20Our%20developer%20is%20doing%20some%20final%20testing.%26nbsp%3B%20Hopefully%20soon%20a%20fix%20will%20be%20available%20in%20a%20build%20that%20you%20folks%20can%20try%20out%26nbsp%3B%3CIMG%20class%3D%22lia-deferred-image%20lia-image-emoji%22%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Fhtml%2F%408341BD79091AF36AA2A09063B554B5CD%2Fimages%2Femoticons%2Fsmile_40x40.gif%22%20alt%3D%22%3Asmile%3A%22%20title%3D%22%3Asmile%3A%22%20%2F%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EWe'll%20follow%20up%20with%20updates!%26nbsp%3B%20Thanks!%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CEM%3E-Kelly%3C%2FEM%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2115139%22%20slang%3D%22en-US%22%3ERe%3A%20Two%20taskbar%20icon%20if%20working%20with%20startmenu.xml%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2115139%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F757644%22%20target%3D%22_blank%22%3E%40Kelly_Y%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20do%20not%20want%20to%20be%20impatiant%2C%20but%20is%20there%20a%20planned%20date%20for%20the%20release%20of%20the%20bugfixed%20version%20we%20can%20look%20forward%20to%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2118481%22%20slang%3D%22en-US%22%3ERe%3A%20Two%20taskbar%20icon%20if%20working%20with%20startmenu.xml%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2118481%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F757644%22%20target%3D%22_blank%22%3E%40Kelly_Y%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHello%2C%20I'm%20also%20checking%20to%20see%20if%20there%20is%20an%20update%20on%20this%20fix.%20My%20organization%20is%20looking%20to%20replace%20an%20IE%20taskbar%20shortcut%20we%20currently%20have%20currently%20have%20set%20in%20our%26nbsp%3BLayoutModification.xml%20with%20an%20Edge%20shortcut%20to%20increase%20adoption%20to%20Edge.%20However%20we%20are%20also%20seeing%20the%20problem%20with%20duplicate%20Edge%20icons%20when%20a%20pointer%20to%20Edge%20is%20in%20the%20xml%20file.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%2C%3C%2FP%3E%3CP%3ERyan%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2140619%22%20slang%3D%22en-US%22%3ERe%3A%20Two%20taskbar%20icon%20if%20working%20with%20startmenu.xml%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2140619%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F960052%22%20target%3D%22_blank%22%3E%40Ryancl25%3C%2FA%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F522208%22%20target%3D%22_blank%22%3E%40pilgi3%3C%2FA%3E%26nbsp%3B%40Deleted%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F929252%22%20target%3D%22_blank%22%3E%40sonofvashon%3C%2FA%3E%26nbsp%3BHi%20Everyone!%26nbsp%3B%20Quick%20update%2C%20we%20are%20being%20extremely%20careful%20with%20the%20rollout%20of%20this%20fix.%26nbsp%3B%20For%20consumer%20devices%2C%20we've%20released%20to%20Microsoft%20Edge%26nbsp%3BCanary%20builds%20(90.0.795.0%2B).%26nbsp%3B%20For%20enterprise%20devices%2C%20we%20will%20be%20monitoring%20feedback%20and%20planning%20to%20rollout%20soon.%26nbsp%3B%20We%20will%20keep%20you%20folks%20updated%20here!%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks%20for%20your%20patience!%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CEM%3E-Kelly%3C%2FEM%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

We are using a xml to set the startmenu and the pinned taskbar icon.

Our taskbar section in the XML looks like:

<CustomTaskbarLayoutCollection PinListPlacement="Replace">
      <defaultlayout:TaskbarLayout>
		<taskbar:TaskbarPinList>
          <taskbar:DesktopApp DesktopApplicationLinkPath="%APPDATA%\Microsoft\Windows\Start Menu\Programs\System Tools\File Explorer.lnk" />
		<taskbar:DesktopApp DesktopApplicationID="MSEdge" />
		</taskbar:TaskbarPinList>
		</defaultlayout:TaskbarLayout>
	</CustomTaskbarLayoutCollection>

 

All looks fine and the Edge is pinned in the Taskbar.

At the first start there are two icons in the taskbar a few seconds.

Then log out and log in now there are two Edge icons in the taskbar :unamused:.

So I am checking the properties of them and see the target is different.

First icon: "C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" --profile-directory=Default

Second icon: "C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe"

 

If I unpin the first icon and open edge with the second one the same happens as i mention above.

Only one icon stays, but if I log out and log in the second one (from the xml) get pinned.

If I unpin the second icon and open Edge the same happens as mentioned before.

 

So everytime the icon on the taskbar get changed to "C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" --profile-directory=Default

 

Additional information: If I do not pin Edge with the xml on the taskbar and open them out of the startmenu NO icon get pinned automatically.

So this happens ONLY when open the taskbar pinned Edge!

 

That behavior is super annoying and make no sense!

Microsoft please fix this or let us know how we could add Edge to the xml!

 

Thanks!

 

21 Replies

@pilgi3 Hello!  Thanks for your post!  Our developers have taken a look and the two MS Edge icons is indeed a bug.  They are currently working on a fix.  

 

Once the change is available, you should be able to use the following entry in your XML for MS Edge:

 

<taskbar:DesktopApp DesktopApplicationLinkPath="%appdata%\Microsoft\Internet Explorer\Quick Launch\Microsoft Edge.lnk" />

 

We'll follow up once the change is available!  

 

-Kelly

@Kelly_Y Thanks for your reply!

I tried so many things but nothing works, driving me a little bit crazy :lol:

 

Good to know that this get fixed.

Do you will post when the fix was released or should I check the release notes?

@pilgi3 I'll try to make sure to update you here once it has been released!  Due to the holidays, it might get delayed until the new year.  But they are working on it!  Thanks! 

 

-Kelly

Hello,

I am also experiencing this issue in my company. 

 

Additionally if I unpin the 1st icon and restart explorer only one icon is in pinned to the taskbar. If I click on this icon edge starts in a separate icon.

 

Is there any timeline on when the fix will be released?

@sonofvashon @pilgi3 Hello!  Thanks for your patience!  Our developer is busy working on the fix!  Hopefully we'll have some updates soon!  

 

-Kelly

@Kelly_Y  Any news from your side? We are facing this issue too.. Even in Edge Stable 88. We want to deploy MS Edge Chromium group wide and everything's look fine. Just this tiny little annoying issue ;)

@Deleted @pilgi3 @sonofvashon Happy Friday everyone!  Our developer is doing some final testing.  Hopefully soon a fix will be available in a build that you folks can try out :smile:

 

We'll follow up with updates!  Thanks! 

 

-Kelly

@Kelly_Y 

 

I do not want to be impatiant, but is there a planned date for the release of the bugfixed version we can look forward to?

@Kelly_Y 

 

Hello, I'm also checking to see if there is an update on this fix. My organization is looking to replace an IE taskbar shortcut we currently have currently have set in our LayoutModification.xml with an Edge shortcut to increase adoption to Edge. However we are also seeing the problem with duplicate Edge icons when a pointer to Edge is in the xml file.

 

Thanks,

Ryan

@Ryancl25 @pilgi3 @Deleted @sonofvashon Hi Everyone!  Quick update, we are being extremely careful with the rollout of this fix.  For consumer devices, we've released to Microsoft Edge Canary builds (90.0.795.0+).  For enterprise devices, we will be monitoring feedback and planning to rollout soon.  We will keep you folks updated here! 

 

Thanks for your patience! 

 

-Kelly

@Kelly_Y 

Thank you very much for the information!

I will test it with the canary version and provide feedback.

@Kelly_Y 
I have tested the DEV version 90.0.796.0 but same behavior.

Also as you mentioned the canary version is for consumer, so I can't test in our environment.

Because the canary version will always installed in the user profile even as system account.

So I wait for your next update here, thanks for your help!

@pilgi3 @Kelly_Y 

I just tested this with DEV version 90.0.796.0 downloaded from the Edge for business page.

With this version I was no longer able to reproduce the issues mentioned before when using the LayoutModification.xml.

 

Edit:

After retesting based on the instructions @pilgi3  provided I was also able to reproduce the issue.

@sonofvashon @Kelly_Y 
Because of your previous post @sonofvashon I tested with the Edge Dev again.

My findings are in the attached gif below but I explain my steps:

  1. At the first sign in there is only one Edge Dev icon in the taskbar.
  2. I opened the Edge Dev and there you can see two icons a few second before they will be migrated.
  3. Then I sign out.
  4. After signing in again there are two Edge Dev icons.
  5. Now I clicked the first icon and they will get migrated again.
  6. Sign out and in again.
  7. Still two icons here.
  8. I opened Edge with the second icon and they will get migrated again.
  9. Log out and in again and voila only one icon is in the taskbar and no second icon will be placed! :smile:

edge_dev.gif

 

So I checked both icons but could not see any differents

GeneralGeneralShortcutShortcut

 

I hope this feedback helps!

Thanks!

 

@pilgi3 @sonofvashon Thank you for the feedback!  If you are testing with an Enterprise device, I do not think you will be able to see the fix yet.  But we will keep you folks updated as we continue to evaluate and roll out.  

 

-Kelly

@Kelly_Y  Just adding myself to this thread as my organization is also having this issue, it's been plaguing us for quite a while now. I know it's being worked on, just want to make sure I am notified when the fix is out. I look forward to your reply with said update

@Kelly_Y 

I downloaded the new DEV version 90.0.803 and tested again.

Good news, because it works right now! :smile:

@sonofvashon maybe you could test in your environment and confirm?

 

 

@pilgi3 @Kelly_Y 

I tested with version 90.0.803.0 with the same procedure as @pilgi3 described earlier and I was not able to reproduce the issue any more.

So I can confirm the results from @pilgi3 that it is now working correctly.

@sonofvashon @pilgi3 Thanks for the feedback!  The current plan is to fully release the fix enabled to all customers in Edge V89 (Microsoft Edge release schedule | Microsoft Docs).  If there are any changes we will let you folks know.  

 

-Kelly

 

CC: @Fatal_Ignorance @Ryancl25