Theme defaults to "light" vs "system default" when signing in or declining to sign-in

%3CLINGO-SUB%20id%3D%22lingo-sub-1065718%22%20slang%3D%22en-US%22%3ETheme%20defaults%20to%20%22light%22%20vs%20%22system%20default%22%20when%20signing%20in%20or%20declining%20to%20sign-in%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1065718%22%20slang%3D%22en-US%22%3E%3CP%3ENoticed%20a%20bizarre%20behavior%20when%20launching%20edge%20for%20the%20first%20time%20with%20some%20a%20handful%20of%20group%20policies%20applied.%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F161733iC28D25F3A60A56BD%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_1.png%22%20title%3D%22clipboard_image_1.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F161732iA5851ACAE100C8EB%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F161736i2D14E18F4A936FD8%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_3.png%22%20title%3D%22clipboard_image_3.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoesn't%20matter%20if%20you%20sign-in%20or%20click%20confirm%20to%20skip%20sign-in%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F161737i8F0AB06E2BAE8384%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_4.png%22%20title%3D%22clipboard_image_4.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20will%20auto-set%20to%20%22light%22%20instead%20of%20%22system%20default%22%26nbsp%3B%3C%2FP%3E%3CP%3Eunable%20to%20force%20to%20%3Asystem%20default%3A%20theme%20with%20group%20policy%20so%20this%20is%20a%20bit%20annoying.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F161738iA143B8F8E6AA5064%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_5.png%22%20title%3D%22clipboard_image_5.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1067310%22%20slang%3D%22en-US%22%3ERe%3A%20Theme%20defaults%20to%20%22light%22%20vs%20%22system%20default%22%20when%20signing%20in%20or%20declining%20t%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1067310%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F462142%22%20target%3D%22_blank%22%3E%40trandall%3C%2FA%3E%26nbsp%3BAre%20you%20enabling%20sync%20on%20FirstRun%20Wizard%3F%20I'm%20wondering%20if%20the%20theme%20is%20being%20overridden%3F%20If%20you%20are%20enabling%20it%2C%20it's%20the%20default%20option%2C%20try%20disabling%20it.%20I've%20run%20a%20couple%20of%20tests%20of%20my%20own%2C%20we%20have%20a%20bunch%20more%20policies%2C%20with%20Edge%20Beta%2079.0.309.51%20(tad%20newer)%2C%26nbsp%3BWindows%2010%201909%20build%2018363.476%20in%20dark%20mode%20and%20on%20new%20profile%20creation%20the%20theme%20was%20set%20to%20%3CSTRONG%3ESystem%20default%3C%2FSTRONG%3E.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1068705%22%20slang%3D%22en-US%22%3ERe%3A%20Theme%20defaults%20to%20%22light%22%20vs%20%22system%20default%22%20when%20signing%20in%20or%20declining%20t%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1068705%22%20slang%3D%22en-US%22%3E%3CP%3EIt%20would%20really%20bum%20me%20out%20to%20disable%20setting%20up%20sync%20on%20first%20run%2C%20although%20I'm%20not%20forcing%20to%20setup%20sync%20and%20can%20easily%20be%20skipped.%20And%20when%20if%20first%20launches%20its%20clear%20that%20is%20set%20to%20system%20default%20(screenshots)%2C%20but%20as%20soon%20as%20you%20skip%20sync%20or%20sign-in%20either%20way%20it%20will%20auto%20switch%20to%20light%20for%20no%20obvious%20reason.%20Why%20default%20to%20%22light%22%20when%20there%20is%20a%20system%20default%20option%20that%20it%20SHOULD%20obviously%20default%20to.%20It's%20just%20a%20trivial%20bug%20but%20annoying%20me%20a%20great%20deal.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F162013iF4E9CD0EE7FBFBD3%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1069231%22%20slang%3D%22en-US%22%3ERe%3A%20Theme%20defaults%20to%20%22light%22%20vs%20%22system%20default%22%20when%20signing%20in%20or%20declining%20t%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1069231%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F462142%22%20target%3D%22_blank%22%3E%40trandall%3C%2FA%3E%26nbsp%3BI%20agree%2C%20sync%20is%20an%20awesome%20feature%20to%20have%20and%20I'm%20not%20suggesting%20you%20disable%20it%3B%26nbsp%3Bit's%20more%20a%20test%20to%20validate%20the%20behaviour%20of%20the%20FirstRun%20experience%20when%20sync%20is%20out%20of%20the%20picture.%20If%20Edge%20still%20had%20the%20%22Light%20theme%22%20when%20sync%20was%20disabled%20then%20it%20may%20be%20something%20local%2C%20or%20at%20least%20nothing%20in%20your%20sync%20profile.%26nbsp%3BIf%20it%20WAS%20stored%20in%20your%20sync%20profile%20then%20I'd%20have%20suggested%20to%20modify%20the%20theme%20back%20to%20%22System%20Default%22%2C%20verify%20the%20sync%20has%20taken%20place%20in%20%22%3CSPAN%3ELast%20Synced%22%20within%3C%2FSPAN%3E%26nbsp%3B%3CA%20href%3D%22edge%3A%2F%2Fsync-internals%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Eedge%3A%2F%2Fsync-internals%2F%3C%2FA%3E%26nbsp%3Band%20then%20try%20your%20testing%20again%20on%20a%20clean%20windows%20profile.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBy%20the%20sounds%20of%20it%20something%20sounds%20amiss%20-%20if%20it's%20any%20help%20I%20run%20the%20follow%20PowerShell%20to%20clear%20out%20all%20Edge%20references%20in%20the%20local%20user%20profile%20for%20all%20my%20testing%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-markup%22%3E%3CCODE%3E%23%20Kills%20procs%0AGet-Process%20*msedge*%20%7C%20Stop-Process%20-Force%0AStart-Sleep%20-Seconds%201%0A%0A%24EdgePaths%20%3D%20(%0A%20%20%20%20%22%24env%3ALOCALAPPDATA%5CMicrosoft%5CEdge%20Beta%22%2C%0A%20%20%20%20%22%24env%3AAPPDATA%5CMicrosoft%5CEdge%20Beta%22%2C%0A%20%20%20%20%22HKCU%3A%5CSoftware%5CMicrosoft%5CEdge%20Beta%22%2C%0A%20%20%20%20%22%24env%3ALOCALAPPDATA%5CMicrosoft%5CEdge%20Dev%22%2C%0A%20%20%20%20%22%24env%3AAPPDATA%5CMicrosoft%5CEdge%20Dev%22%2C%0A%20%20%20%20%22HKCU%3A%5CSoftware%5CMicrosoft%5CEdge%20Dev%22%0A%20%20%20%20)%0A%0AForeach%20(%24i%20in%20%24EdgePaths)%20%7B%0A%20%20%20%20If(Test-Path%20%24i)%20%7B%0A%20%20%20%20%20%20%20%20Write-host%20%22Removing%20%24i%22%20-ForegroundColor%20Cyan%0A%20%20%20%20%20%20%20%20Remove-Item%20-Path%20%24i%20-Recurse%20-Force%0A%20%20%20%20%20%20%20%20%7D%0A%7D%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1072762%22%20slang%3D%22en-US%22%3ERe%3A%20Theme%20defaults%20to%20%22light%22%20vs%20%22system%20default%22%20when%20signing%20in%20or%20declining%20t%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1072762%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F467665%22%20target%3D%22_blank%22%3E%40csrswalch%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20assistance!%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ewith%20sign-in%20disabled%20in%20group%20policy%20the%20behavior%20doesn't%20persist..%20Obviously%20I%20don't%20want%20sign-in%20disabled.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F162362i84927E2D255B5085%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1093183%22%20slang%3D%22en-US%22%3ERe%3A%20Theme%20defaults%20to%20%22light%22%20vs%20%22system%20default%22%20when%20signing%20in%20or%20declining%20t%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1093183%22%20slang%3D%22en-US%22%3E%3CP%3ESo%20no%20more%20assistance%20with%20this%20issue%3F%20That%20would%20be%20disappointing..%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1094084%22%20slang%3D%22en-US%22%3ERe%3A%20Theme%20defaults%20to%20%22light%22%20vs%20%22system%20default%22%20when%20signing%20in%20or%20declining%20t%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1094084%22%20slang%3D%22en-US%22%3EWhats%20the%20value%20of%20the%20theme%20setting%20on%20the%20old%20Edge%20Legacy%3F%3CBR%20%2F%3EAt%20first%20run%2C%20the%20New%20Edge%20migrates%20all%20the%20user%20data%20and%20setting%20from%20the%20old%20one%20so%20that%20user%20can%20move%20to%20the%20new%20browser%20version%20without%20any%20friction.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1094806%22%20slang%3D%22en-US%22%3ERe%3A%20Theme%20defaults%20to%20%22light%22%20vs%20%22system%20default%22%20when%20signing%20in%20or%20declining%20t%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1094806%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F317109%22%20target%3D%22_blank%22%3E%40rishavsharan%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20dark%20theme%20set%20by%20default%20via%20autounattend.xml%20when%20any%20new%20users%20signs%20in.%20despite%20this%20being%20set%20it%20appears%20that%20Legacy%20Edge%20still%20defaults%20to%20light..%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F164107i5CA151E31DAC5602%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22clipboard_image_1.png%22%20title%3D%22clipboard_image_1.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F164108i8C7E4C3367D3839A%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22clipboard_image_2.png%22%20title%3D%22clipboard_image_2.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20found%20the%20only%20workaround%20to%20maintain%20the%20system%20default%20theme%20is%20to%20close%20this%20dialog%20without%20signing%20in%20or%20clicking%20confirm..%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F164110iB358F42C56BC9BF8%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22clipboard_image_3.png%22%20title%3D%22clipboard_image_3.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Noticed a bizarre behavior when launching edge for the first time with some a handful of group policies applied. 

clipboard_image_1.png

clipboard_image_0.png

clipboard_image_3.png

 

Doesn't matter if you sign-in or click confirm to skip sign-in 

clipboard_image_4.png

 

It will auto-set to "light" instead of "system default" 

unable to force to :system default: theme with group policy so this is a bit annoying.

clipboard_image_5.png

 

Thanks

 

 

7 Replies
Highlighted

@trandall Are you enabling sync on FirstRun Wizard? I'm wondering if the theme is being overridden? If you are enabling it, it's the default option, try disabling it. I've run a couple of tests of my own, we have a bunch more policies, with Edge Beta 79.0.309.51 (tad newer), Windows 10 1909 build 18363.476 in dark mode and on new profile creation the theme was set to System default

Highlighted

It would really bum me out to disable setting up sync on first run, although I'm not forcing to setup sync and can easily be skipped. And when if first launches its clear that is set to system default (screenshots), but as soon as you skip sync or sign-in either way it will auto switch to light for no obvious reason. Why default to "light" when there is a system default option that it SHOULD obviously default to. It's just a trivial bug but annoying me a great deal.

 

clipboard_image_0.png

Highlighted

@trandall I agree, sync is an awesome feature to have and I'm not suggesting you disable it; it's more a test to validate the behaviour of the FirstRun experience when sync is out of the picture. If Edge still had the "Light theme" when sync was disabled then it may be something local, or at least nothing in your sync profile. If it WAS stored in your sync profile then I'd have suggested to modify the theme back to "System Default", verify the sync has taken place in "Last Synced" within edge://sync-internals/ and then try your testing again on a clean windows profile.

 

By the sounds of it something sounds amiss - if it's any help I run the follow PowerShell to clear out all Edge references in the local user profile for all my testing:

 

# Kills procs
Get-Process *msedge* | Stop-Process -Force
Start-Sleep -Seconds 1

$EdgePaths = (
    "$env:LOCALAPPDATA\Microsoft\Edge Beta",
    "$env:APPDATA\Microsoft\Edge Beta",
    "HKCU:\Software\Microsoft\Edge Beta",
    "$env:LOCALAPPDATA\Microsoft\Edge Dev",
    "$env:APPDATA\Microsoft\Edge Dev",
    "HKCU:\Software\Microsoft\Edge Dev"
    )

Foreach ($i in $EdgePaths) {
    If(Test-Path $i) {
        Write-host "Removing $i" -ForegroundColor Cyan
        Remove-Item -Path $i -Recurse -Force
        }
}

 

Highlighted

@csrswalch 

Thanks for assistance! 

 

with sign-in disabled in group policy the behavior doesn't persist.. Obviously I don't want sign-in disabled.

 

clipboard_image_0.png

Highlighted

So no more assistance with this issue? That would be disappointing..  

Highlighted
Whats the value of the theme setting on the old Edge Legacy?
At first run, the New Edge migrates all the user data and setting from the old one so that user can move to the new browser version without any friction.
Highlighted

@rishavsharan 

I have dark theme set by default via autounattend.xml when any new users signs in. despite this being set it appears that Legacy Edge still defaults to light.. 

 

clipboard_image_1.png

clipboard_image_2.png

 

I found the only workaround to maintain the system default theme is to close this dialog without signing in or clicking confirm..

clipboard_image_3.png