status_access_violation error on all pages

Occasional Visitor

i've previously used edge canary version succesfully, but after uninstalling and installing the dev version i now get a status_access_violation error on every page, incognito or settings pages all give the same error.

 

i've tried un-installing, re-installing, tried dev, beta and canary versions all give the same error.

 

Does anyone have any ideas how to get edge working again?

thanks

4 Replies

@Paul_Cooper Hello!  This question recently came up on Reddit and our awesome Community Manager Missy shared some great troubleshooting tips.  Sounds like you've already tried things but please take a look here: 

https://www.reddit.com/r/MicrosoftEdge/comments/lcwuvy/since_the_latest_update_ive_been_having_this/...

 

Thanks!

 

-Kelly

 

 

@Kelly_Y 

thanks for the reply, it did lead me somewhere...

i've managed to run edge succesfully via the command line:

msedge.exe --disable-features=RendererCodeIntegrity

 

Checking the event viewer I can see this being logged when i run edge with code integrity enabled:

Code Integrity determined that a process (\Device\HarddiskVolume3\Program Files (x86)\Microsoft\Edge\Application\msedge.exe) attempted to load \Device\HarddiskVolume3\Program Files\DELL\Dell Data Protection\Advanced Threat Prevention\CyMemDef64.dll that did not meet the Microsoft signing level requirements

 

should mention this is in a virtual desktop corporate machine which uses dell's advanced threat prevention running on my laptop.

running edge on the laptop directly works fine, so not really clear why the vm isn't happy.

chrome also shows these errors in the event viewer - but doesn't have issues running in the vm.

@paulcooper1675 Great to hear you've made some progress! 

 

I'm not sure the difference when you are using the VM but have you checked if your Dell Data Protection/Advanced Threat Prevention needs to be updated?  

 

-Kelly

@Kelly_Y 

 

i've tried checking for updates through the dell software but no updates are installed