Smartscreen not working / delay in downloading files

%3CLINGO-SUB%20id%3D%22lingo-sub-1419979%22%20slang%3D%22en-US%22%3ESmartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1419979%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENot%20sure%20if%20this%20belongs%20in%20the%20Enterprise%20section%20but%20here%20goes%3B%20we're%20currently%20implementing%20Edge%20as%20our%20new%20default%20browser%20(large%20healthcare%20organization)%20in%20our%20VDI%20environment.%20Besides%20this%20issue%2C%20everything%20is%20working%20as%20intended.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20issue%20we're%20facing%20is%20that%2C%20on%20our%20VDI%20platform%2C%20SmartScreen%20doesn't%20work%3A%3C%2FP%3E%3COL%3E%3CLI%3EWhen%20I%20test%20the%20demo.smartscreen.msft.net%20page%2C%20nothing%20happens%20-%20all%20the%20pages%20open%20without%20a%20warning.%3C%2FLI%3E%3CLI%3EDownloading%20files%20(we%20test%20this%20wit%20Notepad%2B%2B)%20have%20a%20significant%20delay%3B%20only%20after%20%2B-%2020%20sec%20you%20can%20see%20the%20download%20starting.%26nbsp%3B%3C%2FLI%3E%3CLI%3EThis%20leads%20me%20to%20believe%20that%20something%20is%20broken%20with%20regard%20to%20SmartScreen%20in%20Edge.%26nbsp%3B%3C%2FLI%3E%3C%2FOL%3E%3CP%3EI've%20tried%20different%20proxy%20settings%20(automatic%20vs%20fixed%20server%20entry)%2C%20disabled%20our%20Trend%20Micro%20AV%20solution%20but%20all%20without%20any%20result.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe're%20not%20seeing%20this%20on%20our%20fysical%20endpoints%20so%20there's%20something%20goin%20on%20in%20our%20VDI%20platform.%20Is%20there%20any%20logging%20in%20Edge%20regarding%20SmartScreen%20that%20could%20help%20us%20out%3F%20Note%2C%20the%20platform%20is%20still%20using%20Windows%207%20as%20the%20new%20platform%20with%20Windows%2010%20is%20not%20yet%20ready%20for%20production%20use.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe're%20using%20Edge%2081.x%20but%20newer%20versions%20have%20the%20same%20issue.%20I've%20attached%20a%20video%20of%20the%20delay%20when%20downloading%20a%20file.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1420464%22%20slang%3D%22en-US%22%3ERe%3A%20Smartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1420464%22%20slang%3D%22en-US%22%3EDoes%20it%20only%20happens%20on%20VDI%3F%3CBR%20%2F%3ETry%20disable%20all%20extensions%20in%20Microsoft%20Edge%20and%20see%20if%20problem%20persist%3F%3CBR%20%2F%3ETry%20report%20this%20issue%20through%20Feedback%20option%2C%20so%20Microsoft%20Edge%20team%20could%20investigate%20it.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1420491%22%20slang%3D%22en-US%22%3ERe%3A%20Smartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1420491%22%20slang%3D%22en-US%22%3EYes%2C%20we're%20only%20seeing%20this%20on%20VDI.%20Besides%20uBlock%20Origin%20we%20do%20not%20have%20any%20extensions%20installed%20-%20but%20even%20with%20that%20one%20removed%2C%20the%20issue%20persist.%20I%20did%20notice%20that%20when%20I%20install%20the%20Beta%2FDev%20channel%20next%20to%20the%20stable%20version%20we're%20rolling%20out%2C%20SmartScreen%20is%20working%20in%20Dev.%3CBR%20%2F%3E%3CBR%20%2F%3EThis%20lead%20me%20to%20believe%20that%20it%20might%20have%20been%20my%20Edge%20profile%20so%20I%20renamed%20%25localappdata%25%5CMicrosoft%5CEdge%20but%20that%20didn't%20work%20either.%3CBR%20%2F%3E%3CBR%20%2F%3EI'll%20try%20the%20Feedback%20option%2C%20thanks!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1425619%22%20slang%3D%22en-US%22%3ERe%3A%20Smartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1425619%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F680687%22%20target%3D%22_blank%22%3E%40marceldk%3C%2FA%3E%26nbsp%3BRegarding%20the%20demo%20pages%20not%20working%2C%20you%20can%20try%20checking%26nbsp%3B%3CA%20href%3D%22edge%3A%2F%2Fhistograms%2FMicrosoft.SmartScreen.ErrorState%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Eedge%3A%2F%2Fhistograms%2FMicrosoft.SmartScreen.ErrorState%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EFor%20the%20download%20delay%2C%20you%20can%20try%20disabling%20SmartScreen%20and%20then%20download%20the%20same%20file.%20If%20it%20is%20indeed%20due%20to%20SmartScreen%2C%20then%20Download%20should%20start%20instantaneously%20this%20time%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIn%20a%20fresh%20browser%20session%2C%20perform%20the%20repro%20and%20then%20%3CA%20href%3D%22edge%3A%2F%2Fhistograms%2FMicrosoft.SmartScreen%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Eedge%3A%2F%2Fhistograms%2FMicrosoft.SmartScreen%3C%2FA%3E%26nbsp%3Bshould%20give%20you%20some%20data%20around%20SmartScreen%20which%20can%20help%20pinpoint%20the%20problem%20further%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3Eor%20you%20can%20use%20edge%3A%2F%2Ftracing%20and%20enable%20the%20category%20'SmartScreen'%20which%20should%20give%20more%20details%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1432713%22%20slang%3D%22en-US%22%3ERe%3A%20Smartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1432713%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F682874%22%20target%3D%22_blank%22%3E%40bhkumar007%3C%2FA%3E%26nbsp%3Bthanks%20for%20the%20suggestions%2C%20never%20knew%20these%20items%20were%20available.%20I'm%20not%20sure%20what%20i'm%20looking%20at%20though%3B%20what%20does%200%2C%201%2C%202%20etc%20mean%20with%20these%20histogram%20results%20(these%20results%20are%20only%20when%20clicking%20a%20few%20of%20the%20demo%20items%20on%20demo.smartscreen.msft.net).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CPRE%3EHistogram%3A%20Microsoft.SmartScreen.ErrorState%20recorded%209%20samples%2C%20mean%20%3D%201.3%20(flags%20%3D%200x41)%3CBR%20%2F%3E0%20------------------------------------O%20(3%20%3D%2033.3%25)%3CBR%20%2F%3E1%20O%20(0%20%3D%200.0%25)%20%7B33.3%25%7D%3CBR%20%2F%3E2%20------------------------------------------------------------------------O%20(6%20%3D%2066.7%25)%20%7B33.3%25%7D%3CBR%20%2F%3E3%20...%3C%2FPRE%3E%3CPRE%3E%3CBR%20%2F%3EHistogram%3A%20Microsoft.SmartScreen.OnCompleteAsyncNoServiceTime%20recorded%209%20samples%2C%20mean%20%3D%2014034.3%20(flags%20%3D%200x41)%3CBR%20%2F%3E0%20------------------------------------------------------------O%20(1%20%3D%2011.1%25)%3CBR%20%2F%3E1%20O%20(0%20%3D%200.0%25)%20%7B11.1%25%7D%3CBR%20%2F%3E2%20------------------------------------------------------------O%20(1%20%3D%2011.1%25)%20%7B11.1%25%7D%3CBR%20%2F%3E3%20...%20%3CBR%20%2F%3E10%20------------------------------O%20(1%20%3D%2011.1%25)%20%7B22.2%25%7D%3CBR%20%2F%3E12%20...%20%3CBR%20%2F%3E10000%20------------------------------------------------------------------------O%20(6%20%3D%2066.7%25)%20%7B33.3%25%7D%3C%2FPRE%3E%3CPRE%3E%3CBR%20%2F%3EHistogram%3A%20Microsoft.SmartScreen.PuaProtectionEnabled%20recorded%201%20samples%2C%20mean%20%3D%200.0%20(flags%20%3D%200x41)%3CBR%20%2F%3E0%20------------------------------------------------------------------------O%20(1%20%3D%20100.0%25)%3CBR%20%2F%3E1%20...%3C%2FPRE%3E%3CPRE%3E%3CBR%20%2F%3EHistogram%3A%20Microsoft.SmartScreen.SetAsyncTime%20recorded%209%20samples%2C%20mean%20%3D%20570515.7%20(flags%20%3D%200x41)%3CBR%20%2F%3E0%20------------------------------------------------------------------------O%20(1%20%3D%2011.1%25)%3CBR%20%2F%3E1000%20...%20%3CBR%20%2F%3E2005%20------------------------------------------------------------------------O%20(1%20%3D%2011.1%25)%20%7B11.1%25%7D%3CBR%20%2F%3E2187%20...%20%3CBR%20%2F%3E3097%20------------------------------------------------------------------------O%20(1%20%3D%2011.1%25)%20%7B22.2%25%7D%3CBR%20%2F%3E3378%20...%20%3CBR%20%2F%3E9588%20------------------------------------------------------------------------O%20(1%20%3D%2011.1%25)%20%7B33.3%25%7D%3CBR%20%2F%3E10458%20------------------------------------------------------------------------O%20(1%20%3D%2011.1%25)%20%7B44.4%25%7D%3CBR%20%2F%3E11407%20O%20(0%20%3D%200.0%25)%20%7B55.6%25%7D%3CBR%20%2F%3E12443%20------------------------------------------------------------------------O%20(1%20%3D%2011.1%25)%20%7B55.6%25%7D%3CBR%20%2F%3E13573%20...%20%3CBR%20%2F%3E24936%20------------------------------------------------------------------------O%20(1%20%3D%2011.1%25)%20%7B66.7%25%7D%3CBR%20%2F%3E27200%20...%20%3CBR%20%2F%3E64858%20------------------------------------------------------------------------O%20(1%20%3D%2011.1%25)%20%7B77.8%25%7D%3CBR%20%2F%3E70746%20...%20%3CBR%20%2F%3E5000000%20------------------------------------------------------------------------O%20(1%20%3D%2011.1%25)%20%7B88.9%25%7D%3C%2FPRE%3E%3CPRE%3E%3CBR%20%2F%3EHistogram%3A%20Microsoft.SmartScreen.SmartScreenEnabled%20recorded%201%20samples%2C%20mean%20%3D%201.0%20(flags%20%3D%200x41)%3CBR%20%2F%3E0%20O%20(0%20%3D%200.0%25)%3CBR%20%2F%3E1%20------------------------------------------------------------------------O%20(1%20%3D%20100.0%25)%20%7B0.0%25%7D%3CBR%20%2F%3E2%20O%20(0%20%3D%200.0%25)%20%7B100.0%25%7D%3C%2FPRE%3E%3CPRE%3E%3CBR%20%2F%3EHistogram%3A%20Microsoft.SmartScreen.TimeoutState%20recorded%209%20samples%2C%20mean%20%3D%201.1%20(flags%20%3D%200x41)%3CBR%20%2F%3E0%20O%20(0%20%3D%200.0%25)%3CBR%20%2F%3E1%20------------------------------------------------------------------------O%20(8%20%3D%2088.9%25)%20%7B0.0%25%7D%3CBR%20%2F%3E2%20---------O%20(1%20%3D%2011.1%25)%20%7B88.9%25%7D%3CBR%20%2F%3E3%20...%3C%2FPRE%3E%3CPRE%3E%3CBR%20%2F%3EHistogram%3A%20Microsoft.SmartScreen.UrlCheckWentAsync%20recorded%209%20samples%2C%20mean%20%3D%201.0%20(flags%20%3D%200x41)%3CBR%20%2F%3E0%20O%20(0%20%3D%200.0%25)%3CBR%20%2F%3E1%20------------------------------------------------------------------------O%20(9%20%3D%20100.0%25)%20%7B0.0%25%7D%3CBR%20%2F%3E2%20O%20(0%20%3D%200.0%25)%20%7B100.0%25%7D%3C%2FPRE%3E%3CPRE%3E%3CBR%20%2F%3EHistogram%3A%20Microsoft.SmartScreen.UrlThreatType%20recorded%209%20samples%2C%20mean%20%3D%200.0%20(flags%20%3D%200x41)%3CBR%20%2F%3E0%20------------------------------------------------------------------------O%20(9%20%3D%20100.0%25)%3CBR%20%2F%3E1%20...%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1434149%22%20slang%3D%22en-US%22%3ERe%3A%20Smartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1434149%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F680687%22%20target%3D%22_blank%22%3E%40marceldk%3C%2FA%3E%26nbsp%3B2%20indicates%20the%20internal%20code%20error%20in%20SmartScreen%20(looks%20like%20it%20is%20related%20to%20environment%20you%20are%20using).%20Can%20you%20run%20edge%3A%2F%2Ftracing%20with%20SmartScreen%20category%3F%20If%20there%20is%20any%20error%20message%20in%20there%2C%20that%20will%20help%20pinpoint%20the%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1435217%22%20slang%3D%22en-US%22%3ERe%3A%20Smartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1435217%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F682874%22%20target%3D%22_blank%22%3E%40bhkumar007%3C%2FA%3E%26nbsp%3BI've%20had%20to%20capture%20from%20start-up%20(used%20the%20info%26nbsp%3B%40%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fwww.chromium.org%2Fdevelopers%2Fhow-tos%2Ftrace-event-profiling-tool%2Frecording-tracing-runs%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noreferrer%22%3Ehttps%3A%2F%2Fwww.chromium.org%2Fdevelopers%2Fhow-tos%2Ftrace-event-profiling-tool%2Frecording-tracing-runs%3C%2FA%3E)%20to%20catch%20these%20events.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CPRE%3EC%3A%5CProgram%20Files%20(x86)%5CMicrosoft%5CEdge%5CApplication%26gt%3Bmsedge.exe%20demo.smartscreen.msft.net%20--trace-startup%20--trace-startup-file%3DH%3A%5Ctrace_startup.json%20--trace-startup-duration%3D5%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CPRE%3ETitle%20%3CBR%20%2F%3ETelemetryDatapoint%3A%3Adata_name%20%3Amagnifying_glass_tilted_left%3A%3CBR%20%2F%3ECategory%20SmartScreen%3CBR%20%2F%3EUser%20Friendly%20Category%20other%3CBR%20%2F%3EStart%20%3CBR%20%2F%3E339%2C512%20ms%3CBR%20%2F%3EArgs%3CBR%20%2F%3Edata_name%20%3CBR%20%2F%3E%22message%22%3CBR%20%2F%3Eevent_name%20%3CBR%20%2F%3E%22Microsoft.Defender.SmartScreen.Error%22%3C%2FPRE%3E%3CPRE%3ETitle%20%3CBR%20%2F%3ETelemetryDatapoint%3A%3Adata_value%20%3Amagnifying_glass_tilted_left%3A%3CBR%20%2F%3ECategory%20SmartScreen%3CBR%20%2F%3EUser%20Friendly%20Category%20other%3CBR%20%2F%3EStart%20%3CBR%20%2F%3E339%2C586%20ms%3CBR%20%2F%3EArgs%3CBR%20%2F%3Edata_value%20%3CBR%20%2F%3E%7Bcode%3A%2022%2C%3CBR%20%2F%3Ecall_stack%3A%20%7Bframes%3A%20%5B%7Bfile%3A%20%22delay_load.h%22%2C%3CBR%20%2F%3Eline%3A%2086%7D%5D%7D%2C%3CBR%20%2F%3Econtext%3A%20%5B%22RtlGetDeviceFamilyInfoEnum%3A%20Invalid%20argument%22%5D%7D%3CBR%20%2F%3Eevent_name%20%3CBR%20%2F%3E%22Microsoft.Defender.SmartScreen.Error%22%3C%2FPRE%3E%3CPRE%3ETitle%20%3CBR%20%2F%3ETelemetryDatapoint%3A%3Adata_name%20%3Amagnifying_glass_tilted_left%3A%3CBR%20%2F%3ECategory%20SmartScreen%3CBR%20%2F%3EUser%20Friendly%20Category%20other%3CBR%20%2F%3EStart%20%3CBR%20%2F%3E339%2C593%20ms%3CBR%20%2F%3EArgs%3CBR%20%2F%3Edata_name%20%3CBR%20%2F%3E%22client_version%22%3CBR%20%2F%3Eevent_name%20%3CBR%20%2F%3E%22Microsoft.Defender.SmartScreen.Error%22%3C%2FPRE%3E%3CPRE%3ETitle%20%3CBR%20%2F%3ETelemetryDatapoint%3A%3Adata_value%20%3Amagnifying_glass_tilted_left%3A%3CBR%20%2F%3ECategory%20SmartScreen%3CBR%20%2F%3EUser%20Friendly%20Category%20other%3CBR%20%2F%3EStart%20%3CBR%20%2F%3E339%2C597%20ms%3CBR%20%2F%3EArgs%3CBR%20%2F%3Edata_value%20%3CBR%20%2F%3E%221.1.1912.3%22%3CBR%20%2F%3Eevent_name%20%3CBR%20%2F%3E%22Microsoft.Defender.SmartScreen.Error%22%3C%2FPRE%3E%3CP%3E%26nbsp%3BThe%20clientversion%20matches%20the%20libsmartscreen.dll%20version%20in%20the%20C%3A%5CProgram%20Files%20(x86)%5CMicrosoft%5CEdge%5CApplication%5C81.0.416.64%20folder.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEdit%2C%20looks%20like%20I%20skipped%20over%20some%20events%2C%20most%20of%20them%20are%20the%20same%20as%20above%20but%20this%20one%20is%20different%20(and%20a%20little%20later%20on%20in%20the%20trace)%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CPRE%3Edata_value%20%3CBR%20%2F%3E%7Bcode%3A%2022%2C%3CBR%20%2F%3Ecall_stack%3A%20%7Bframes%3A%20%5B%7Bfile%3A%20%22delay_load.h%22%2C%3CBR%20%2F%3Eline%3A%2077%7D%5D%7D%2C%3CBR%20%2F%3Econtext%3A%20%5B%22wldp.dll%22%5D%7D%3CBR%20%2F%3Eevent_name%20%3CBR%20%2F%3E%22Microsoft.Defender.SmartScreen.Error%22%3C%2FPRE%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1435453%22%20slang%3D%22en-US%22%3ERe%3A%20Smartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1435453%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F680687%22%20target%3D%22_blank%22%3E%40marceldk%3C%2FA%3E%26nbsp%3BThanks%20for%20sharing%20the%20details.%20It%20does%20give%20an%20idea%20on%20where%20the%20issue%20lies.%20Can%20you%20share%20the%20details%20on%20OS%20version%2Farchitecture%2Fsku%20you%20are%20using%3F%20I%20don't%20see%20the%20issue%20on%20a%20regular%20Win7%20machine%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1435514%22%20slang%3D%22en-US%22%3ERe%3A%20Smartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1435514%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F682874%22%20target%3D%22_blank%22%3E%40bhkumar007%3C%2FA%3E%26nbsp%3Bthis%20is%20Windows%207%20Enterprise%206.1.7601%20SP1%2C%20x64.%20Running%20on%20an%20Intel%20Xeon%20CPU%20E5-2680%20v2%20with%205GB's%20of%20RAM%20with%20Dutch%20language%20settings.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20noticed%20that%20when%20I%20install%20the%20Beta%20build%20(or%20Dev)%20next%20to%20the%20stable%2081.x%20version%2C%20SmartScreen%20does%20work%20in%20%3CU%3Ethat%3C%2FU%3E%20browser.%20But%20we've%20reinstalled%20this%2081.x%20a%20few%20times%20now%20but%20no%20changes%20in%20behaviour.%20The%20difference%20being%20that%20the%2081.x%20is%20installed%20during%20our%20automatic%20process%20with%20ConfigMgr's%20Task%20Sequences%20to%20build%20the%20new%20VDI%20images%20and%20the%20Beta%2FDev%20build%20is%20installed%20manually%20in%20this%20case.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1436408%22%20slang%3D%22en-US%22%3ERe%3A%20Smartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1436408%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F680687%22%20target%3D%22_blank%22%3E%40marceldk%3C%2FA%3E%26nbsp%3Bfrom%20what%20you%20are%20saying%20it%20looks%20more%20that%20the%20user%20context%20or%20installer%20media%20from%20where%20the%20install%20is%20done%20during%20the%20TS%20is%20of%20influence%20or%20the%20install%20media.%3C%2FP%3E%3CP%3EAre%20you%20using%20the%20MSI%20during%20the%20TS%20I%20presume%3F%20What%20are%20you%20using%20when%20installing%20manually%3F%20MSI%20or%20C2R%3F%3C%2FP%3E%3CP%3EWhy%20not%20deploy%20Edge%20after%20the%20TS%20from%20SCCM%2C%20just%20select%20stable%20channel%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1439238%22%20slang%3D%22en-US%22%3ERe%3A%20Smartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1439238%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F400875%22%20target%3D%22_blank%22%3E%40Henno_Keers%3C%2FA%3E%26nbsp%3Byes%2C%20I'm%20using%20the%20MSI%20to%20install%20Edge%20during%20TS%20and%20I've%20used%20the%20C2R%20with%20Beta%2FDev.%20I%20*think*%20I've%20also%20used%20the%20MSI%20to%20install%20Beta%2FDev%20next%20to%20Stable%20but%20I'm%20going%20to%20try%20that%20again.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20reason%20why%20we're%20installing%20the%20MSI%20during%20the%20TS%20is%20because%20of%20the%20automated%20image%20creation%3B%20after%20the%20TS%20is%20ready%2C%20the%20image%20is%20captured%20and%20used%20for%20our%20VDI%20platform.%20One%20of%20the%20final%20steps%20is%20removing%20the%20configmgr%20agent%20(no%20use%20for%20that%20in%20a%20non-persistant%20environment)%20so%20pushing%20software%20%3CEM%3Eafter%3C%2FEM%3E%20the%20TS%20is%20not%20an%20option.%20For%20the%20sake%20of%20troubleshooting%20I%20can%20manually%20install%20Edge%20after%20TS%20and%20then%20capture%20this%20image%2C%20to%20see%20if%20smartscreen%20is%20still%20broken.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1439307%22%20slang%3D%22en-US%22%3ERe%3A%20Smartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1439307%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F680687%22%20target%3D%22_blank%22%3E%40marceldk%3C%2FA%3E%26nbsp%3BThe%20white%20elephant%20in%20the%20room%20is%20the%20%22IS%20Not%22%20object.%20The%20object%20that%20should%20%2F%20could%20have%20the%20deviation%2C%20but%20does%20not%20have%20it.%3C%2FP%3E%3CP%3EThat%20platform%20%2Fobject%20is%20different%20to%20the%20platform%20%2F%20object%20that%20has%20the%20deviation.%20What%20are%20de%20differences%3F%3C%2FP%3E%3CP%3EIS%3A%20VDI%20platform%3C%2FP%3E%3CP%3EIS%20Not%3A%20physical%20machines%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1439309%22%20slang%3D%22en-US%22%3ERe%3A%20Smartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1439309%22%20slang%3D%22en-US%22%3EI%20ran%20the%20TS%20with%20no%20Edge%20installer%20so%20I%20could%20install%20Edge%20manually%3B%20looks%20like%20we%20have%20an%20issue%20with%20all%20the%2081.x%20builds%20available%20for%20download.%20Non%20of%20these%20trigger%20the%20smartscreen%20warnings%20on%20demo.smartscreen.msft.net.%3CBR%20%2F%3E%3CBR%20%2F%3EAfter%20installing%20the%2083.x%20builds%2C%20smartscreen%20is%20triggered!%20Now%20I'm%20starting%20to%20doubt%20my%20first%20post%20because%20I%20did%20install%20newer%20versions%20but%20..%20maybe%20just%2081.x%20builds%3F%20Not%20sure%20anymore.%20This%2083.x%20MSI%20install%20does%20match%20my%20findings%20with%20the%20Dev%2FBeta%20builds%20with%20C2R%3B%20these%20are%20ofcourse%20%26gt%3B%2081.x.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1439313%22%20slang%3D%22en-US%22%3ERe%3A%20Smartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1439313%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F680687%22%20target%3D%22_blank%22%3E%40marceldk%3C%2FA%3E%26nbsp%3Bwe%20are%20already%20on%2083%20so%20I%20could%20not%20reproduce%20your%20issue%2C%20I%20saw%20the%20posting%20just%20to%20late.%3C%2FP%3E%3CP%3EBut%20what%20is%20the%20point%20in%20looking%20back%20if%2083%20works%3F%2081%20is%20history.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1439337%22%20slang%3D%22en-US%22%3ERe%3A%20Smartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1439337%22%20slang%3D%22en-US%22%3EWe're%20about%20to%20start%20a%20company%20wide%20rollout%20and%20did%20all%20our%20testing%20with%2081.x.%20We%20planned%20on%20upgrading%20to%20the%20newest%20version%20very%20soon%20after%20the%20rollout.%20I%20agree%20that%20there%20is%20no%20point%20in%20figuring%20this%20out%20now%2C%20since%20it%20seems%20to%20work%20with%2083.x%20and%20higher.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1439343%22%20slang%3D%22en-US%22%3ERe%3A%20Smartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1439343%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F680687%22%20target%3D%22_blank%22%3E%40marceldk%3C%2FA%3E%26nbsp%3BSucces%20with%20the%20rollout!%26nbsp%3B%20Greetings%20to%20Ronald%20van%20der%20Plas.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1440282%22%20slang%3D%22en-US%22%3ERe%3A%20Smartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1440282%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F400875%22%20target%3D%22_blank%22%3E%40Henno_Keers%3C%2FA%3E%26nbsp%3Bthanks%2C%20guess%20it's%20a%20small%20world%20after%20all%20%3B)%3C%2Fimg%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegarding%20the%20issue%3B%20I've%20successfully%20deployed%20a%20new%20non-persistent%20VDI%20image%20with%20Edge%2083.x%20and%20Smartscreen%20is%20working%20in%20that%20image.%20Not%20sure%20what's%20wrong%20with%2081.x%20on%20that%20platform%20but%20upgrading%20to%20the%20newer%20release%20will%20happen%20sooner%20then%20later%20anyway.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20all%20the%20help%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F682874%22%20target%3D%22_blank%22%3E%40bhkumar007%3C%2FA%3E%2C%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F13441%22%20target%3D%22_blank%22%3E%40Reza%20Ameri%3C%2FA%3E%26nbsp%3Band%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F400875%22%20target%3D%22_blank%22%3E%40Henno_Keers%3C%2FA%3E.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1440300%22%20slang%3D%22en-US%22%3ERe%3A%20Smartscreen%20not%20working%20%2F%20delay%20in%20downloading%20files%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1440300%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F680687%22%20target%3D%22_blank%22%3E%40marceldk%3C%2FA%3E%26nbsp%3Bwelcome%2C%20the%20actual%20help%20done%20with%20Microsoft%20Edge%20engineering%20teams.%3C%2FP%3E%0A%3CP%3EWhen%20you%20run%20into%20such%20incidents%20make%20sure%20share%20feedback%20through%20feedback%20option%20in%20Microsoft%20Edge.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi,

 

Not sure if this belongs in the Enterprise section but here goes; we're currently implementing Edge as our new default browser (large healthcare organization) in our VDI environment. Besides this issue, everything is working as intended.

 

The issue we're facing is that, on our VDI platform, SmartScreen doesn't work:

  1. When I test the demo.smartscreen.msft.net page, nothing happens - all the pages open without a warning.
  2. Downloading files (we test this wit Notepad++) have a significant delay; only after +- 20 sec you can see the download starting. 
  3. This leads me to believe that something is broken with regard to SmartScreen in Edge. 

I've tried different proxy settings (automatic vs fixed server entry), disabled our Trend Micro AV solution but all without any result. 

 

We're not seeing this on our fysical endpoints so there's something goin on in our VDI platform. Is there any logging in Edge regarding SmartScreen that could help us out? We've disable the Windows Defender service because we're using a different AV product but even with the service enabled, there is no change in the observed behaviour. 

 

We're using Edge 81.x but newer versions have the same issue. I've attached a video of the delay when downloading a file. 

 

Note, the platform is still using Windows 7 as the new platform with Windows 10 is not yet ready for production use. 

17 Replies
Does it only happens on VDI?
Try disable all extensions in Microsoft Edge and see if problem persist?
Try report this issue through Feedback option, so Microsoft Edge team could investigate it.
Yes, we're only seeing this on VDI. Besides uBlock Origin we do not have any extensions installed - but even with that one removed, the issue persist. I did notice that when I install the Beta/Dev channel next to the stable version we're rolling out, SmartScreen is working in Dev.

This lead me to believe that it might have been my Edge profile so I renamed %localappdata%\Microsoft\Edge but that didn't work either.

I'll try the Feedback option, thanks!

@marceldk Regarding the demo pages not working, you can try checking edge://histograms/Microsoft.SmartScreen.ErrorState 

 

For the download delay, you can try disabling SmartScreen and then download the same file. If it is indeed due to SmartScreen, then Download should start instantaneously this time

 

In a fresh browser session, perform the repro and then edge://histograms/Microsoft.SmartScreen should give you some data around SmartScreen which can help pinpoint the problem further

 

or you can use edge://tracing and enable the category 'SmartScreen' which should give more details

@bhkumar007 thanks for the suggestions, never knew these items were available. I'm not sure what i'm looking at though; what does 0, 1, 2 etc mean with these histogram results (these results are only when clicking a few of the demo items on demo.smartscreen.msft.net).

 

Histogram: Microsoft.SmartScreen.ErrorState recorded 9 samples, mean = 1.3 (flags = 0x41)
0 ------------------------------------O (3 = 33.3%)
1 O (0 = 0.0%) {33.3%}
2 ------------------------------------------------------------------------O (6 = 66.7%) {33.3%}
3 ...

Histogram: Microsoft.SmartScreen.OnCompleteAsyncNoServiceTime recorded 9 samples, mean = 14034.3 (flags = 0x41)
0 ------------------------------------------------------------O (1 = 11.1%)
1 O (0 = 0.0%) {11.1%}
2 ------------------------------------------------------------O (1 = 11.1%) {11.1%}
3 ...
10 ------------------------------O (1 = 11.1%) {22.2%}
12 ...
10000 ------------------------------------------------------------------------O (6 = 66.7%) {33.3%}

Histogram: Microsoft.SmartScreen.PuaProtectionEnabled recorded 1 samples, mean = 0.0 (flags = 0x41)
0 ------------------------------------------------------------------------O (1 = 100.0%)
1 ...

Histogram: Microsoft.SmartScreen.SetAsyncTime recorded 9 samples, mean = 570515.7 (flags = 0x41)
0 ------------------------------------------------------------------------O (1 = 11.1%)
1000 ...
2005 ------------------------------------------------------------------------O (1 = 11.1%) {11.1%}
2187 ...
3097 ------------------------------------------------------------------------O (1 = 11.1%) {22.2%}
3378 ...
9588 ------------------------------------------------------------------------O (1 = 11.1%) {33.3%}
10458 ------------------------------------------------------------------------O (1 = 11.1%) {44.4%}
11407 O (0 = 0.0%) {55.6%}
12443 ------------------------------------------------------------------------O (1 = 11.1%) {55.6%}
13573 ...
24936 ------------------------------------------------------------------------O (1 = 11.1%) {66.7%}
27200 ...
64858 ------------------------------------------------------------------------O (1 = 11.1%) {77.8%}
70746 ...
5000000 ------------------------------------------------------------------------O (1 = 11.1%) {88.9%}

Histogram: Microsoft.SmartScreen.SmartScreenEnabled recorded 1 samples, mean = 1.0 (flags = 0x41)
0 O (0 = 0.0%)
1 ------------------------------------------------------------------------O (1 = 100.0%) {0.0%}
2 O (0 = 0.0%) {100.0%}

Histogram: Microsoft.SmartScreen.TimeoutState recorded 9 samples, mean = 1.1 (flags = 0x41)
0 O (0 = 0.0%)
1 ------------------------------------------------------------------------O (8 = 88.9%) {0.0%}
2 ---------O (1 = 11.1%) {88.9%}
3 ...

Histogram: Microsoft.SmartScreen.UrlCheckWentAsync recorded 9 samples, mean = 1.0 (flags = 0x41)
0 O (0 = 0.0%)
1 ------------------------------------------------------------------------O (9 = 100.0%) {0.0%}
2 O (0 = 0.0%) {100.0%}

Histogram: Microsoft.SmartScreen.UrlThreatType recorded 9 samples, mean = 0.0 (flags = 0x41)
0 ------------------------------------------------------------------------O (9 = 100.0%)
1 ...

 

@marceldk 2 indicates the internal code error in SmartScreen (looks like it is related to environment you are using). Can you run edge://tracing with SmartScreen category? If there is any error message in there, that will help pinpoint the issue.

@bhkumar007 I've had to capture from start-up (used the info @ https://www.chromium.org/developers/how-tos/trace-event-profiling-tool/recording-tracing-runs) to catch these events. 

 

C:\Program Files (x86)\Microsoft\Edge\Application>msedge.exe demo.smartscreen.msft.net --trace-startup --trace-startup-file=H:\trace_startup.json --trace-startup-duration=5

 

Title 
TelemetryDatapoint::data_name 🔍
Category SmartScreen
User Friendly Category other
Start
339,512 ms
Args
data_name
"message"
event_name
"Microsoft.Defender.SmartScreen.Error"
Title 
TelemetryDatapoint::data_value 🔍
Category SmartScreen
User Friendly Category other
Start
339,586 ms
Args
data_value
{code: 22,
call_stack: {frames: [{file: "delay_load.h",
line: 86}]},
context: ["RtlGetDeviceFamilyInfoEnum: Invalid argument"]}
event_name
"Microsoft.Defender.SmartScreen.Error"
Title 
TelemetryDatapoint::data_name 🔍
Category SmartScreen
User Friendly Category other
Start
339,593 ms
Args
data_name
"client_version"
event_name
"Microsoft.Defender.SmartScreen.Error"
Title 
TelemetryDatapoint::data_value 🔍
Category SmartScreen
User Friendly Category other
Start
339,597 ms
Args
data_value
"1.1.1912.3"
event_name
"Microsoft.Defender.SmartScreen.Error"

 The clientversion matches the libsmartscreen.dll version in the C:\Program Files (x86)\Microsoft\Edge\Application\81.0.416.64 folder. 

 

Edit, looks like I skipped over some events, most of them are the same as above but this one is different (and a little later on in the trace):

 

data_value 
{code: 22,
call_stack: {frames: [{file: "delay_load.h",
line: 77}]},
context: ["wldp.dll"]}
event_name
"Microsoft.Defender.SmartScreen.Error"

@marceldk Thanks for sharing the details. It does give an idea on where the issue lies. Can you share the details on OS version/architecture/sku you are using? I don't see the issue on a regular Win7 machine

@bhkumar007 this is Windows 7 Enterprise 6.1.7601 SP1, x64. Running on an Intel Xeon CPU E5-2680 v2 with 5GB's of RAM with Dutch language settings. 

 

I've noticed that when I install the Beta build (or Dev) next to the stable 81.x version, SmartScreen does work in that browser. But we've reinstalled this 81.x a few times now but no changes in behaviour. The difference being that the 81.x is installed during our automatic process with ConfigMgr's Task Sequences to build the new VDI images and the Beta/Dev build is installed manually in this case. 

@marceldk from what you are saying it looks more that the user context or installer media from where the install is done during the TS is of influence or the install media.

Are you using the MSI during the TS I presume? What are you using when installing manually? MSI or C2R?

Why not deploy Edge after the TS from SCCM, just select stable channel?

 

 

@Henno_Keers yes, I'm using the MSI to install Edge during TS and I've used the C2R with Beta/Dev. I *think* I've also used the MSI to install Beta/Dev next to Stable but I'm going to try that again. 

 

The reason why we're installing the MSI during the TS is because of the automated image creation; after the TS is ready, the image is captured and used for our VDI platform. One of the final steps is removing the configmgr agent (no use for that in a non-persistant environment) so pushing software after the TS is not an option. For the sake of troubleshooting I can manually install Edge after TS and then capture this image, to see if smartscreen is still broken. 

@marceldk The white elephant in the room is the "IS Not" object. The object that should / could have the deviation, but does not have it.

That platform /object is different to the platform / object that has the deviation. What are de differences?

IS: VDI platform

IS Not: physical machines

I ran the TS with no Edge installer so I could install Edge manually; looks like we have an issue with all the 81.x builds available for download. Non of these trigger the smartscreen warnings on demo.smartscreen.msft.net.

After installing the 83.x builds, smartscreen is triggered! Now I'm starting to doubt my first post because I did install newer versions but .. maybe just 81.x builds? Not sure anymore. This 83.x MSI install does match my findings with the Dev/Beta builds with C2R; these are ofcourse > 81.x.

@marceldk we are already on 83 so I could not reproduce your issue, I saw the posting just to late.

But what is the point in looking back if 83 works? 81 is history.

We're about to start a company wide rollout and did all our testing with 81.x. We planned on upgrading to the newest version very soon after the rollout. I agree that there is no point in figuring this out now, since it seems to work with 83.x and higher.

@marceldk Succes with the rollout!  Greetings to Ronald van der Plas.

@Henno_Keers thanks, guess it's a small world after all ;)

 

Regarding the issue; I've successfully deployed a new non-persistent VDI image with Edge 83.x and Smartscreen is working in that image. Not sure what's wrong with 81.x on that platform but upgrading to the newer release will happen sooner then later anyway.

 

Thanks for all the help @bhkumar007@Reza_Ameri-Archived and @Henno_Keers.

@marceldk welcome, the actual help done with Microsoft Edge engineering teams.

When you run into such incidents make sure share feedback through feedback option in Microsoft Edge.