showmodaldialog から Window.open を開いた時の挙動が異なる

%3CLINGO-SUB%20id%3D%22lingo-sub-3051132%22%20slang%3D%22ja-JP%22%3EDifferent%20behavior%20when%20opening%20Window.open%20from%20showmodaldialog%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3051132%22%20slang%3D%22ja-JP%22%3E%3CP%3EIn%20EDGE's%20IE%20mode%3C%2FP%3E%3CP%3EWhen%20you%20open%20Window.open%20from%20showmodaldialog%3C%2FP%3E%3CP%3E%3CSPAN%3EHKEY_LOCAL_MACHINE%3C%2FSPAN%3E%3CBR%20%2F%3E%20%3CSPAN%3ESOFTWARE%5CMicrosoft%5CWindows%5CCurrentVersion%5Cpolicies%5Csystem%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EEnableLUA%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EThe%20behavior%20is%20different%20at%200%20and%201.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3E1%3A%20When%20enabled%2C%20it%20will%20stand%20up%20in%20EDGE's%20IE%20mode.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E0%3A%20If%20disabled%2C%20IE%20will%20stand%20up%20instead%20of%20EDGE's%20IE%20mode.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhy%20does%20this%20movement%20change%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20environment%20is%20as%20follows%2C%20but%20we%20have%20confirmed%20that%20it%20has%20occurred%20in%20other%20versions.%3C%2FP%3E%3CDIV%20class%3D%22%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22%22%3E%3CSPAN%20class%3D%22%22%3EMicrosoft%20Edge%20version%3C%2FSPAN%3E%20%3CSPAN%20class%3D%22%22%3E%3CSPAN%20class%3D%22%22%3E96.0.1054.62%20(official%20build)%20(64-bit)%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%20class%3D%22%22%3E%3CDIV%20class%3D%22%22%3E%3CSPAN%20class%3D%22%22%3EWindows%20Version%3C%2FSPAN%3E%20%3CSPAN%20class%3D%22%22%3E%3CSPAN%20class%3D%22%22%3EWindows%2010%20Version%2020H2%20(Build%2019042.1415)%20(64-bit)%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%20class%3D%22%22%3E%3CSPAN%20class%3D%22%22%3EInternet%20Explorer%20Mode%20Adapter%20Version%3C%2FSPAN%3E%20%3CSPAN%20class%3D%22%22%3E%3CSPAN%20class%3D%22%22%3E96.0.1054.62%20(dual_engine_adapter_x64.dll)%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%20class%3D%22%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22%22%3E%3CSPAN%20class%3D%22%22%3EPlease%20confirm.%3C%2FSPAN%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

EdgeのIEモードで

showmodaldialog から Window.open を開いた時に

HKEY_LOCAL_MACHINEの
SOFTWARE\Microsoft\Windows\CurrentVersion\policies\systemの

EnableLUAが

0と1の時で挙動が異なります。

 

1:有効の場合は、EdgeのIEモードで立ち上がります。

0:無効の場合は、EdgeのIEモードではなく、IEが立ち上がります。

 

この動きが異なるのはなぜ発生するのですか?

 

環境は以下の通りですが、他のバージョンでも発生しているのは確認しております。

 
Microsoft Edge のバージョン96.0.1054.62 (公式ビルド) (64 ビット)
Windows のバージョンWindows 10 Version 20H2 (Build 19042.1415) (64 ビット)
Internet Explorer モード アダプターのバージョン96.0.1054.62 (dual_engine_adapter_x64.dll)
 
確認お願い致します。
1 Reply
単純な翻訳を転記

The behavior when opening Window.open from showmodaldialog is different
In IE mode on Edge

When opening Window.open from showmodaldialog

HKEY_LOCAL_MACHINE
SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ policies \ system

EnableLUA

The behavior is different when it is 0 and 1.



1: If enabled, it will start up in IE mode of Edge.

0: If disabled, IE will be launched instead of Edge's IE mode.



Why does this movement occur differently?



The environment is as follows, but we have confirmed that it has occurred in other versions as well.


Microsoft Edge version 96.0.1054.62 (official build) (64-bit)
Windows version Windows 10 Version 20H2 (Build 19042.1415) (64-bit)
Internet Explorer Mode Adapter Version 96.0.1054.62 (dual_engine_adapter_x64.dll)

Please check.

Thank you.