Setting Google as Default Search Provider (Group Policy)

%3CLINGO-SUB%20id%3D%22lingo-sub-1477201%22%20slang%3D%22en-US%22%3ESetting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1477201%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20testing%20the%20new%20Edge%20browser%20(I%20love%20it%20btw).%20Setting%20IE%20mode%20for%20specific%20websites%20and%20all%20kinds%20of%20other%20things%20and%20its%20working%20out%20great%20so%20far.%20I've%20noticed%20that%20for%20some%20reason%20it%20completely%20ignores%20USER%20Group%20Policies%20so%20for%20now%20I%20am%20setting%20everything%20under%20COMPUTER.%20My%20issue%20is%20that%20I%20am%20trying%20to%20make%20it%20so%20that%20when%20you%20search%20from%20the%20address%20bar%20or%20the%20Office%20365%20experience%20new%20tab%20page%20it%20uses%20Google%20instead%3F%20I%20have%20all%20these%20policies%20and%20it's%20not%20working.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20idea's%20as%20to%20what%20I%20am%20doing%20wrong%2Fmissing%20here%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Edge-Chromium-Default-Search-Google.png%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F199738i8E8B1BF28F14E3BF%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22Edge-Chromium-Default-Search-Google.png%22%20alt%3D%22Edge-Chromium-Default-Search-Google.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1479490%22%20slang%3D%22en-US%22%3ERe%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1479490%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F352618%22%20target%3D%22_blank%22%3E%40Kevin_Still%3C%2FA%3E%26nbsp%3Bare%20you%20aware%20that%20you%20cannot%20use%20Google%20to%20search%20in%20your%20Office%20365%20tenant%3F%20We%20decided%20to%20let%20the%20users%20to%20make%20their%20own%20mind%20up%20since%20the%20GPO's%20have%20not%20yet%20the%20possibility%20to%20set%20a%20preference%2C%20and%20changing%20things%20to%20Google%20cripples%20the%20usefulness%20of%20Edge%20with%20Office365.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1479493%22%20slang%3D%22en-US%22%3ERe%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1479493%22%20slang%3D%22en-US%22%3EI%20forgot%20to%20mention%3A%20when%20using%20GPO's%20with%20users%20you%20have%20to%20give%20%22authenticated%20users%22%20read%20permissions%20on%20the%20gpo%2C%20did%20you%20do%20that%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1479494%22%20slang%3D%22en-US%22%3ERe%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1479494%22%20slang%3D%22en-US%22%3EWhat%20about%20just%20doing%20Google%20search%20from%20the%20address%20bar%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1479495%22%20slang%3D%22en-US%22%3ERe%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1479495%22%20slang%3D%22en-US%22%3EDon't%20the%20users%20have%20read%20permissions%20by%20default%3F%20I%20have%20over%20100%20GPOs%20already.%20They%20all%20work%20fine%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1479496%22%20slang%3D%22en-US%22%3ERE%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1479496%22%20slang%3D%22en-US%22%3E%3CP%3EThat%20keeps%20the%20search%20and%20scrolling%20on%20the%20new%20tab%20page%20working.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1479497%22%20slang%3D%22en-US%22%3ERe%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1479497%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F352618%22%20target%3D%22_blank%22%3E%40Kevin_Still%3C%2FA%3E%26nbsp%3Bmmm%20we%20had%20this%20issue%20when%20using%20older%20gpo's%20from%20the%20Windows%207%20era%2C%20they%20did%20not.%20And%20you%20have%20lots%20of%20that%20do%20work.%3C%2FP%3E%3CP%3EWe%20have%20the%20Edge%20settings%20on%20user%20OU's%20and%20have%20no%20problem%2C%20with%20authenticated%20users%20in%20the%20security%20filtering%2C%20if%20you%20have%20a%20group%20there%20of%20separate%20accounts%2C%20then%20you%20have%20to%20add%20authenticated%20users%20.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1479511%22%20slang%3D%22en-US%22%3ERE%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1479511%22%20slang%3D%22en-US%22%3E%3CP%3EI%20just%20realized%20I%20forgot%20to%20drag%20my%20test%20account%20into%20the%20same%20OU...%20uhh%20ill%20do%20that%20Monday.%20But%20I%20still%20need%20to%20figure%20out%20how%20to%20get%20the%20Search%20Bar%20to%20be%20google%20instead%20of%20bing.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20it%20have%20anything%20to%20do%20with%20the%20O365%20experience%20thing%3F%20If%20I%20change%20it%20to%20something%20different%20will%20it%20fix%20itself%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1481041%22%20slang%3D%22en-US%22%3ERe%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1481041%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F352618%22%20target%3D%22_blank%22%3E%40Kevin_Still%3C%2FA%3E%26nbsp%3BFor%20chrome%20the%20formula%20would%20have%20been%20(if%20you're%20using%20Encrypted)%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-html%22%3E%3CCODE%3Ehttps%3A%2F%2Fencrypted.google.com%2Fsearch%3F%7Bgoogle%3AacceptedSuggestion%7D%7Bgoogle%3AoriginalQueryForSuggestion%7Dsourceid%3Dchrome%26amp%3Bie%3D%7BinputEncoding%7D%26amp%3Bq%3D%7BsearchTerms%7D%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CDIV%20class%3D%22container%22%3E%3CDIV%20class%3D%22container%22%3E%3CDIV%20class%3D%22container%22%3E%3CDIV%20class%3D%22container%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22container%22%3EIf%20you're%20changing%20from%20Google%20Chome%2C%20to%20MS%20Edge%20(Chromium)%2C%20why%20not%20just%20do%20a%20'force%20settings%20import'%20(Unless%20you've%20done%20a%20User%20Data%20Directory%20redirect%2C%20which%20causes%20that%20data%20import%20to%20fail%20for%20Chrome)%20and%20allow%20the%20system%20do%20just%20import%20the%20user's%20prior%20settings%3F%20(i.e.%20Is%20there%20a%20corporate%2Fagency%20requirement%20to%20force%20a%20specific%20search%20engine%3F)%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1481051%22%20slang%3D%22en-US%22%3ERe%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1481051%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F314857%22%20target%3D%22_blank%22%3E%40TheOtherJosh%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAre%20you%20talking%20about%20the%20default%20provider%20url%20gpo%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ELooks%20like%20you%20edited%20your%20reply%20and%20added%20a%20question%20-%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20already%20have%20it%20automatically%20import%20chrome%20settings.%20That%20isn't%20the%20issue.%20As%20far%20as%20Google%20as%20our%20Default%20Search%20provider%20-%20we%20have%20had%20it%20like%20that%20for%20years.%20Our%20users%20throw%20a%20fit%20every%20time%20we%20change%20anything.%20We%20spoke%20to%20department%20managers%20and%20they%20all%20agreed%20they%20wanted%20Google%20so%20we%20decided%20to%20stick%20with%20Google%20but%20I%20cannot%20go%20live%20with%20this%20project%20before%20I%20figure%20this%20out.%20When%20I%20was%20originally%20looking%20at%20the%20GPO's%20(screenshot%20I%20provided%20above).%20It%20seemed%20really%20easy%20for%20me%20to%20set%20the%20default%20search%20provider%20but%20its%20not%20working%20so%20project%20is%20on%20hold%20until%20I%20can%20figure%20it%20out.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1481073%22%20slang%3D%22en-US%22%3ERe%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1481073%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F352618%22%20target%3D%22_blank%22%3E%40Kevin_Still%3C%2FA%3E%26nbsp%3BSorry%20...%20the%20forum%20was%20interpreting%20the%20'code'%20not%20as%20code%2C%20but%20as%20an%20HTML%20redirect.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPreviously%20we%20also%20configured%20the%20'Default%20Search%20provider%20Name'%20for%20Chrome%20as%3A%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-html%22%3E%3CCODE%3EGoogle%20Encrypted%20Search%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1481092%22%20slang%3D%22en-US%22%3ERe%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1481092%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F314857%22%20target%3D%22_blank%22%3E%40TheOtherJosh%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20tried%20your%20suggestion%20and%20it%20still%20doesn't%20work.%20These%20are%20all%20the%20policies%20I%20have%20currently%20configured%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Kevin_Still_1-1592837553511.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F200054i7360ADA763F16198%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22Kevin_Still_1-1592837553511.png%22%20alt%3D%22Kevin_Still_1-1592837553511.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1481113%22%20slang%3D%22en-US%22%3ERe%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1481113%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F314857%22%20target%3D%22_blank%22%3E%40TheOtherJosh%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOriginally%20I%20had%26nbsp%3B%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-applescript%22%3E%3CCODE%3E%7Bgoogle%3AbaseURL%7Dsearch%3Fq%3D%7BsearchTerms%7D%26amp%3B%7Bgoogle%3ARLZ%7D%7Bgoogle%3AoriginalQueryForSuggestion%7D%7Bgoogle%3AassistedQueryStats%7D%7Bgoogle%3AsearchFieldtrialParameter%7D%7Bgoogle%3AsearchClient%7D%7Bgoogle%3AsourceId%7Die%3D%7BinputEncoding%7D%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3EWhich%20is%20what%20Microsoft%20states%20to%20use%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Kevin_Still_0-1592837935350.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F200057iB5527E9218BF17B3%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22Kevin_Still_0-1592837935350.png%22%20alt%3D%22Kevin_Still_0-1592837935350.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20been%20searching%20around%20the%20net%20and%20using%20different%20suggestions%20including%20yours%20but%20none%20work.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAs%20you%20can%20see%20here%20(this%20is%20something%20I%20just%20now%20noticed)%20it%20shows%20both%20search%20options%20in%20the%20dropdown.%20I%20manually%20selected%20Google%20and%20now%20it%20finally%20defaults%20to%20Google...%20weird%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Kevin_Still_1-1592838110777.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F200058i426699BA8956FF49%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22Kevin_Still_1-1592838110777.png%22%20alt%3D%22Kevin_Still_1-1592838110777.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1481096%22%20slang%3D%22en-US%22%3ERe%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1481096%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F352618%22%20target%3D%22_blank%22%3E%40Kevin_Still%3C%2FA%3E%26nbsp%3BYep%2C%20the%20policies%20respond%20to%20chromium.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20I'm%20reading%20your%20GPO%20correctly%2C%20you're%20not%20following%20the%20example%20value%20for%20the%20default%20search%20engine%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22TheOtherJosh_0-1592837707580.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F200055iD2A0ED8E980705E7%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22TheOtherJosh_0-1592837707580.png%22%20alt%3D%22TheOtherJosh_0-1592837707580.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYou%20don't%20have%20the%20actual%20URL%2C%20just%20the%20search%20value.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EStart%20by%20pulling%20out%20the%20Image%20Search%20GPO%20components%2C%20and%20the%20'Suggested%20Search'%20drop%20the%20number%20of%20search%20components%20to%20this%20and%20then%20try%20it%20again.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22TheOtherJosh_0-1592838217829.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F200059iA1A3B72DAC1A0B83%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22TheOtherJosh_0-1592838217829.png%22%20alt%3D%22TheOtherJosh_0-1592838217829.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1481126%22%20slang%3D%22en-US%22%3ERe%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1481126%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22TheOtherJosh_0-1592838353396.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F200060iB2642C74D28A57C7%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22TheOtherJosh_0-1592838353396.png%22%20alt%3D%22TheOtherJosh_0-1592838353396.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3ELook%20at%20the%20example%20text%20I%20hilighted%20in%20the%20bottom.%20(right%20under%20your%20hilight)%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1481127%22%20slang%3D%22en-US%22%3ERe%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1481127%22%20slang%3D%22en-US%22%3EHowever%2C%20upon%20closing%20the%20browser%20and%20reopening.%20It%20goers%20back%20to%20Bing%20as%20default%20until%20I%20select%20Google%20again...%20very%20frustrating%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1481152%22%20slang%3D%22en-US%22%3ERe%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1481152%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F352618%22%20target%3D%22_blank%22%3E%40Kevin_Still%3C%2FA%3E%26nbsp%3BSo%2C%20it%20is%20quite%20likely%20that%20Edge%20is%20doing%20this%20slightly%20differently%3A%3C%2FP%3E%3CP%3EIn%20the%20'Default%20Search%20providers'%20list%20they%20are%20listing%20a%20keyword%20for%20the%20search%20provider%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22TheOtherJosh_0-1592838776196.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F200062i40125052CC9BDC95%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22TheOtherJosh_0-1592838776196.png%22%20alt%3D%22TheOtherJosh_0-1592838776196.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EIn%20addition%20to%20the%20actual%20code%20line%20for%20the%20search%3A%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-html%22%3E%3CCODE%3E%7Bgoogle%3AbaseURL%7Dsearch%3Fq%3D%25s%26amp%3B%7Bgoogle%3ARLZ%7D%7Bgoogle%3AoriginalQueryForSuggestion%7D%7Bgoogle%3AassistedQueryStats%7D%7Bgoogle%3AsearchFieldtrialParameter%7D%7Bgoogle%3AiOSSearchLanguage%7D%7Bgoogle%3AsearchClient%7D%7Bgoogle%3AsourceId%7D%7Bgoogle%3AcontextualSearchVersion%7Die%3D%7BinputEncoding%7D%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1481166%22%20slang%3D%22en-US%22%3ERe%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1481166%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F314857%22%20target%3D%22_blank%22%3E%40TheOtherJosh%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20not%20sure%20how%20or%20why%20but%20after%20switching%20the%20GPO's%20from%20Computer%20to%20User%20policies%20this%20started%20working...%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Kevin_Still_0-1592838974100.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F200063i3A9D7A8061CB5713%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22Kevin_Still_0-1592838974100.png%22%20alt%3D%22Kevin_Still_0-1592838974100.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHere%20is%20what%20I%20am%20using%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Kevin_Still_1-1592839008559.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F200064i81B47D34B12D6691%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22Kevin_Still_1-1592839008559.png%22%20alt%3D%22Kevin_Still_1-1592839008559.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20exact%20values%20copy%2Fpaste%20from%20Microsoft%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1481203%22%20slang%3D%22en-US%22%3ERe%3A%20Setting%20Google%20as%20Default%20Search%20Provider%20(Group%20Policy)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1481203%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F352618%22%20target%3D%22_blank%22%3E%40Kevin_Still%3C%2FA%3E%26nbsp%3BWell%2C%20glad%20you%20found%20what%20appears%20to%20be%20a%20solution%20for%20you.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EGiven%20that%20I've%20not%20needed%20to%20force%20specific%20ones%20for%20specific%20users%2C%20I've%20typically%20done%20it%20entirely%20in%20Computer%20Policy.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAfter%20you%20configured%20the%20computer%20policy%2C%20did%20the%20setting%20update%20on%20the%20'Privacy%20and%20Services%20%26gt%3B%20Address%20Bar'%20page%3F%20Or%20just%20on%20the%20configuration%20page%3F%20(Prior%20to%20changing%20the%20configuration%20to%20User%20Based')%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

Hello,

 

I am testing the new Edge browser (I love it btw). Setting IE mode for specific websites and all kinds of other things and its working out great so far. I've noticed that for some reason it completely ignores USER Group Policies so for now I am setting everything under COMPUTER. My issue is that I am trying to make it so that when you search from the address bar or the Office 365 experience new tab page it uses Google instead? I have all these policies and it's not working.

 

Any idea's as to what I am doing wrong/missing here?

 

Edge-Chromium-Default-Search-Google.png

 

 

18 Replies
Highlighted

@WC_KStill are you aware that you cannot use Google to search in your Office 365 tenant? We decided to let the users to make their own mind up since the GPO's have not yet the possibility to set a preference, and changing things to Google cripples the usefulness of Edge with Office365. 

Highlighted
I forgot to mention: when using GPO's with users you have to give "authenticated users" read permissions on the gpo, did you do that?
Highlighted
What about just doing Google search from the address bar?
Highlighted
Don't the users have read permissions by default? I have over 100 GPOs already. They all work fine
Highlighted

That keeps the search and scrolling on the new tab page working.

Highlighted

@WC_KStill mmm we had this issue when using older gpo's from the Windows 7 era, they did not. And you have lots of that do work.

We have the Edge settings on user OU's and have no problem, with authenticated users in the security filtering, if you have a group there of separate accounts, then you have to add authenticated users .

Highlighted

I just realized I forgot to drag my test account into the same OU... uhh ill do that Monday. But I still need to figure out how to get the Search Bar to be google instead of bing.

 

Does it have anything to do with the O365 experience thing? If I change it to something different will it fix itself?

Highlighted

@WC_KStill For chrome the formula would have been (if you're using Encrypted):

 

https://encrypted.google.com/search?{google:acceptedSuggestion}{google:originalQueryForSuggestion}sourceid=chrome&ie={inputEncoding}&q={searchTerms}

 

 
If you're changing from Google Chome, to MS Edge (Chromium), why not just do a 'force settings import' (Unless you've done a User Data Directory redirect, which causes that data import to fail for Chrome) and allow the system do just import the user's prior settings? (i.e. Is there a corporate/agency requirement to force a specific search engine?)
Highlighted

@TheOtherJosh 

 

Are you talking about the default provider url gpo?

 

Looks like you edited your reply and added a question -

 

I already have it automatically import chrome settings. That isn't the issue. As far as Google as our Default Search provider - we have had it like that for years. Our users throw a fit every time we change anything. We spoke to department managers and they all agreed they wanted Google so we decided to stick with Google but I cannot go live with this project before I figure this out. When I was originally looking at the GPO's (screenshot I provided above). It seemed really easy for me to set the default search provider but its not working so project is on hold until I can figure it out.

 

 

Highlighted

@WC_KStill Sorry ... the forum was interpreting the 'code' not as code, but as an HTML redirect.

 

Previously we also configured the 'Default Search provider Name' for Chrome as:

Google Encrypted Search

 

Highlighted

@TheOtherJosh 

 

I tried your suggestion and it still doesn't work. These are all the policies I have currently configured:

 

Kevin_Still_1-1592837553511.png

 

Highlighted

@WC_KStill Yep, the policies respond to chromium.

 

If I'm reading your GPO correctly, you're not following the example value for the default search engine:

 

TheOtherJosh_0-1592837707580.png

 

You don't have the actual URL, just the search value.

 

Start by pulling out the Image Search GPO components, and the 'Suggested Search' drop the number of search components to this and then try it again.

 

TheOtherJosh_0-1592838217829.png

 

Highlighted

@TheOtherJosh 

 

Originally I had 

{google:baseURL}search?q={searchTerms}&{google:RLZ}{google:originalQueryForSuggestion}{google:assistedQueryStats}{google:searchFieldtrialParameter}{google:searchClient}{google:sourceId}ie={inputEncoding}

Which is what Microsoft states to use:

 

Kevin_Still_0-1592837935350.png

 

I've been searching around the net and using different suggestions including yours but none work.

 

As you can see here (this is something I just now noticed) it shows both search options in the dropdown. I manually selected Google and now it finally defaults to Google... weird

 

Kevin_Still_1-1592838110777.png

 

 

TheOtherJosh_0-1592838353396.png

Look at the example text I hilighted in the bottom. (right under your hilight)

Highlighted
However, upon closing the browser and reopening. It goers back to Bing as default until I select Google again... very frustrating
Highlighted

@WC_KStill So, it is quite likely that Edge is doing this slightly differently:

In the 'Default Search providers' list they are listing a keyword for the search provider:

TheOtherJosh_0-1592838776196.png

In addition to the actual code line for the search:

{google:baseURL}search?q=%s&{google:RLZ}{google:originalQueryForSuggestion}{google:assistedQueryStats}{google:searchFieldtrialParameter}{google:iOSSearchLanguage}{google:searchClient}{google:sourceId}{google:contextualSearchVersion}ie={inputEncoding}

 

Highlighted

@TheOtherJosh 

 

I am not sure how or why but after switching the GPO's from Computer to User policies this started working...

 

Kevin_Still_0-1592838974100.png

 

Here is what I am using

 

Kevin_Still_1-1592839008559.png

 

The exact values copy/paste from Microsoft

 

Highlighted

@WC_KStill Well, glad you found what appears to be a solution for you.

 

Given that I've not needed to force specific ones for specific users, I've typically done it entirely in Computer Policy.

 

After you configured the computer policy, did the setting update on the 'Privacy and Services > Address Bar' page? Or just on the configuration page? (Prior to changing the configuration to User Based')