PlayReady missing from available DRMs

Highlighted
New Contributor

I'm having issues with the Chromium Edge and PlayReady. It appears that on my PC, Edge thinks that PlayReady is not a supported DRM. When I query the browser to check for PlayReady support, Edge responds as if PlayReady is not supported (see sample Javascript at the bottom of this post). Additionally, a Javascript player we use (Shaka Player) suggests that it is not supported (https://shaka-player-demo.appspot.com/support.html the "drm" object has "null" for "com.microsoft.playready" which indicates no support). 

 

Strangely, my coworker's computers show that they do have support for PlayReady in Chromium Edge (except for one, who is seeing the exact same behavior as my computer). PlayReady was working for me prior to the stable release of the Chromium Edge (aka Dev/Beta/Canary). It was only upon installing the stable version that I lost support (which affected all release channels I had installed at the time).

 

If I uninstall the stable version of the Chromium Edge, I get Edge 44/EdgeHTML 18 back, which does support PlayReady. IE11 also still supports PlayReady. This would indicate that the issue is isolated to Chromium Edge.

 

I was on Windows 10 build 1803 and upgraded to Windows 10 build 1909 as an attempt to fix this issue with no success.

 

I've uninstalled all the Edge versions I had, removed the directories they created in the user directory, and reinstalled Edge. This did not fix my issue. Here are my current Edge versions:

Edge stable - version 80.0.361.66

Edge beta - version 81.0.416.28

Edge dev - not installed, but I've had it installed without it working

Edge canary - version 82.0.451.0

 

Is this a known issue? Any idea what could be causing this?

 

Thanks,

Brad

 

Javascript used to test for PlayReady support:

navigator.requestMediaKeySystemAccess("com.microsoft.playready", [{
     "initDataTypes": ["cenc"],
     "audioCapabilities": [{
          "contentType": "audio/mp4;codecs=\"mp4a.40.2\""
     }],
     "videoCapabilities": [{
          "contentType": "video/mp4;codecs=\"avc1.42E01E\""
     }]
}]).then(console.log).catch(console.error)

 

4 Replies
Highlighted

@bnadler 

 

What does edge://compat/cdm say?

 

Greetings

Joachim

Highlighted

@Joachim_T 

 

I've attached a screenshot of the edge://compat/cdm page from my Stable channel install. Beta has the same output as stable. Canary, however, says "Currently there are no entries in this list.". My stable output is the same as my coworkers that has PlayReady working, if that helps.

 

Just for reference, the webpages that I'm testing this on is a localhost web server, an intranet web server that is served over HTTPS, and on Shaka Player's support.html that I linked to in my original post (which is also served over HTTPS).

 

Also, I forgot to mention in my original post that I've tried toggling edge://flags/#edge-playready-drm-win10 which made no difference. I also forgot to mention that the Widevine CDM is working just fine.

 

Thanks,

Brad

Highlighted

@Joachim_T the same like @bnadler . No PR CDM. WV working fine. Any idea? is PR only available on some scenarios? 

 

var config = [{
"initDataTypes": ["cenc"],
"audioCapabilities": [{
"contentType": "audio/mp4;codecs=\"mp4a.40.2\""
}],
"videoCapabilities": [{
"contentType": "video/mp4;codecs=\"avc1.42E01E\""
}]
}];
undefined
try {
navigator.
requestMediaKeySystemAccess("com.microsoft.playready", config).
then(function(mediaKeySystemAccess) {
console.log('playready support ok');
}).catch(function(e) {
console.log('no playready support');
console.log(e);
});
} catch (e) {
console.log('no playready support');
console.log(e);
}
VM301:7 no playready support
VM301:8 Error: The key system specified is not supported.
at <anonymous>:3:3

Highlighted

@rceles 

 

I am sorry. No more Ideas