SOLVED

MSN weather metric system settings not saving (Edge Chromium Based)

Highlighted
New Contributor

Hello, it was recommend in Microsoft Community Forums that I should post this here.

In the new Microsoft Edge Dev Browser, I noticed that the greetings message on the new tab was displaying in the wrong location with different metric system, so I went to the content section of the new tab and saw the weather widget, I changed to use my location + the metric system that I use, and in that tab, all the settings that I changed were all applied, the greetings message was displaying the correct metric system, until I changed a new tab, the location was saved but the metrics didn't.

In www.msn.com the changes were also applied correctly (if I'm logged in, if not, the default is the same has the new tab).

I'm logged in and synced in the Browser.

  • My Edge Dev version is 82.0.453.2
  • My Current Language in Edge Dev is English with Portuguese as optional
  • My Windows 10 version build 1909
  • My Windows 10 Language is English (United States) with Portuguese as optional

I also tried in Edge Canary and regular Edge with the same result.
Edge Legacy works fine and all the changes are saved.

 

10 Replies
Highlighted

@ricardomorais You've come to the right place; welcome to our MS Edge Insiders community! We're sorry to hear that you're encountering some issues with the New Tab Page weather settings.

 

Thanks for sharing those details, I'll reach out to our NTP team and see if they have any insights into this. In the meantime, if you're comfortable with it, can you please submit detailed feedback and diagnostics through the browser? And if you have any extensions enabled, can you try turning them off?

 

Thanks,

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

Highlighted
Best Response confirmed by ricardomorais (New Contributor)
Solution

@ricardomorais Great news! The team just let me know that this bug should be fixed. Please install any updates, and let us know how it goes!

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

Highlighted

@fawkes Yes, the new tab is now saving the settings and applying them correctly, thank you for warning me that this was fixed

Highlighted

@ricardomorais Great, we're glad that we could get you a fix quickly! Hope you enjoy the new Microsoft Edge, and let us know if you have any additional feedback.

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

Highlighted

@fawkes i have the same issue and it used to show it in Celsius but now it uses F and keeps doing it on every new tab even if I switch to C...

Highlighted

@Mustakivi , @fawkes 

 

I have the same problem here. I'm currently using Edge Stable (84.0.522.52) (64 bit)

Highlighted

@fawkes Good Morning, I too am having the same problem - this has only started since I have updated to the last version of Edge Version 84.0.522.52 (Official build) (64-bit).

 

Additionally, I am also having a problem where after logging into my 2 Factor Authenticated Hotmail account with Edge and selecting do not ask again for this computer when adding the security code. If I log off it does not remember 'This computer'. I now use Chrome as it works as intended, but would much prefer to use Edge.
Cheers

Highlighted

@Homith @jenskunze @Mustakivi  Thanks for letting me know! It looks like the team has an open work item for this, so it's on their radar. However, more data points are always helpful; if you haven't yet, can you please submit feedback and diagnostic data through the browser? (Shift+Alt+I)

 

Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge

Highlighted

@fawkes oh please, as if anyone actually looking at those. This issue exists since March according to this thread alone. If Microsoft can't solve a simple setting saving issue in the browser, then what hope do we have in getting, for example, the touch input nightmare to be resolved?

 

I'll just disable the greeting so the F temperature wouldn't annoy me and go buy a thermometer to stick in the window...

Highlighted

@Mustakivi We're sorry to hear that this has been frustrating for you. Our team strives to deliver a smooth browsing experience, so we're actively investigating the F/C setting issue.

 

Due to our privacy protections, I can't share details about individual pieces of feedback. However, since I've personally looked at the internal bug for this, I can confirm that it was indeed created from an in-browser diagnostics submission. So yes, we do look at (and greatly appreciate!) the feedback we receive.

 

Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge