Microsoft Edge hanging in Kiosk Mode (Reproduceable)

Copper Contributor

@Raj_GS  I found another issue. I have a simple website hosted locally.  It is a Wordpress site using Apache, MySql, PHP.  I have my Kiosk app setup to Edge with 5 minute restart interval.



What I found is that when I reboot the computer, after logging in the Edge browser just has a grey (#f0eeee) background screen and the mouse cursor shows up as blinking (loading) sign and that is it. Things get stuck and nothing further happens. I waited 10 minutes (even though I have restart app every 5 minutes set in Kiosk setting) and nothing happens. If I hit Ctrl+Alt+Del to logoff Kiosk and log back in as Admin, Run Task Manager, Force logoff Kiosk and then logout as Admin and log back in as Kiosk, everything loads up. I figured there might be an issue with Apache and Mysql service starting and in the meantime Edge trying to access the page and going crazy.


To troubleshoot, I switched the website to a simple static HTML page with one page only.  Here is HTML for the simple page





What I noticed is something similar. The simple page is displaying a "loading gif" and is supposed to redirect after 10 records.  When the page loads, the gif animation gets stuck with the cursor again blinking and nothing else happens - this time only apache is involved and no mySQL db.  


Then I tried the same but instead of using a localhost URL (the involves Apache), I just provided the direct URL to the file "file:///C:/load/index.html" and the same result. Upon reboot and first login to Kiosk, Edge just gets stuck in a loop of some sort and nothing more.


Then I figured maybe there is an issue with the Kiosk account so I deleted it and created a new one with a different name altogether and still the same exact issue. I am able to reproduce this issue consistently.


I have a brand new ASUS all in one desktop that I just bought two days ago. Downloaded all the latest Windows patches (updates) and the latest Edge browser.







4 Replies

@Raj_GS , attached are two videos showing exactly what is happening.  In the Not Working video you can see how the loading image gets stuck.  No matter what I click or what I do, it is stuck like that.  The only way to get it out of this state is Logout as Kiosk, Login as Admin, kill the Kiosk Session from Task Manager and then log back in as Kiosk.  They happens every time I reboot

@The_Naval_Museum ,


First off, I'm really excited each time I see real customers trying the features that our teams worked on and the videos just amped that feeling up. So I'd really love to see this succeed! :)


Thanks for posting this as a separate thread based on my request!


The videos and the code chunk were useful in furthering my understanding of your setup. I believe you already sort of answered your query -  you have a server on the same device that you're trying to access its contents too. Based on my (limited) understanding, here are a few things happening:


1. Edge kiosk is able to see the html file, as it loads the .gif. But it does not load your expected webpage.

2. FYI, the "Kiosk" user that you'd setup is a local account with regular user privileges. The web server has most likely been configured via the admin user and the web server/sql backend service may all be set to start when that admin user logs in.

3. The problem "goes away", if you login as the admin and log back in as the Kiosk user.


Given the above, it seems the act of logging in as the admin user starts the webserver and the sql backend, thereby making your local site fully available/ready to be served. When you log back in as the Kiosk user, Edge kiosk is now able to navigate to your pages. In the normal flow though, Kiosk user auto logs on upon the device boot up and hence, the web server and sql backend may not start running at all.


Would it be possible to configure the web server and sql backend to start when the system boots up (or when ANY user logs in)? Even in this case, you will most likely run into hiccups - Assuming Windows allows such startup requests for the Kiosk user, Windows Assigned Access will launch Edge kiosk (the designated app) soon as the Kiosk user logs in. Even if you configure the web server and sql backend to start for all users, Edge kiosk may have trouble loading the site depending on the order in which these things finish.


Is a non-local site an option at all? If so, that will be your best and safest bet.


If not, here are a couple of things to try:

1. Configure your web server and sql backend to start at system boot up or when ANY user logs in.

2. Assuming step 1 works for the Kiosk user, have a static landing page that kicks off a delay timer for 'N' seconds (you might need to play with this to figure out the best value for 'N' - make sure to add some buffer to it) and then tries loading your site.


Let me know how this goes!



I have tried the KIOSK with no MYSQL or APACHE.  


Two simple Static HTML pages only so there is no service or admin account involved and still the same.  It hangs up.  Just two HTML pages on the local file system being loaded directly using  file UNC.  One redirects to the other after 10 seconds.  That is it.  It has nothing to do with admin account or service account issue.

I have also created just a separate local user account (Standard account - not admin) and then rebooted the PC.  When I login interactively as the standard local user and start edge and navigate to the locally hosted wp site, it opens up with no issue.  That also proves that there is no admin account kicking of mysql and apache service issue. 


I have now gone ahead and moved on to "mirabyte frontfacelock" tool to lock down the standard user account and using that as kiosk mode and everything is working like a charm.


Being a developer myself with 22 yrs of experience, I can assure you that this is a bug.



@The_Naval_Museum ,


Thanks for the update! Glad to know that you have a way to simply lock down Windows to your needs - I'm guessing it is using many of the Windows lockdowns, like Applocker, Keyboard filters etc , but yes, it is convenient to just have some simple config tool especially when your needs are simple and maybe required just for 1 to a few devices :)


We do lock down a bunch of things as part of our "single app" restriction in Windows Assigned Access - so it is highly likely that something there is causing this issue too. I'll pass this info on to the team that is best equipped to look at your issue (along with your feedback hub report regarding the virtual keyboard).