Login with AzureAD Account sync instantly goes in "Error" state

Brass Contributor

Hi

 

Please see this video about my problem: https://youtu.be/atxOfCJBKRE

To recap in words, When I sign-in with my personal AzureAD account to Edge Dev and Canary (Newest builds 78.0.262.0/78.0.267.0) it instantly goes into Error state.

 

I have tried on 3 different PC's. 2 of them newly installed Win10 1903 setup and logged in directly with the AzureAD credentials. 

So it's not a PC problem, cause as the video shows I have two other profiles, which both are setup with AzureAD account sync.

EDIT: It hasn't worked in previous builds either.

88 Replies

@cdo11 Hi. I don't know if @akhator did some magic but my issue was resolved and sync now works without any issue. Hope you problem will be also fixed soon.

@cdo11 I'm one of Ankur's peers working on Auth. Happy to help fix this auth error you're running into. I'll reach out over private message to debug since this issue to prevent conflating with other issues on this thread

@Avi Vaid I could use your assistance on this issue as well. I shot you a DM with my details. 

@akhator Has this fix been rolled out yet? My work account still won't sync and edge://sync-internals/ still looks (screenshot attached) very unhappy.

@pivotrobert your issue is different than other issues reported on this thread. Few questions 

- How long have you been in this state? When did you start using new Edge roughly ?

-  Have you switches alias recently or changed the domain for your account? 

 

 

@akhator I've been using Edge (Dev channel) since it came out. However this sync issue happens with my work account in all branches - stable, beta, dev and canary. I have never been able to get sync working with my work account. There have not been any changes to my account - same alias, same domain.

@akhator are you sure we're not talking about the same issue? From your previous reply on this thread:

 

2. There is a second bucket of errors reported where encryption management ran into error. This is expected to impact the account and thus will prevail on all devices (you should see crypto error on edge://sync-internals for this bucket). We are working on in-app control for users to reset their cloud data. However that is still further out. In the meantime, we are preparing and verifying a manual process allowing users to request deletion of their cloud data. I am hoping that we will be able to offer this manual set of instructions soon while we work on right long term solution in parallel. 

 

This is happening on all my devices, regardless of channel, and they all show the crypto errors. Screenshots from 2 different machines and the Stable channel.

I am having exactly the same issue - seems something to do with crypto issue. In my tenant I am the only affected user; the other users are able to sync their Edge settings without problems.
I compare the output from my edge://sync-interals with outputs from the other users and it seems that my account's cryptographer is having pending keys and passphrase is required. See attached screenshots.

@thomasknapp Yup, no one else in the org is affected. It sounds like it's due to participating in early Dev or Canary builds.

@pivotrobert Exactly the same situation over here. It's been confirmed before that this affects users who participated in the beta/dev/canary channels. It's quite disappointing that those users are being left behind now that the product has been released. 

@Daniel Brezina Same situation here. There's no way to fix this? Sync works for me on Beta build, but no other channel including release. I'm actually glad to hear it only affects testers at this point, as I can roll it out in my org now without worrying (I'm sure no one else participated in an earlier build). However I'm also scared to sign out of edge now for fear of never being able to sign in again. 

@Avi Vaid It seems I have the same issue as @cdo11 & @pivotrobert. edge://sync-internals shows I have an auth error.

Server Connection auth error since 2020-04-13 15:01:15 +08

And under Type info, I can see a crypto error:

GenerateCryptoErrorsForTypes@../../components/sync/driver/data_type_manager_impl.cc:38, cryptographer error was encountered:

Snipaste_2020-04-13_15-01-07.png

I was able to sync with my alias in my old laptop. However, I changed a new laptop last Friday. And it cannot work in my new laptop. My old laptop seems working well. However, after I signed out and signed in again, the old laptop also stopped working anymore.

 

Could you please also help me out with this issue?   

@akhator 

 

I have a similar issue since the upgrade to the latest production build, but different error.  I am able to sign in, however Sync is never able to connect.  I can find no internet reference for the below error.  Any idea what it means?

rror: Primary Error: kTokenRequestFailed, Secondary Error: kUserSwitch, Platform error: 1002, hex:3ea, Error string: UserSwitch {"Description":"Authentication was blocked because a user switch was detected. Old ID: '(pii)', new ID: '(pii)'.","ErrorCode":"1002","Tag":"96h1z"}

 

 

ycore290_0-1586899401134.png

 

@ycore290 this seems like an issue that has recently been fixed in early Canary builds. Could you try this in an updated Canary (84.0.480.0 or later versions)? If this is still an issue, feel free to reach out to me over direct message and we can try to fix this issue.

@Avi Vaid 

 

Sure thing, will give it a try in the morning, however for some further color, I AM able to sync on my windows 10 1909 desktop using the same build (81.0.416.53) and account, however when I try and sync on our Windows 2016 RDS server, I get the error that I attached.  But if I used a test account that has never synced before, I CAN sync on that same 2016 server.  The behavior is mystifying, but clearly it isn't a client side network/proxy/config issue if I can sync with a new account, unless there is some profile specific file that is causing the issue.

@JayZuo @Avi Vaid @ycore290 

 

Any updates to the crypto error? Same issue still - My account signed in on a device that was previously working with Edge Beta Channel since late 2019 is still working. No new setups will work. I can't sign in on a VM or fresh device to new Edge - release, beta, dev or canary - all say "Couldn't connect to the sync server" and show the crypto error referenced above. New accounts on my domain that never signed into a beta channel before release are working fine. 

 

Please fix this! I'll back it up myself and restore my info if you can at least give us a way to clear whatever bad data is causing the sync issue. I get that it was a beta, but participating in it shouldn't render the full release unusable!

Same issue for my user. Sync works with other users, also on my computer, but doesnt work with my user on any device. 

 

I started using Edge with the first public DEV-Versions, Sync never worked for me. Even on the latest public, dev or canary builds (84.0.502) not working. In Sync-Internals I see the GenerateCryptoErrorsForTypes messages for all model types. 

 

Popping in this thread to receive updates on the fix.  

cc @akhator  

I finally got my sync data reset, and now I can sync with my account.

I got help from the Edge Feedback team, after I used the feedback button in Edge and asked for my cloud data to be reset due to lack of sync.

They are not fast 1,5 month, but they did get the job done in the end.

 

Thanks to everyone involved

 

Regards Lars.

@nOrphf Took that suggestion and got a response back on the 13th. No change yet, but it's something.

 

Capture.PNG

I can't possibly deploy this to my user base in its current format.  There needs to be a way to diagnose this issue, and fix it from the client side.  In my case, I still can't sync on a Windows 2016 RDS server, though I can on my Windows 10 PC.  Test users also report inconsistent behavior.  Also, the inability to force toggle the sync by GPO is a massive oversight.  This is getting tossed on the same pile as Intune-- buggy and immature with poor documentation.  C'mon Microsoft, get it together.