Login with AzureAD Account sync instantly goes in "Error" state

Brass Contributor



Please see this video about my problem: https://youtu.be/atxOfCJBKRE

To recap in words, When I sign-in with my personal AzureAD account to Edge Dev and Canary (Newest builds it instantly goes into Error state.


I have tried on 3 different PC's. 2 of them newly installed Win10 1903 setup and logged in directly with the AzureAD credentials. 

So it's not a PC problem, cause as the video shows I have two other profiles, which both are setup with AzureAD account sync.

EDIT: It hasn't worked in previous builds either.

88 Replies


Just to be clear, on my sync-internals page I see this error


Local State
Server Connection auth error since 2020-01-21 14:33:14 -05


is that the crypto error you are referring to? 

@jasonsch69 Could you clarify what account you're using to try to sync. I seem to recall from previous comments that you were using an on-prem AD account? We don't yet support sync for on-prem AD accounts

@Avi Vaid 


It is an azure AD account.

@jasonsch69 Thanks. Could you send us copies of edge://signin-internals and edge://histograms to help debug your specific issue further. You can send it to me privately.

@Avi Vaid 

Throwing mine in, as one of my accounts work, but my primary dosn't, so it should work.

No accounts are synced from AD, they are cloud only.

Taken from newest canary, do you want them from GA release?



@Avi Vaid  I sent the sync-internals status dump via private message. 


Turns out if you try to paste a copy of the histogram into a private message, It kills edge and/or chrome.


Must be the 23000 lines of text. how can I send you a txt file?



I'm guessing the sync error you are referring to is this, taken from my sync-internals.


Error: GenerateCryptoErrorsForTypes@../../components/sync/driver/data_type_manager_impl.cc:38, cryptographer error was encountered:


Any clue when we may get a fix, or a way to clear the corrupted data?

@Avi Vaid @akhator 

Just got a bunch of mail telling me that "You helped fix an issue in Microsoft Edge!"

Does that mean that we are closing in on getting this to work?



As I had suspected. My problem was related to changing my UPN after I had enabled sync. The fix was to add my old UPN as a proxy address to my Azure account (via my local AD). Once I added my old UPN as a proxy address and let it sync up to azure, Edge sync worked immediately. Thanks @akhator for putting me in touch with one of your team. 


Bucket #2 here ;(
Looking forward to the workaround.

@Avi Vaid @akhator Still no news on this?...


Also looking for updated information on this issue. Lots of people having problems, but no solutions.


Interestingly, I was syncing as of last week, but this week, I'm back to "Couldn’t connect to the sync server. Retrying…"


Would like to roll Edge Chromium out to users, but sync is a marquee feature we need before we can do any roll out.

@JRichmond Can you share a screenshot of your edge://sync-internals ?

@JRichmond Thanks. We are aware that some users are running into this issue. We have a fix ready undergoing validation. We will be begin rolling it out once validated. Please ping if this issue in not resolved in next 4-5 days. Thanks for your patience. 

Cool. Thanks for the quick reply!

@akhator Hi. I have same error as @JRichmond on one of my accounts. Could you update us on fix?

@Patryk_B are you running into this error for Microsoft account or for work/school account? 

@akhator This is on my Microsoft account. I get such error. It must be account related because on my other account sync works without any issue. 



@Patryk_B @akhator I have same issue on MS account, when I look at the edge://sync-internals/ logs I see the error from the discussion:


Server Connection auth error since 2020-03-28 17:14:56 -07


I have this sync error on all my devices.


Is this related to item (2) akhator described? Is there a fix?