Installing MicrosoftEdgeBetaEnterpriseX64.msi - Error 1722 when EdgeUpdate Policy is configured

%3CLINGO-SUB%20id%3D%22lingo-sub-843654%22%20slang%3D%22en-US%22%3EInstalling%20MicrosoftEdgeBetaEnterpriseX64.msi%20-%20Error%201722%20when%20EdgeUpdate%20Policy%20is%20configured%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-843654%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20installing%20MicrosoftEdgeBetaEnterpriseX64.msi%20(current%20Version%2077.0.235.20)%20I%20get%20following%20MSI%20Error%201722%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CFONT%20face%3D%22lucida%20sans%20unicode%2Clucida%20sans%22%20color%3D%22%230000FF%22%3E%3CEM%3EProduct%3A%20Microsoft%20Edge%20Beta%20--%20Error%201722.%20There%20is%20a%20problem%20with%20this%20Windows%20Installer%20package.%20A%20program%20run%20as%20part%20of%20the%20setup%20did%20not%20finish%20as%20expected.%20Contact%20your%20support%20personnel%20or%20package%20vendor.%3C%2FEM%3E%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAfter%20some%20investigation%20I%20found%20out%2C%20that%20the%20configured%20EdgeUpdate%20Policy%20results%20in%20this%20Error.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUpdate-Policy%20as%20follows%3A%3CBR%20%2F%3E%3CFONT%20face%3D%22lucida%20sans%20unicode%2Clucida%20sans%22%20size%3D%222%22%20color%3D%22%230000FF%22%3E%5BHKEY_LOCAL_MACHINE%5CSOFTWARE%5CPolicies%5CMicrosoft%5CEdgeUpdate%5D%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20face%3D%22lucida%20sans%20unicode%2Clucida%20sans%22%20size%3D%222%22%20color%3D%22%230000FF%22%3E%22UpdateDefault%22%3Ddword%3A00000000%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20face%3D%22lucida%20sans%20unicode%2Clucida%20sans%22%20size%3D%222%22%20color%3D%22%230000FF%22%3E%22InstallDefault%22%3Ddword%3A00000000%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20face%3D%22lucida%20sans%20unicode%2Clucida%20sans%22%20size%3D%222%22%20color%3D%22%230000FF%22%3E%22AutoUpdateCheckPeriodMinutes%22%3Ddword%3A00000000%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETo%20solve%20the%20MSI%20Installation%20Problem%20I%20had%20to%20delete%20the%20EdgeUpdate%20Policy%20prior%20to%20start%20the%20MSI-Installation%3A%3C%2FP%3E%3CP%3E%3CFONT%20face%3D%22lucida%20sans%20unicode%2Clucida%20sans%22%20size%3D%222%22%20color%3D%22%230000FF%22%3Ereg%20DELETE%20HKEY_LOCAL_MACHINE%5CSOFTWARE%5CPolicies%5CMicrosoft%5CEdgeUpdate%20%2Ff%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20seems%20to%20be%20a%20bug%20which%20should%20be%20fixed.%20The%20UpdatePolicy%20configures%20the%20Automatic%20Online-Update%20behavior%20-%20but%20should%20not%20result%20in%20MSI-Errors%20when%20deploying%20the%20Package%20by%20on-premise%20software-distribution%20Solutions.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-846101%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeBetaEnterpriseX64.msi%20-%20Error%201722%20when%20EdgeUpdate%20Policy%20is%20configured%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-846101%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F60488%22%20target%3D%22_blank%22%3E%40Gunnar%20Haslinger%3C%2FA%3E%26nbsp%3BHow%20do%20you%20plan%20to%20distribute%20updates%2Fpatches%3F%20Do%20you%20think%20every%20single%20update%2Ffix%20well%20be%20available%20as%20MSI%20package%3F%20How%20do%20you%20organize%20test%20deployment%20rings%20for%20new%20releases%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-846187%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeBetaEnterpriseX64.msi%20-%20Error%201722%20when%20EdgeUpdate%20Policy%20is%20configured%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-846187%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F213419%22%20target%3D%22_blank%22%3E%40Thilo%20Langbein%3C%2FA%3E%26nbsp%3BMicrosoft%20didn't%20publish%20information%20how%20the%20Lifecycle%20of%20the%20final%20product%20is%20planned.%20But%20as%20there%20are%20the%20EdgeUpdate%20Policies%20I%20guess%20this%20is%20part%20of%20the%20final%20product%20too%20(wouldn't%20make%20sense%20to%20create%20EdgeUpdate%20Policies%20only%20for%20beta-phase).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESure%2C%20offline%20MSI-Package-Deployment%20is%20the%20preferred%20way.%20Planning%20to%20deploy%20Edge%20based%20on%20Chromium%20as%20every%20other%20software%20package%20by%20our%20internal%20fully-managed%20enterprise%20deployment.%20Seems%20there%20is%20no%20need%20for%20separate%20%22Updates%2FFixes%22%20because%20the%20full%20MSI-Package%20of%20Edge%20itself%20is%20not%20very%20large%20and%20can%20be%20used%20to%20update%20to%20the%20most%20current%20version.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-857900%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeBetaEnterpriseX64.msi%20-%20Error%201722%20when%20EdgeUpdate%20Policy%20is%20configured%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-857900%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F60488%22%20target%3D%22_blank%22%3E%40Gunnar%20Haslinger%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EBased%20on%20the%20reg%20keys%20that%20were%20set%20it%20looks%20like%20%22install%20default%22%20is%20the%20culprit%20and%20this%20experience%20would%20be%20by%20design%20(though%20we%20should%20look%20into%20having%20a%20more%20descriptive%20error%20message%20in%20this%20scenario).%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EEssentially%20with%20InstallDefault%20set%20that%20way%20the%20machine%20is%20being%20told%20%22don't%20allow%20the%20next%20version%20of%20Edge%20to%20be%20installed%22%20so%20when%20you%20try%20to%20install%20the%20next%20version%20of%20Edge%20it%20recognizes%20that%20there%20is%20policy%20set%20saying%20%22don't%20allow%20installation%22%20and%20it%20is%20respecting%20that.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EPresetting%20the%20Update%20policies%20(UpdateDefault)%20should%20work%20as%20you%20expect%20and%20not%20block%20installation.%20Doing%20this%20would%20be%20the%20intended%20way%20to%20prevent%20Auto-update%20from%20running%20after%20you%20install%20using%20the%20MSI.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EHope%20that%20helps!%3C%2FP%3E%0A%3CP%3E-Steve%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1132852%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeBetaEnterpriseX64.msi%20-%20Error%201722%20when%20EdgeUpdate%20Policy%20is%20configured%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1132852%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F60488%22%20target%3D%22_blank%22%3E%40Gunnar%20Haslinger%3C%2FA%3E%26nbsp%3BIn%20my%20test%20Environment%20I%20was%20still%20affected%20by%20this%20bug%20with%20the%20stable%20version%20of%20Edge%20(%3CSPAN%3E%26nbsp%3B79.0.309.71)%3C%2FSPAN%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%3EThe%20workaround%20fixed%20the%20issue.%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%3CSPAN%3EShould%20this%20be%20fixed%3F%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1132910%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeBetaEnterpriseX64.msi%20-%20Error%201722%20when%20EdgeUpdate%20Policy%20is%20configured%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1132910%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F178129%22%20target%3D%22_blank%22%3E%40Stefan%20R%C3%B6ll%3C%2FA%3E%26nbsp%3BI'm%20still%20using%20my%20workaround%20(deleting%20the%20EdgeUpdate%20Policies%20before%20applying%20the%20MSI-Package).%20I%20haven't%20tested%20if%20newer%20MSI%20Packages%20behave%20different%20or%20at%20least%20give%20more%20intuitive%20Error-Messages.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESee%20the%20message%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F74394%22%20target%3D%22_blank%22%3E%40Steve%20Rugh%3C%2FA%3E%26nbsp%3Bposted%20which%20basically%20tells%20us%20to%20just%20set%20the%20UpdateDefault%20and%20not%20the%20InstallDefault%20Policy%20as%20an%20other%20solution.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20solution%20is%20still%2C%20to%20delete%20the%20EdgeUpdate%20Policies%20before%20Installation%20the%20MSI-Package%20and%20ReApply%20the%20Policy%20after%20Installation.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1751015%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeBetaEnterpriseX64.msi%20-%20Error%201722%20when%20EdgeUpdate%20Policy%20is%20configured%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1751015%22%20slang%3D%22en-US%22%3EThank%20you%20so%20much%20for%20discovering%20this!%20We%20had%20implemented%20group%20policy%20to%20lock%20down%20the%20new%20Edge%20browser%20and%20it%20was%20applied%20to%20our%20test%20machines.%20I%20couldn't%20figure%20out%20why%20it%20wouldn't%20install%20on%20ANY%20of%20them%20and%20this%20was%20why.%20I%20simply%20put%20in%20a%20delete%20command%20before%20the%20installation%20and%20it%20works%20flawlessly%20now.%3C%2FLINGO-BODY%3E
Highlighted
Frequent Contributor

When installing MicrosoftEdgeBetaEnterpriseX64.msi (current Version 77.0.235.20) I get following MSI Error 1722:

 

Product: Microsoft Edge Beta -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.

 

After some investigation I found out, that the configured EdgeUpdate Policy results in this Error.

 

Update-Policy as follows:
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\EdgeUpdate]
"UpdateDefault"=dword:00000000
"InstallDefault"=dword:00000000
"AutoUpdateCheckPeriodMinutes"=dword:00000000

 

To solve the MSI Installation Problem I had to delete the EdgeUpdate Policy prior to start the MSI-Installation:

reg DELETE HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\EdgeUpdate /f

 

This seems to be a bug which should be fixed. The UpdatePolicy configures the Automatic Online-Update behavior - but should not result in MSI-Errors when deploying the Package by on-premise software-distribution Solutions.

 

6 Replies

@Gunnar Haslinger How do you plan to distribute updates/patches? Do you think every single update/fix well be available as MSI package? How do you organize test deployment rings for new releases?

Highlighted

@Thilo Langbein Microsoft didn't publish information how the Lifecycle of the final product is planned. But as there are the EdgeUpdate Policies I guess this is part of the final product too (wouldn't make sense to create EdgeUpdate Policies only for beta-phase).

 

Sure, offline MSI-Package-Deployment is the preferred way. Planning to deploy Edge based on Chromium as every other software package by our internal fully-managed enterprise deployment. Seems there is no need for separate "Updates/Fixes" because the full MSI-Package of Edge itself is not very large and can be used to update to the most current version.

Highlighted

@Gunnar Haslinger 

 

Based on the reg keys that were set it looks like "install default" is the culprit and this experience would be by design (though we should look into having a more descriptive error message in this scenario).

 

Essentially with InstallDefault set that way the machine is being told "don't allow the next version of Edge to be installed" so when you try to install the next version of Edge it recognizes that there is policy set saying "don't allow installation" and it is respecting that.

 

Presetting the Update policies (UpdateDefault) should work as you expect and not block installation. Doing this would be the intended way to prevent Auto-update from running after you install using the MSI.

 

Hope that helps!

-Steve

Highlighted

@Gunnar Haslinger In my test Environment I was still affected by this bug with the stable version of Edge ( 79.0.309.71) 

The workaround fixed the issue.

Should this be fixed? 

Highlighted

@Stefan Röll I'm still using my workaround (deleting the EdgeUpdate Policies before applying the MSI-Package). I haven't tested if newer MSI Packages behave different or at least give more intuitive Error-Messages. 

 

See the message @Steve Rugh posted which basically tells us to just set the UpdateDefault and not the InstallDefault Policy as an other solution.

 

My solution is still, to delete the EdgeUpdate Policies before Installation the MSI-Package and ReApply the Policy after Installation.

Highlighted
Thank you so much for discovering this! We had implemented group policy to lock down the new Edge browser and it was applied to our test machines. I couldn't figure out why it wouldn't install on ANY of them and this was why. I simply put in a delete command before the installation and it works flawlessly now.