Edge Sync Fails with M365 Business Premium account after changing licence

New Contributor



I have recently upgraded my M365 licence from Business Basic to Business Premium, after previously having a trial of M365 E5. When I was running the trial E5 licence I had all my installs of Edge syncing via my M365 account. This stopped when the trial ran out, as I then had no AAD licence.


On purchasing my M365 Business Premium licence I expected the sync to start again, however it errors with the message "Sync is not available for this account" and the sync button is greyed out, even though I now have the correct licence. I raised this with M365 Business support team. They tried a lot of troubleshooting to no avail and have now referred me to Edge support.


Note I have tried the steps matching my error above from here https://docs.microsoft.com/en-gb/deployedge/microsoft-edge-enterprise-sync to no avail.


Also please note the following.


  • This is happening on all my devices. 5 PCs. All copies of Edge are up to date.
  • The sync button is only greyed out when the machines are joined to AAD. The sync button is available if I remove from AAD, but the sync still doesn't work. However I can then access the settings. In here a reset sync does nothing, just tries and never completes.
  • If I go to edge://sync-internals/ I can see these errors - "DISABLED_BY_ADMIN, STOP_SYNC_FOR_DISABLED_ACCOUNT, Microsoft Information Protection service is disabled". However AIP is enabled.
  • If I had to guess, something seems to have gone wrong with the sync from when I had an E5 Trial licence, went back to M365 Business Basic (with not licence that included Edge sync), back to M365 Business Premium.

Can anyone please help? Note the ticket is still open with the M365 team if I need to speak to them.





5 Replies

@Jon Flannagan Hello!  Sorry to hear about your issues!  You mentioned you tried to some steps to fix.  Is this the documentation you were following?  https://docs.microsoft.com/en-us/deployedge/microsoft-edge-troubleshoot-enterprise-sync#issue-sync-i... 


If you are still having issues, please reach out to MS Edge support mentioned in the article.  https://www.microsoftedgeinsider.com/en-us/support 





Hi Kelly,

Yes that's the article I have followed. I have tried raising a ticket with Edge support as well as M365 support, however Edge support refused the ticket as its a "business" 365 account, even through I am just a personal user with one license in 365 for my domain. Plus they said they cant support AAD

They referred me to Commercial Browser Support, but I am not a premier support customer and pay per incident support is not available for me as it says its not available for Azure Active Directory accounts. Edge supports other option was to post on here.

@Jon Flannagan I got some additional information from the team, if there was a previous M365 subscription which was then replaced with a new subscription it is possible that the tenant ID has changed and the service data needs to be reset.  Please see here for instructions: https://docs.microsoft.com/en-us/deployedge/edge-learnmore-reset-data-in-cloud 



@Kelly_Y Have tried that but no luck. If the machine I try it on is Azure AD joined the Sync option is greyed out. I removed it from AAD and then Sync became available. Tried a Reset but it just sits there spinning for hours and never completes.

Re your reply above. Note I only changed licenses on the tenant. the tenant is still the same one.

Hi Kelly,

Any further ideas please?