Edge Sync Fails with M365 Business Premium account after changing licence

Copper Contributor



I have recently upgraded my M365 licence from Business Basic to Business Premium, after previously having a trial of M365 E5. When I was running the trial E5 licence I had all my installs of Edge syncing via my M365 account. This stopped when the trial ran out, as I then had no AAD licence.


On purchasing my M365 Business Premium licence I expected the sync to start again, however it errors with the message "Sync is not available for this account" and the sync button is greyed out, even though I now have the correct licence. I raised this with M365 Business support team. They tried a lot of troubleshooting to no avail and have now referred me to Edge support.


Note I have tried the steps matching my error above from here https://docs.microsoft.com/en-gb/deployedge/microsoft-edge-enterprise-sync to no avail.


Also please note the following.


  • This is happening on all my devices. 5 PCs. All copies of Edge are up to date.
  • The sync button is only greyed out when the machines are joined to AAD. The sync button is available if I remove from AAD, but the sync still doesn't work. However I can then access the settings. In here a reset sync does nothing, just tries and never completes.
  • If I go to edge://sync-internals/ I can see these errors - "DISABLED_BY_ADMIN, STOP_SYNC_FOR_DISABLED_ACCOUNT, Microsoft Information Protection service is disabled". However AIP is enabled.
  • If I had to guess, something seems to have gone wrong with the sync from when I had an E5 Trial licence, went back to M365 Business Basic (with not licence that included Edge sync), back to M365 Business Premium.

Can anyone please help? Note the ticket is still open with the M365 team if I need to speak to them.





11 Replies

@Jon Flannagan Hello!  Sorry to hear about your issues!  You mentioned you tried to some steps to fix.  Is this the documentation you were following?  https://docs.microsoft.com/en-us/deployedge/microsoft-edge-troubleshoot-enterprise-sync#issue-sync-i... 


If you are still having issues, please reach out to MS Edge support mentioned in the article.  https://www.microsoftedgeinsider.com/en-us/support 





Hi Kelly,

Yes that's the article I have followed. I have tried raising a ticket with Edge support as well as M365 support, however Edge support refused the ticket as its a "business" 365 account, even through I am just a personal user with one license in 365 for my domain. Plus they said they cant support AAD

They referred me to Commercial Browser Support, but I am not a premier support customer and pay per incident support is not available for me as it says its not available for Azure Active Directory accounts. Edge supports other option was to post on here.

@Jon Flannagan I got some additional information from the team, if there was a previous M365 subscription which was then replaced with a new subscription it is possible that the tenant ID has changed and the service data needs to be reset.  Please see here for instructions: https://docs.microsoft.com/en-us/deployedge/edge-learnmore-reset-data-in-cloud 



@Kelly_Y Have tried that but no luck. If the machine I try it on is Azure AD joined the Sync option is greyed out. I removed it from AAD and then Sync became available. Tried a Reset but it just sits there spinning for hours and never completes.

Re your reply above. Note I only changed licenses on the tenant. the tenant is still the same one.

Hi Kelly,

Any further ideas please?

Did you solve this issue? We are stuck on the same company wide and MS support ist clue less...

@Herr_Merlin I did, but after looking back not sure how much help I can be, as I was never really sure what fixed it in the end. Below are the closing notes I sent to the support engineer (raised separately to this forum post). I think the Edge Sync page I am referring to there is this edge://sync-internals/


If you want to let me know what troubleshooting steps you've tried or what errors you are getting, some of it may jog my memory 2 years on? 


For reference and am not entirely sure if all or any of the below is what fixed it or I got lucky!


  • Changed DNS provider for my home network from OpenDNS to
  • Cleared DNS cache on home Domain Controllers
  • Unticked all options on the Edge Sync page and then clicked reset. First time it failed, then second time it successfully cleared the Edge data synced to AAD. I could then set it up again on all machines.

I spent hours and hours on this, eventually I found that for one particular customer I had to enable Enterprise State Roaming and that fixed the problem instantly (in some cases had to sign out of Edge and back in again)


Go to Azure Active Directory - Devices - Enterprise State Roaming - Enable - All Users


I can't figure out why this happened for one customer, but anyway, that fixed it for me.

We had the exact same issues after the following:
Customers with several email domains in their tenant split their tenant, moving one e-mail domain to a brand new tenant.
E-mail boxes migrated to the new tenant and E/F licenses applied. We couldn't get it to work until we restarted the AIP service (disable/enable). The synk started immediately.
This was the Edge Sync solution for my tenant, also!! After 6 hours of debugging copilot gave a reference to this thread, AAD Enterprise State roaming was the magic bullet - THANK YOU!