Edge requests twice to download Excel file

New Contributor

Hi, I administer the web service to create Excel file like the following.

 

1) user requests to endpoint "/create".
2) "/create" responses status 302. redirect to "/document/one_time_unique_key/some.xlsx".
3) user's browser requests "/document/one_time_unique_key/some.xlsx" according to the redirect response.
4) "/document/one_time_unique_key/some.xlsx" responses status 200 with Excel file. And remove the file from server.
5) user's browser downloads the file.

 

From the middle of September, some Edge users cannot download Excel files.
In that case, it turned out that it worked as follows.

 

1) to 4) are the same as above.
5b) Another browser (that is not user's) requests "/document/one_time_unique_key/some.xlsx".
6b) "/document/one_time_unique_key/some.xlsx" responses status 404. Because the file is already removed in 4.
7b) user's browser requests "/document/one_time_unique_key/some.xlsx" again.
8b) "/document/one_time_unique_key/some.xlsx" responses status 404. Because the file is already removed in 4.
9b) user's browser cannot download the file. It says that file is not found. Since 8b is 404.

 

In 5b, remote address is not user's address. According to whois, these address owner is Microsoft (!).
And User-Agent is Edg/89.0.774.48 in 5b.
User's User-Agent is Edg/93.* or Edg/94.*.

 

I want to stop user's Edge requesting "/document/*" twice.
Do you know why Microsoft requesting to my server?
Do you know why user's Edge requesting twice?

 

Please help.

3 Replies
We are currently facing the same problem with our webservice.
It also only affects Edge users trying to download excel data.
We can retrace a second request by a microsoft address which leads to the problem described by @Koji_Noritake - the initial user cannot download the excel data.
Our users are encouraged to use another browser until we have a solution.
Please have a look at this problem

@MarieHebel @Koji_Noritake Hi!  Have you tried to reach out to Support?   https://microsoftedgesupport.microsoft.com/hc/en-us  They should be able to help investigate your specific case.  Thanks! 

 

-Kelly

@MarieHebel
I found the solution. The following setting should be turned off.
edge://settings/downloads -> 'Open Office files in the browser'
2nd and 3rd request will not come.
I do not know which version has the setting first...

But I think Edge should use 1st response content to 'Open Office files in the browser'.