Custom Protocol Handler in PDFs

%3CLINGO-SUB%20id%3D%22lingo-sub-1186598%22%20slang%3D%22en-US%22%3ECustom%20Protocol%20Handler%20in%20PDFs%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1186598%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20a%20document%20management%20system%20that%20is%20registered%20as%20a%20custom%20protocol%20handler%20with%20Windows%20and%20can%20open%20specific%20documents%20by%20using%20a%20syntax%20similar%20to%20the%20following%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ecustomprotocol%3A%2F%2F3d6022460ff74d1ea09d82acd141436b%2F%3Ftenant%3Dexample%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20works%20perfectly%20throughout%20the%20OS%20and%20also%20in%20HTML%20pages%20in%20Edge.%20Unfortunately%20I%20can't%20get%20it%20to%20work%20within%20PDFs%20in%20the%20Edge%20PDF%20viewer.%20Edge%20just%20seems%20to%20ignore%20the%20click%20and%20nothing%20happens.%20Opening%20the%20link%20in%20the%20same%20PDF%20from%20within%20Adobe%20Reader%20works%20as%20expected.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20this%20a%20known%20limitation%20or%20is%20there%20a%20setting%20somewhere%20I%20need%20to%20turn%20on%20for%20this%20to%20work%3F%20It%20worked%20fine%20in%20the%20old%20Edge%2C%20so%20for%20our%20users%20it%20looks%20like%20a%20regression.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETested%20on%20the%20latest%20Edge%20Stable%20version%20on%20Windows%2010%201909.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

We have a document management system that is registered as a custom protocol handler with Windows and can open specific documents by using a syntax similar to the following:

 

customprotocol://3d6022460ff74d1ea09d82acd141436b/?tenant=example

 

This works perfectly throughout the OS and also in HTML pages in Edge. Unfortunately I can't get it to work within PDFs in the Edge PDF viewer. Edge just seems to ignore the click and nothing happens. Opening the link in the same PDF from within Adobe Reader works as expected.

 

Is this a known limitation or is there a setting somewhere I need to turn on for this to work? It worked fine in the old Edge, so for our users it looks like a regression.

 

Tested on the latest Edge Stable version on Windows 10 1909.

0 Replies