Bug: Edge v104.0.1293.54 always unable to start after own update on v103.0.1264.77 (Stable)

Occasional Contributor

Hello all,

 

3 days ago my client still running Edge Enterprise v103.0.1264.77 (Stable) received via MicrosoftEdgeUpdate.exe (v1.3.165.21 updated manually by me to avoid unexpected effects, if also interested to know why please see this my past reference) current v104.0.1293.54 and this happened 6 days after it had received previous v104.0.1293.47 (so 9 days ago).

Unfortunately after I was unable to complete a proper manual Edge restart after receiving v104.0.1293.47, I was also unable to complete same expected Edge manually assisted restart after receiving v104.0.1293.54 and so, as it always also happened in past similar occurrences, I saw v104.0.1293.54 setup being completed only when I 1st ran Edge again on 8/15.

Big problem is that since then v104.0.1293.54 has never properly completed own startup that was also expected to recover last opened 2 opened sessions I had before (more opened tabs in each one).

So far I've tried to restart it 4 times in total and each time Edge hung with own single window still opened and only creates a single .dmp inside C:\Users\<myAlias>\AppData\Local\Microsoft\Edge\User Data\Crashpad\reports but with no real evidence that it also succeeded in reporting that .dmp via network (until now I've determined that this very likely happened properly, when, also probably due to own size, last created dump file has a .edmp extension).

Now after quite a lot of investigations and my need to temporarily switch back to Firefox Portable (now at current v103.0.2) I've already found that my best option is to rollback (=downgrade) to previous v103.0.1264.77, since last one that ran properly and I've already configured Edge proper policies to possibly ensure that next self run of MicrosoftEdgeUpdateTaskMachineCore will revert to it (I also already got its MicrosoftEdgeEnterpriseX64.msi for it but for now & other reasons I'm unsure I'll be able to use it properly).

But ITMT may someone (unsure about @mkruger or @Kelly_Y) be so kind to please be able to tell me if I might have any other way to manually report those same dump files to Edge Dev so they can ensure to definitely fix issue and also avoid it again in future ?

P.S. So far I'm avoiding to attach same dumps here since also I'm assuming it might not be best thing to do.

 

Thanks for attention.

Best Regards

Rob

5 Replies

@SwimmeRM Hello - Yes, you are correct it is best not to post the dumps here because the files might have personal information.  In this case, you can either submit feedback through the browser 

("..." menu > Help and feedback > Send feedback) or you can reach out to Support 

https://developer.microsoft.com/en-us/microsoft-edge/support/.  Thanks! 

 

-Kelly

@Kelly_Y  maybe you missed main point that so far my Edge is not starting at all because it's still v104.0.1293.54. In few minutes 2nd MicrosoftEdgeUpdate self scheduled instance (the one called MicrosoftEdgeUpdateTaskMachineCore) should run so I should see if 2nd self rollback method described by Andy Zeigler in his Ignite September 2020 video and based on executing v103.0.1264.77 setup via standard MicrosoftEdgeUpdate.exe updates while proper policy settings are also enabled might work correctly in my situation even if my test client is not in a domain.

Otherwise I'll have to fix it by manually running MicrosoftEdgeEnterpriseX64.msi v103.0.1264.77 using 'msiexec /I FileName.msi /qn ALLOWDOWNGRADE=1' syntax and so far I'm not yet sure it might work immediately since lately my client experienced difficulties to install 64bit .msi programs only with Windows Installer (always failing) while 32bit .msi programs indeed always installed fine.
P.S. About your reference to that Dev support area could you be more specific ?

I mean were you considering 'Microsoft Q&A' side or just the 'Insider Program' side where it also says 'Get help, including email support, for the Microsoft Edge Insider Channels.' ?

Thanks in advance.

@Kelly_Y  Hello again,

1st of all apologies for so much delay occurred before this additional reply of mine (due to some unexpected OS freezes).

Even if I still haven't received any further reply to my latest post P.S. questions (About your reference to that Dev support area could you be more specific ? I mean were you considering 'Microsoft Q&A' side or just the 'Insider Program' side where it also says 'Get help, including email support, for the Microsoft Edge Insider Channels.' ?) at least now I'm again able to provide you (and possibly others interested too) that I would still like to receive, I can now update you again about my previously anticipated tests and my current status.

- About using 2nd self rollback method described by Andy Zeigler in his Ignite September 2020 video based on executing v103.0.1264.77 setup via standard MicrosoftEdgeUpdate.exe updates while all properly required Edge policy settings were also enabled: only after I manually enabled all 3 required  Edge v103.0.1264.77 policy settings I also discovered that same method could not have worked because my client was not inside a Domain (evidence of this was inside C:\ProgramData\Microsoft\EdgeUpdate\Log\MicrosoftEdgeUpdate.log where I also found this explanation ... [ConfigManager::LoadGroupPolicies][Machine is not Enterprise Managed]...). Due to this I also assumed that I would have likely needed to try to 'simulate' somehow being inside a Domain by only using OS group policies, but then I also figured out I could have not really been sure that doing so was indeed possible :-(( ;

- About manually running MicrosoftEdgeEnterpriseX64.msi v103.0.1264.77 using 'msiexec /I FileName.msi /qn ALLOWDOWNGRADE=1' syntax: I foud not enough spare time to try to ensure to definitely fix my client difficulties to install 64bit .msi programs only with Windows Installer (always failing) while 32bit .msi programs indeed always installed fine;

- About my current browser status: when on Tue 16th August I created this post I was forced to use latest Firefox Portable (v103.0.2.8255) but after some other unexpected OS freeze experienced while it was still running, on Sat 20th afternoon I found I could no more use it properly because of a weird error still unsolved ('Your Firefox profile cannot be loaded. It may be missing or inaccessible') even when starting it while also specifying its '-safe-mode' switch. Anyway same day in the evening I also discovered by chance that at least while in InPrivate mode, an Edge v104.0.1293.54 window could be opened properly (this happened after an IE11 InPrivate session, run with Admin privileges, displaying an embedded Youtube video on a local web site was redirected to another separate Youtube hosted site video that opened an Edge window using a very specific command line syntax I'm only partially logging here: "C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" --from-ie-to-edge=1 --inprivate ...). Then on Mon 22nd evening my client also received latest (& current) Edge v104.0.1293.63 and finally only today I could find enough spare time to repro same situation again always starting from an IE11 InPrivate session run with Admin privileges. So, after I displayed another embedded Youtube video, at the end I choose to see another one and again this opened a separate new Edge v104.0.1293.63 InPrivate mode window, once again using a very specific command line syntax that this time I can nearly fully log here (I'm just excluding involved Youtube video because it was not in English: "C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" --from-ie-to-edge=1 --inprivate --customer-type=1 --enable-features --disable-features --flag-switches-begin --flag-switches-end --do-not-de-elevate https://www.youtube.com/watch?v=<removed_since_NotInEnglish>&feature=emb_rel_end), and while that window was opened I also verified I could properly run Edge via its Quick launch application bar icon I manually created after dragging 1st Edge v92.0.902.73 self created icon from Start (menu) -> All programs (just for the records this is what it always runs '"C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" --profile-directory=Default') , and this also allowed Edge v104.0.1293.63 (Enterprise) to recover those same 2 standard Edge windows that were still opened while Edge v103.0.1264.77 (Stable) was still running before an unexpected OS freeze.

 

At this point here are my new questions to you (unless someone else might like to jump to reply and maybe add even more details) :

- Is what I experienced, I mean Edge v104.0.1293.54 or v104.0.1293.63 only starting properly while in InPrivate mode because of a very specific command line syntax execution, something that had to be expected because Edge was not yet really switched to be OS default browser ?

- Is there already any known reference documentation (i.e. maybe on MS Docs, rather than inside 1 or more MS Support KB articles) that can also confirm all valid command line options available for Edge and/or Edge Enterprise ?

P.S. Just to confirm that now I've been able to report all older dumps created by Edge v104.0.1293.54 via Edge Feedback opened from same 1st Edge v104.0.1293.63 InPrivate mode window opened yesterday.

ITMT I also :

- checked that so far no known MS Support KB article exists to confirm MS Edge all known or most likely used command line switches (so far I searched starting from 'Microsoft Edge help & learning' page <https://support.microsoft.com/en-us/microsoft-edge?ui=en-US&rs=en-US&ad=US>),

- tried to expand my investigation through bing to also look for "--from-ie-to-edge=1" switch usage but I still have to fully check results,

- can confirm you I received latest v104.0.1293.70 but I still have to manually restart Edge via its UI to complete its update.

 

Thanks in advance for any next reply.

Best Regards

@Kelly_Y (and others) Hello again,

 

once again I'm sorry for so much delay occurred before adding this reply (this time less dued to unexpected OS freezes) and if so far this topic has become a little too much TL;DR for you all (but I always try to summarize all as much as I can).

Fact is that after I tried to restart Edge after its v104.0.1293.70 update it continued to always hang at startup, and this also happened with v105.0.1343.27 that followed after 1 more week, thus also preventing me to access my mailbox on Outlook.com or add more here.

Fortunately enough, 1 more week later, and only after I received v105.0.1343.33 that I'm still using, I was able to verify that an Edge InPrivate session could start without hanging, but again that only happened after I had used an IE11 InPrivate session (started as Admin) to view a YouTube embedded video from a local web site page, and after its end I selected another video from video index shown.

That indeed finally started an Edge InPrivate window using following command line (but this time I'm leaving referenced YouTube video even if not in English, "C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" --from-ie-to-edge=1 --inprivate --customer-type=1 --flag-switches-begin --flag-switches-end --do-not-de-elevate https://www.youtube.com/watch?v=IdhK3jtBQOY&feature=emb_rel_end) and at its startup I was also warned that an extension ('Clipboard Helper' if I'm recalling correctly) was self disabled (and also self removed even if I was not confirmed) because containing malware so I decided to additionally report about that via a checkbox that Edge proposed me.

After that I also verified I could again properly restart the 2 Edge standard window sessions I typically use and then also reported all that happened via 'Edge feedback'.

FYI ITMT I also received more Edge updates, v105.0.1343.42 (last week) and v105.0.1343.50 (right before I started writing this post) and I also strongly hope when I'll have enough spare time to let Edge finish all its Self-Update actions and self restart as usual it will have no more issues.

But anyway, unfortunately due to lack of a published known list of Edge valid command line switches available, I still won't be able to know if there's any specific switch I can use to be sure that Edge can always continue to start reliably as it did until v103.0.1264.77 (included).

And because of this I'll only have to continue to start it using same old default one I manually copied from one of earlier versions update I received (so again '"C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" --profile-directory=Default').

P.S. Please could you @Kelly_Y or anyone else be so very kind to try to also answer all my previous questions from past reply I added before this one?

TIA

 

Best Regards

Rob

 

 

@SwimmeRM Hello!  Unfortunately, I do not think the command line options are documented.  Eric Lawrence, Principal PM has written an article about it here: Edge Command Line Arguments – text/plain (textslashplain.com)

 

-Kelly