Azure AD sign-in stopped working / conditional access with Edge Insider


I have v80 in dev channel, it used to work, but sometimes before v79 it stopped to work.

I have a profile "Work" i have logged in with my organizational / Azure AD account for profile, all sync is on and working.


However, when I want to login to I am denied access due to Azure AD conditional policies. (It works from Internet Explorer or (old) Edge)


It seems that Edge Insider stopped reading info from my device (AAD registerd device / MDM Intune, compliance status) and this info is not passed for login to Office 365 and other services.

I have tried to delete profile folder and recreate it, but the same issue.
Any idea, or how to troubleshoot in more detail from Edge Insider browser side? Any workaround?


Thank you,

Kind regards

6 Replies


If you can please answer these questions, it would be very helpful for us to troubleshoot.

  1. When you login to on your work profile, do you have to enter your credentials manually or are you being signed in automatically? 
  2. When Conditional Access is blocking your access, do you see a page similar to the one in the screenshot at the link below?  Any screenshots you could attach of the error message/page would be very helpful!
  3. Does this issue occur on the latest Canary channel build?

Thank you for your time!


I have latest dev channel, not using canary. It used to work, but in past 2+ months it stopped.
When try to login, example to, it asks for username/password. Normally it should auto login or show under account "Connected to Windows" which is not showing in Edge Insider (old Edge is working normally.)
Yes, according to docs, this is message/screenshot I get.
So somehow it is not detecting credentials from my Windows 10 OS (including Intune compliance etc.) .


@Naren- Ok, I have tried several devices, everywhere when I login to AAD profile, it shows my profile on as Connected to Windows. Except on my only / first device. So I do not know where is the error nor how to recreate "work" profile and re-login again so it is working with my Win10 OS login to MS O365 services..

@hkusulja Are you signed into this Edge on this device where you're not getting automatically signed in? You can check by looking at the menu here. 


best response confirmed by hkusulja (MVP)

@Avi Vaid Yes, of course, Edge Insider, dev channel, Work profile, signed in with AAD account which is in sync. But when login to it does not see from my Win10 this.. The issue is only on one computer, uninstall/reinstall Edge insider does not resolve issue. In test VM and on other computers with same users it works normally. :\ Must be something inside particular Edge profile issue, but could not find what.
I have now deleted whole %localappdata%\Microsoft\Edge Dev\User Data folder, and then opened Edge and created new profiles / and work profile is now working so issue is resolved. To bad, There is no sync about apps and history yet, this is another topic.