AutoImportAtFirstRun policy no longer imports favorites

Iron Contributor

Has anyone else noticed that the "Automatically import another browser's data and settings at first run" policy has stopped working in Edge Dev Version 80.0.361.9? I tried it in Canary 81.0.375.0 and got the same result. However, it works fine in the Beta build 79.0.309.56. 


I have my policy set to automatically import settings from Internet Explorer. On first run, the favorites import dialog is skipped but the browser doesn't import favorites. I tried configuring this in the registry and with group policy and got the same result on two different machines. 


Favorites location has not been redirected on either machine. 






34 Replies







Just tested the new Beta 81.0.416.28. And yes finaly it worked. A few seconds after the first start with a new profile "AutoImportAtFirstRun" at least did what it should do and all my favorites from IE11 are imported automatically.


Maybe you should test and confirm this for your environments



hope my information and our telco helped to fix this.



We are still testing the fixes but yes, this specific issue which was impacting some of you, should now be resolved. Do try the latest Canary.

@Joachim_T and @dkirchberger you information was indeed very helpful in finding and fixing this issue,


Thank you! Looks good in my test environment!


@rishavsharan in light of the changes to the release cycle due to COVID-19: will we see these fixes for stable in 83 or perhaps in 80? 

@Miha Pecnik 

i guess It comes with 81. Chromium M81 stable is now announced for 7.4.2020 i would guess a few days later there will be an edge V81 with the fix

@Joachim_T  thank you very much, I'll definitely test with v81, which is less then a week away.

Thanks @Joachim_T 


@Miha Pecnik 

It is indeed coming in E81 which should be out in a couple of weeks.



Version 86.0.622.69 (Official build) (64-bit) still not work with favorites



We've been testing in our environment, and it this doesn't seem to be working again. We tried version 87.0.664.55 x64.

@Allan Raymond 



We kept digging and figure out our mistake. The short story is built right into the name of the policy. If folks have run Edge before, this won't import favorites. We've found deleting %localappdata%\Microsoft\Edge\User Data\First Run causes the first run experience to trigger again.


Sorry for the confusion. We have a group looking to set Edge as the preferred default and are trying to make that transition as smooth as possible.


Good luck!


Hi there. We are using Version 99.0.1150.39 64Bit, with current ADMX Templates, and the Settings "

Automatically imports all supported datatypes and settings from Google Chrome

" is still not working.  I am talking about the specific setting above, not manual imports! Any News on this issue, it's very important feature for our RDS-Environments. I don't know when (which version) it stopped working. Thank you


We are deploying Edge for Business within our organisation and have found an issue whereby since the upgrade to v97 (and the subsequent change to the First Run Experience), the AutoImportAtFirstRun policy doesn't work. I have rolled the browser back to v96 and the policy works again.

I have tested this in Beta 99 and Dev 100 and this issue is still present. The import will work manually, it's just not happening during the First Run experience for new users.

I have removed the %localappdata%\Microsoft\Edge folder each time I downgraded to fully test the first run experience again, and as mentioned, it does seem to be an issue with Edge v97 and above.

Thanks, Tom.

@Tomr96 Thank you for your confirmation. Any other sources where these issues are tracked or anything from Microsoft about this?

Nothing that I'm aware of - I'm going to post on Reddit.

@Tomr96 @AjAl79 Hello!  It looks like you are running into the same issue that has been reported here: Re: AutoImportAtFirstRun policy not working since v97.0.1072.69 - Microsoft Tech Community


I believe MS Edge Canary Channel versions 101.0.1204.0+ should have a fix.  Please test and let us know if you are still reproducing the issue.  Thanks!