Allow sites to be reloaded in Internet Explorer mode Greyed Out

Copper Contributor

We have installed Edge 85.0.564.44 (Official build(64-bit) and are attempting to do testing with IE Compatibility mode. The option appears, but is greyed out. I have also got Dev and Canary installed, the option is greyed out there as well. 

28 Replies



I am in the same boat.  I have configured compatability mode in GPO as well.

@animejay @Springer84 Hello!  I've reached out to our IE Mode team.  Specifically for Enterprises, IE Mode is configured by IT Admins.  ( 


You mentioned you were doing some testing, have you checked out the InternetExplorerIntegrationTestingAllowed policy? 



Note: It is available on Windows since Version 86 or later





I have the same problem. And can't switch it on. Stuck in the wrong place.

There are no Edge GPO settings in place.


Note that both options under "Internet Explorer compatibility" are greyed out.

I do have IE GPO settings in place, but there are no Edge GPO settings used yet. (edge://policy is empty)

And install was deployed via SCCM - Edge node - stable version - updates disabled. (In case it matters)

Someone else with problem here: 

@Kelly_Y The policy you mentioned "InternetExplorerIntegrationTestingAllowed" did put the option to reload the site in internet explorer mode in the More Tools menu. The other options in Default Settings are still greyed out. I will note that I had a couple members of my team check their home computers (not on company domain) with Edge 85, and some are greyed out and some are not. 

@Springer84 In order to test IE mode, the policy that Kelly pointed you to is the right one to use.

The settings under Internet Explorer compatibility are meant for non-managed devices and are intentionally greyed out on managed devices, so it checks out that your users are seeing it on their home devices. We understand that having them greyed out is confusing when there is no policy backing up the setting and we're working on hiding those options when they are not meant to be actionable.

Thanks for reaching out and please let us know if you have further questions!

@Shilpa_SubramanianThis answer is not good at all.   And I feel that that can not be the right answer.
Why would Microsoft be trying to stop corporate computers from being able to use those functions.

Microsoft, please please please remove the blocks that is stopping corporate computers from using the Internet Explorer compatibility settings in Edge. Your answer makes no sense that Microsoft would be doing this.

Can you please provide more info on what is happening here?

@Mike_Bound @Shilpa_Subramanian I agree, I have spot checked several people, managed or unmanaged devices, some are greyed out, some are not. 


@Mike_Bound to clarify, we are working on a policy for the first setting to "Let Internet Explorer open sites in Microsoft Edge". Until the policy is available, this setting will be hidden so as to not cause confusion.


For the second setting - "Allow sites to be loaded in Internet Explorer mode", corporate devices can already use this feature using group policies available. For more information, see

@Springer84 For managed devices, the setting should be greyed out. For unmanaged devices, the setting should be actionable. If you are seeing the opposite behavior, please let us know and we can investigate what is happening.


Can you please point me at the documentation from Microsoft that talks about why the "Internet Explorer compatibility" settings are greyed out and not available for managed devices?

It is baffling to understand why Microsoft would intentionally stop IE compatibility for Edge to managed devices, but allow for un-managed devices.   There has got to be more to this?

Corporate environment is where IE compatibility will be needed the most.



I've already read through before reaching out.

Note that I already have GPO setting "Configure Internet Explorer integration" set to 1 which is "Internet Explorer mode". Still the 2nd option under "Internet Explorer compatibility" is still in the off position and the 1st option is "never".

It is the current stable version 85 I'm using.

Web page above says version 77 and above.

Am also well use to Site compatibility lists and have them in place since IE11 came out and for use with Edge legacy.

If "Configure Internet Explorer integration" is the right answer, then something doesn't work.

Further so issue is clear:

1) There is no menu option under more tools to open the current site in IE mode.

2) There is no blue "e" icon at the start of the web address on any page that might be showing in IE mode. Or any other indication that a page is showing in IE mode.

Both of these things aren't happening with GPO setting "Configure Internet Explorer integration" turned on.

@Mike_Bound ABSOLUTELY! same problem here, I have scrupulously followed the setting up of the GPO in every detail and I still get the option greyed out and it's still not working on Edge ... a real beginner's job, I have to ask users to wait...


To enable "Allow sites to be reloaded in Internet Explorer mode" on managed devices (version 86 and above), either

  • enable it in GPO settings under "Administrative Templates/Microsoft Edge/Allow Internet Explorer mode testing"
  • or go to registry "HKEY LOCAL MACHINE\SOFTWARE\Policies\Microsoft\Edge" and create a REG-DWORD with the name "InternetExplorerIntegrationTestingAllowed" and set its value to 0x00000001

After a log-off the option to open sites in IE Mode is available in the menu under "More tools", although it's still greyed out on the settings page. 

Afaik the background behind is that MS assumes that organizations with managed devices don't want to allow users to open any site in IE Mode due to security reasons and therefore control the access via IE site lists. 


Organizations with managed devices would use group policy to set these sort of settings the way they want it. And doing so should be shown in Edge's settings. The same as all the other settings are done.

It is not understood why Microsoft would treat this bit any different to any other setting?

Note a key point to your answer about InternetExplorerIntegrationTestingAllowed is that it requires version 86, which is not yet the stable released version.

I think I'll just need to wait for stable 86 to drop, then try this stuff again.

Dropping version 85, with greyed out settings that you can't seem to do anything with, is frustrating without some sort of release notes or KB explaining what is going on.


@Shilpa_Subramanian hi,

To summarize:
- I use for the test .admx files from 2020-09-09 (stable version)
- I use on the client computer the Edge version 87.0.637.0
I have activated the 2 policies necessary to activate IE mode for certain industrial sites of our company:
- Configure Internet Explorer intégration
- Configure the Enterprise Mode Site List

Below the test Site List:
<site-list version="3">
<date-created>09/18/2020 15:15:48</date-created>
<site url="">
<open-in app="true" allow-redirect="false">MSEdge</open-in>

The problem still persists, Edge does not open the defined site from the list ( in IE mode... However in this Edge version I can force the opening in IE mode from "more tools".
But that doesn't interest me, I do not want to impose a procedure on our users, I want it to be done automatically. Logical...

Will this issue be solved?


As weird as it may sounds, but you have to chose "IE11" instead of "MSEdge" for the <open-in> tag in your sitelist.xml to get it to work with Edge IE Mode Integration. 

See documentation (under no. 5):


Also select "IE8Enterprise" for <compat-mode>, this did the trick for us on some pages not loading correctly. 

So your Site List should look like this


<open-in app="true" allow-redirect="false">IE11</open-in>



Hope this helps, works on our clients flawlessly since months.



Thank you for the help!

But it's still the same result...





Yes! Now it works like a charm with your suggestion :

<open-in allow-redirect="false" app="true">IE11</open-in>


Many thanks!