About the UserAgent sent when switching the Internet Explorer mode(Microsoft Edge 96)

New Contributor

Dear Microsoft Edge Team, Hello.


After updating Microsoft Edge 96, the UserAgent sent when switching Internet Explorer mode is the same as Microsoft Edge.
Is this behavior a specification?


The UserAgent sent when switching the Internet Explorer mode

  • Before updating Microsoft Edge 96
    • Mozilla/5.0 (Windows NT 6.3; Trident/7.0; rv 11.0) like Gecko
  • After updating Microosft Edge 96
    • Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.55 Safari/537.36 Edg/96.0.1054.41


If this behavior is a specification, I would like to know how to send an UserAgent of Internet Explorer 11 when switching between Internet Explorer modes.

4 Replies
best response confirmed by Taichi_Motoki (New Contributor)

@Taichi_Motoki Hi!  Do you know if refreshing the page fixes the issue and the expected UA String is sent?  


The team is tracking an issue starting in v96 involving IE mode and the wrong UA String.  It appears the introduction of the InternetExplorerIntegrationComplexNavDataTypes policy might be a factor.  One work around suggested is disabling the InternetExplorerIntegrationComplexNavDataTypes policy (set to 0).  If this is the same issue you are experiencing, we can keep you updated regarding the fix.  I believe the most recent Canary Channel build released today might already have the fix.  


If you have a separate/different issue, I think it might be best to reach out to Support.  They should be able to gather logs and help investigate your specific case.  Thanks! 




Hello, Kelly. Thank you for your reply!


I installed the most recent Canary Channel build(v98.0.1097.0) and confirmed the operation.

And, I confirmed that this issue has been solved!


So, I think this issue will be solved by updating to Edge Stable Channel build v98.


Thank you for teaching me about Canary Channel build!!



@Taichi_Motoki Hi!  I believe our developers were working to backport the fix, I think it might be included in the most recent Stable Build ( released today in case you want to give it a try.  Thanks!




Hi, Kelly.


I confirmed that Microsoft Edge Stabel Build 96.0.1054.53 solves the issue.

I appreciate you sharing this information.