Champion Management Platform Install problem

Brass Contributor

I'm having a strange issue installing the Champion Management Platform app. I downloaded the package from the repository and uploaded it into SharePoint according to the directions. The global admin approved the API requests and everything is visible in SharePoint. I pushed the app to Teams, and I can see it listed in the Teams admin center, but the icon is showing a broken image link, and I'm not seeing it when I try to add the app to a Team or as a personal app on the sidebar.


I got it working fine in my personal test tenant, but I've tried deleting everything 4 times now and everytime I upload the package and push it out to Teams I get the same broken image icon and it's not working. Our VP of digital innovation is heavily pushing the Champions program so this NEEDS to work. Has anyone else run into this that can shed some light on what the issue might be? I figured I'd ask before opening a support ticket.

3 Replies

@CooperAdmin Hi there! One quick thing, when reinstalling we need to also make sure the site is removed from the deleted items container in SharePoint. So - if you've redeployed a few times and removed the sites from active - please remove also from deleted sites (action would be to do another deployment, this time deleting the initial creation from active sites AND from deleted sites).


The other step - please ensure the permissions are granted on the SharePoint site post deployment. Sometimes if those aren't setup right you can see odd behaviors from the app. (Step 8 discusses that part)


If any other questions or help needed, please feel free to reach out here where our devs monitor the issues queue -> 


Let us know how it goes!



I made sure to empty the recycle bin. I tried getting it up and running over the weekend. I could never get farther than the point where it should have been available in Teams to add, but it never actually showed up in the list of available apps. I could see it in the Teams admin center, and push it out to a team from there, but opening up that team to assign the app to a channel it was nowhere to be found.
The global admin was able to get it up and running with whatever magic he possesses. I'm still not sure what he could have done differently that I wasn't doing or able to do. He said he allowed it as a custom Teams app (which I thought I had tried), and the reason the icons were broken was because our admin accounts don't have licenses - though he did not elaborate on that.
Ok, gotcha! Glad it's enabled now and available! If there is a policy to approve custom apps - the Champion Management Platform would be considered that and have to be approved from that area.

Hope the platform helps with your Champion program!