Wrong news language

Copper Contributor

Today my default MSN news page in Edge Chromium opens with news from India instead of US. Everything from news to movies is India and Bollywood. Why? Going to Personalize, it shows I have selected 'US news' and News and Cars and Weather.  Any idea why?

11 Replies
Are you located in India?
your VPN/proxy using Indian IP?
I think he is referring to the news page that is on the default new tab page in Edge insider. you know, that small button at the bottom of the new tab page


It is indeed the edge://newtab page

I am not located in India, or using a VPN. I am actaully located in the Netherlands. But just trying to find out the URL, it brings me now to the correct MSN page again. Somehow it got it wrong this morning. Thanks


Well there isn't much settings in newtab page but you can try heading over to https://www.msn.com/en-us/settings
and see if everything is alright in there.
if you change anything in there, try restarting your browser to look for any changes in newtab page.

if that doesn't fix it, try clearing your browser data from the Edge insider settings:
(select the first 4 checkboxes from the top)
then restart the browser and check newtab page again.

hope that helps :)

@Ben Geerdes 


Does anything on that page say MSN?


Mine says My Feed .......... Powered by Microsoft News.

Mine is coming up localized to my city. I tried it on Edge Canary, Old Edge, and Chromium a few times and it was fine. I'm kind of clueless why that's happening to you. That usually happens when you're using an IP that's been redirected or VPN or Tor Browswer. Try it again especially after rebooting your computer and/or system. Also as HotCakeX said to clear out your entire browser history/data than reboot it all and see what happens.

Hi@Ben Geerdes 


Now added the ability to change the location for news content on the new tab page in Version 81.0.387.0

More info:


Problem is that the whole menu is in Thai. I can't believe that MS have not fixed all the language problems yet. Store is same. Just bought Amazon prime, but had to cancel it because everything in the MS store that I need to use Prime, is in Thai.

My settings is:
English (United States)
Offer to translate pages that aren't in a language I read

Check spelling
Enable spellcheck
English (United States), English

English (United States)


Customize spell check

In other words none of this seems to work at all. So I just wonder, if MS can't make their browser work, why force it on my PC?

Now I just want to get rid of it all together, and Amazon needs to offer another way to use their services.
Make sure Window settings and languages are correct too, as well as language in your Microsoft account.
if you want to see only English and you are from Thailand, then set everything to English.
that will work.
No I'm not from Thailand, and I'm not Thai. I also does not understand Thai.
EVERYTHING is set to ENGLISH, EVERYWHERE, On ALL devices I have. I do not
even use my own Language, Norwegian, and have not had Norwegian on
any OS, or even Windows 98. So no, you are wrong. Problem is that I have
reported this countless time over many many years, and MS developers
are just like you, confident that there myst be something wrong with the