SOLVED

Windows Integrated Authentication - Dialog box prompt for credentials is the wrong one!

Highlighted
Frequent Contributor

One of the reasons why I decided to move my company to the new Edge instead of Chrome is how Chrome handles WIA for non-domain computers. 

 

The issue here is that in all versions prior to 80.0.331.0 when accessing our Intranet remotely, the prompt is like this:
 
 
clipboard_image_1.png
 
But in 80.0.331.0, we get the "other" prompt style:
 
clipboard_image_2.png

 

This one sucks because it does not work with password managers.

 
 
21 Replies
Highlighted
Highlighted

80.0.339.0 and still have this stupid credentials prompt to deal with...is this permanent? Geez, I hope not.

Highlighted

This is really a show stopper for us as well. People need to be able to copy&paste usernames/passwords from browser extension, but with this new credentials dialog you can no longer do that.

Highlighted
Best Response confirmed by Keith Davis (Frequent Contributor)
Solution

Good news @Keith Davis, this is due to "Allow Windows Credentials for HTTP Authentication Challenges" and if you disable it in Edge settings, it will revert to the previous login dialog.

So go to: edge://flags/#edge-windows-credentials-for-http-auth, and set it to Disabled.

 

 

Highlighted

@Jussi Palo 

 

You are awesome and that does work, but I wonder if we will be able to do that via GPO at some point.

Highlighted
Did some testing, and my best guess was that Enabling "authnegotiatedelegateallowlist" but leaving it blank or setting to some bogus value would affect this, but no. So apparentently not possible yet.
Highlighted
Looks like we're back to square one, edge://flags/#edge-windows-credentials-for-http-auth is gone in 84.0.495.2. Has anyone figured out way to revert to the old credentials dialog? Has GPO support been released for this?
Highlighted

@Jussi Palo 

 

Oh, that sucks. No, I don't know of another way.

Highlighted

@Jussi Palo 

 

Well this sucks big time. Are there any Microsoft employees here that can provide som answers?

Highlighted
0 replies from MS so far, tried different channels. Please also send Feedback via browser.
Highlighted

@Jussi Palo 

 

I sent the feedback through the browser now.

 

I actually sent an email to the regular consumer support as well and got a quick answer. But as soon as he understood that I am working for an enterprise he wanted me to open an enterprise support query and I don't have any support agreement so that is not an option.

Highlighted

@josh_bodner 

 

I saw that Josh are making the posts about the new releases so maybe he can bring us an answer?

Highlighted

@Avi Vaid should know if we're tracking this.  Also adding @fawkes for awareness.  

Highlighted
Thanks Josh

I hope we will get a solution to this problem as its kind of a deal breaker for using Edge on a daily basis.
Highlighted

Has anyone seen anything further on the ability to control this setting? We are eager to deploy but not without controlling the login experience for some legacy apps we have. Is there a registry entry even that can force this behavior?

Highlighted

@Ryan Fielding 

 

Nothing new here. I try to ping @Avi Vaid  and @fawkes  one more time and hope we get more lucky this time.

Highlighted

@Ryan Fielding 

 

That is great! The only problem with flags is that (as far as i know) it's not possible to control in any other way then configure them on the local computer. I Would love to see a GPO for this.

Highlighted

@Fredrik_Freden @Ryan Fielding Thanks for your patience and persistence on this. We're looking into this internally, and I will let you know if/when the Identity team has insights to share.

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge