Windows Integrated Authentication - Dialog box prompt for credentials is the wrong one!

Steel Contributor

One of the reasons why I decided to move my company to the new Edge instead of Chrome is how Chrome handles WIA for non-domain computers. 


The issue here is that in all versions prior to 80.0.331.0 when accessing our Intranet remotely, the prompt is like this:
But in 80.0.331.0, we get the "other" prompt style:


This one sucks because it does not work with password managers.

34 Replies

we are planning to migrate to edge and one of the challenge in our POC, we are not able to login into intranet sites without Dialog box prompt for credentials. we installed edge version is 81.0416.72. We don't have any issues with IE 11 and we are able to login without any dialog box prompt for credentials.

Do we have to change in server side or browser setting to work? please let me know if you have any resolution for this issue.


@Deleted any updates on this? Inability to control this setting via GPO or registry is preventing a migration of ~5000 clients towards Edge from Chrome.



Has there been an update on this?

@Ryan Fielding and @Keith Davis Thank you for the follow-up! I've brought this us again with our Identity team, and will hopefully have some insights for you soon.


Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge

Thanks fawkes - watching for updates :) Happy to talk to the teams directly if they need input on the justification and use cases.

@Ryan Fielding @Keith Davis I've been chatting with our Identity team, and while there isn't any conclusive news to share yet, I want to keep you updated in the interim. It sounds like the team has had to prioritize more urgent fixes and feature work, however, they do recognize the need and are actively looking into potential solutions.


Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge

@Deleted Hi Fawkes. It is hard for us to say anything about the way you prioritize things as we don't know what those things are. I just want you and the team to know that in my company this is by far the biggest issue regarding our new Autopilot deployment, and I think there must be a lot of enterprises that experience the same issue.

@Deleted No update it 2 months. Still an issue for us and no way to fix it except to manually configure every machine. :(

You will need to use the very cumbersome way of setting it in the Group Policies, the do work. Although they are reset every time new Windows 10 (now 11) build install, so I have given up on this on my local machine.

@Jussi Palo I've yet to ever see a setting in GP that addresses this, can you point me to it?

Apologies @Keith Davis, didn't have notifications enabled here so didn't notice your question until now. Wrote a blog article of this, as I kept forgetting how to do it:

Let me know if it works for you!

@Jussi Palo The GP setting worked. However, LastPass still can't fill it - maybe something wrong with LP, but that used to work. The built-in password mechanism in Edge worked though.