Weird Edge not responding and RAM eating behaviour

Highlighted
Contributor

Since I cannot recreate nor did I capture any screenshot of the happening, I can only describe the situation back then. I'm using Microsoft Edge Version 85.0.564.8 (Official build) dev (64-bit) as of writing. 

 

Just not long ago before this post, I opened four tabs just for roughly 10 minutes. First is YouTube live for a certain piano youtuber, second is a game forum, third is Bing search and fourth is an article about chrome feature.

 

Since my internet connection not so stable, I'm regularly check for live on YouTube live. From time to time when Windows 10 causes 100% hard drive usage spike for a while, then Microsoft Edge along with multiple programs will not responding for a while then back to normal. 

 

However this time is different, all programs back to normal but not Microsoft Edge. Microsoft Edge keep on not responding. I check Task Manager then found out Edge taking large amount of RAM at 2GB along with around 10% of CPU usage. When Edge respond for a while, I opened Browser task manager found out that YouTube page is taking up the majority of RAM at 1.something GB and the article about chrome keep on using the CPU. 

 

Microsoft Edge continues not responding after that and keep on eating my RAM that my RAM usage reached 90+% so I'm forced to kill it from Task Manager and restart it. After restart and restore the pages, Microsoft Edge is back to normal with no anomality at all. I can't recreate what happen back then. 

 

For your information about my PC specs:

Windows 10 Home version 1909 build 18363.959

Intel(R) Core(TM) i5-8300H CPU @ 2.30Hz

Memory 8GB RAM

1TB HDD + 230GB SSD

Intel(R) UHD Graphics 630

NVIDIA GeForce GTX 1050

1 Reply
Highlighted

FYI: I'm writing all these with the post restart Edge mentioned above.